aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/cannonkeys/ortho75
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/cannonkeys/ortho75')
-rw-r--r--keyboards/cannonkeys/ortho75/config.h8
-rw-r--r--keyboards/cannonkeys/ortho75/rules.mk1
2 files changed, 3 insertions, 6 deletions
diff --git a/keyboards/cannonkeys/ortho75/config.h b/keyboards/cannonkeys/ortho75/config.h
index 6e3651a83..8c1882e65 100644
--- a/keyboards/cannonkeys/ortho75/config.h
+++ b/keyboards/cannonkeys/ortho75/config.h
@@ -55,14 +55,10 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define LOCKING_RESYNC_ENABLE
#define RGBLIGHT_ANIMATIONS
-
-#define WS2812_LED_N 16
-#define RGBLED_NUM WS2812_LED_N
-#define PORT_WS2812 GPIOB
-#define PIN_WS2812 15
+#define RGB_DI_PIN B15
+#define RGBLED_NUM 16
#define WS2812_SPI SPID2
-
/*
* Feature disable options
* These options are also useful to firmware size reduction.
diff --git a/keyboards/cannonkeys/ortho75/rules.mk b/keyboards/cannonkeys/ortho75/rules.mk
index 8acb50d0c..fe9cec84c 100644
--- a/keyboards/cannonkeys/ortho75/rules.mk
+++ b/keyboards/cannonkeys/ortho75/rules.mk
@@ -22,6 +22,7 @@ SLEEP_LED_ENABLE = yes # Breathing sleep LED during USB suspend
NKRO_ENABLE = yes # USB Nkey Rollover
BACKLIGHT_ENABLE = yes
RGBLIGHT_ENABLE = yes
+WS2812_DRIVER = spi
ENCODER_ENABLE = yes
LAYOUTS = ortho_5x15