aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/clueboard/66_hotswap/prototype/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/clueboard/66_hotswap/prototype/rules.mk')
-rw-r--r--keyboards/clueboard/66_hotswap/prototype/rules.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/keyboards/clueboard/66_hotswap/prototype/rules.mk b/keyboards/clueboard/66_hotswap/prototype/rules.mk
new file mode 100644
index 000000000..887592b37
--- /dev/null
+++ b/keyboards/clueboard/66_hotswap/prototype/rules.mk
@@ -0,0 +1,24 @@
+EXTRAFLAGS += -flto
+LAYOUTS = 66_ansi
+MCU = atmega32u4
+F_CPU = 16000000
+ARCH = AVR8
+F_USB = $(F_CPU)
+OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
+OPT_DEFS += -DBOOTLOADER_SIZE=4096
+
+# Build Options
+# comment out to disable the options.
+#
+BACKLIGHT_ENABLE = yes
+BOOTMAGIC_ENABLE = no
+MOUSEKEY_ENABLE = no
+EXTRAKEY_ENABLE = yes
+CONSOLE_ENABLE = yes
+COMMAND_ENABLE = no
+NKRO_ENABLE = yes
+AUDIO_ENABLE = yes
+RGBLIGHT_ENABLE = yes
+MIDI_ENABLE = no
+UNICODE_ENABLE = no
+BLUETOOTH_ENABLE = no