aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ergodox_ez/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/ergodox_ez/rules.mk')
-rw-r--r--keyboards/ergodox_ez/rules.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/keyboards/ergodox_ez/rules.mk b/keyboards/ergodox_ez/rules.mk
index dbc35f683..fd8f5722d 100644
--- a/keyboards/ergodox_ez/rules.mk
+++ b/keyboards/ergodox_ez/rules.mk
@@ -31,11 +31,14 @@ SWAP_HANDS_ENABLE= yes # Allow swapping hands of keyboard
SLEEP_LED_ENABLE = no
API_SYSEX_ENABLE = no
RGBLIGHT_ENABLE = yes
+RGBLIGHT_CUSTOM_DRIVER = yes
+
RGB_MATRIX_ENABLE = no # enable later
DEBOUNCE_TYPE = eager_pr
# project specific files
-SRC += matrix.c
+SRC += matrix.c \
+ led_i2c.c
QUANTUM_LIB_SRC += i2c_master.c
LAYOUTS = ergodox