aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/gingham
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/gingham')
-rw-r--r--keyboards/gingham/readme.md7
-rw-r--r--keyboards/gingham/rules.mk4
2 files changed, 4 insertions, 7 deletions
diff --git a/keyboards/gingham/readme.md b/keyboards/gingham/readme.md
index 9893884e8..d0c3e6fad 100644
--- a/keyboards/gingham/readme.md
+++ b/keyboards/gingham/readme.md
@@ -9,11 +9,12 @@ Hardware Supported: ATMEGA328p with vusb [PCB](https://github.com/yiancar/gingha
Hardware Availability: https://yiancar-designs.com/, https://novelkeys.xyz, https://mechboards.co.uk/
Make example for this keyboard (after setting up your build environment):
+
make gingham:default
-Flash firmware:
- // In bootloader mode
- make gingham:default:program
+Flashing example for this keyboard:
+
+ make gingham:default:flash
Bootloader:
use usbasploader HSGW's my repository.
diff --git a/keyboards/gingham/rules.mk b/keyboards/gingham/rules.mk
index aa228c875..2ef090bd6 100644
--- a/keyboards/gingham/rules.mk
+++ b/keyboards/gingham/rules.mk
@@ -14,10 +14,6 @@ MCU = atmega328p
# ATmega328P USBasp
BOOTLOADER = USBasp
-# Flash program via avrdude, but default command is not suitable.
-# You can use plaid:default:program
-PROGRAM_CMD = avrdude -c usbasp -p m328p -U flash:w:$(BUILD_DIR)/$(TARGET).hex
-
# disable debug code
OPT_DEFS = -DDEBUG_LEVEL=0