aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/handwired/xeal60/keymaps/drashna_old
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/handwired/xeal60/keymaps/drashna_old')
-rw-r--r--keyboards/handwired/xeal60/keymaps/drashna_old/config.h86
-rw-r--r--keyboards/handwired/xeal60/keymaps/drashna_old/keymap.c1
-rw-r--r--keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk28
3 files changed, 0 insertions, 115 deletions
diff --git a/keyboards/handwired/xeal60/keymaps/drashna_old/config.h b/keyboards/handwired/xeal60/keymaps/drashna_old/config.h
deleted file mode 100644
index ddf9d1a40..000000000
--- a/keyboards/handwired/xeal60/keymaps/drashna_old/config.h
+++ /dev/null
@@ -1,86 +0,0 @@
-/*
-Copyright 2017 Danny Nguyen <danny@hexwire.com>
-
-This program is free software: you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation, either version 2 of the License, or
-(at your option) any later version.
-
-This program is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include QMK_KEYBOARD_CONFIG_H
-
-
-#ifdef RGBLIGHT_ENABLE
-#undef RGBLED_NUM
-#define RGBLIGHT_ANIMATIONS
-#define RGBLED_NUM 12
-#define RGBLIGHT_HUE_STEP 8
-#define RGBLIGHT_SAT_STEP 8
-#define RGBLIGHT_VAL_STEP 8
-#define RGBLIGHT_EFFECT_KNIGHT_LENGTH 2
-#define RGBLIGHT_EFFECT_SNAKE_LENGTH 2
-#define RGBLIGHT_EFFECT_BREATHE_CENTER 1
-#define RGBLIGHT_EFFECT_CHRISTMAS_INTERVAL 300
-#define RGBLIGHT_EFFECT_CHRISTMAS_STEP 1
-#endif // RGBLIGHT_ENABLE
-
-
-#undef LOCKING_SUPPORT_ENABLE
-#undef LOCKING_RESYNC_ENABLE
-
-#ifndef NO_DEBUG
-#define NO_DEBUG
-#endif // !NO_DEBUG
-#ifndef NO_PRINT
-#define NO_PRINT
-#endif // !NO_PRINT
-
-/* disable action features */
-//#define NO_ACTION_LAYER
-//#define NO_ACTION_TAPPING
-//#define NO_ACTION_ONESHOT
-//#define NO_ACTION_MACRO
-//#define NO_ACTION_FUNCTION
-
-#undef PRODUCT
-#define PRODUCT Drashnas Viterbi Macro Pad
-
-#define USE_I2C
-
-#ifdef AUDIO_ENABLE
-#define C6_AUDIO
-#define NO_MUSIC_MODE
-#endif
-
-#define LAYOUT_ortho_5x7( \
- L00, L01, L02, L03, L04, L05, L06, \
- L10, L11, L12, L13, L14, L15, L16, \
- L20, L21, L22, L23, L24, L25, L26, \
- L30, L31, L32, L33, L34, L35, L36, \
- L40, L41, L42, L43, L44, L45, L46 \
- ) \
- LAYOUT( \
- L00, L01, L02, L03, L04, L05, L06, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, \
- L10, L11, L12, L13, L14, L15, L16, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, \
- L20, L21, L22, L23, L24, L25, L26, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, \
- L30, L31, L32, L33, L34, L35, L36, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, \
- L40, L41, L42, L43, L44, L45, L46, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO \
- )
-
-#endif
-
-#define QMK_ESC_OUTPUT F5 // usually COL
-#define QMK_ESC_INPUT D4 // usually ROW
-#define QMK_LED B0
-#define QMK_SPEAKER C6
diff --git a/keyboards/handwired/xeal60/keymaps/drashna_old/keymap.c b/keyboards/handwired/xeal60/keymaps/drashna_old/keymap.c
deleted file mode 100644
index 2d361da9a..000000000
--- a/keyboards/handwired/xeal60/keymaps/drashna_old/keymap.c
+++ /dev/null
@@ -1 +0,0 @@
-//placeholder \ No newline at end of file
diff --git a/keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk b/keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk
deleted file mode 100644
index 14ac6a6b3..000000000
--- a/keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk
+++ /dev/null
@@ -1,28 +0,0 @@
-BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
-MOUSEKEY_ENABLE = no # Mouse keys(+4700)
-EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
-CONSOLE_ENABLE = no # Console for debug(+400)
-COMMAND_ENABLE = no # Commands for debug and configuration
-TAP_DANCE_ENABLE = no
-RGBLIGHT_ENABLE = yes
-AUDIO_ENABLE = yes
-NKRO_ENABLE = yes
-
-NO_SECRETS = yes
-MACROS_ENABLED = yes
-INDICATOR_LIGHTS = no
-RGBLIGHT_TWINKLE = no
-
-LAYOUTS = ortho_5x7
-
-# SRC := $(filter-out serial.c matrix.c i2c.c split_util.c,$(SRC))
-# SRC := $(filter-out serial.c,$(SRC))
-# SRC := $(filter-out matrix.c,$(SRC))
-# SRC := $(filter-out i2c.c,$(SRC))
-# SRC := $(filter-out split_util.c,$(SRC))
-# SRC += quantum/matrix.c
-
-USER_NAME := drashna
-SRC += ../drashna/keymap.c
-
-BOOTLOADER = qmk-dfu