aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/helix/rev2/keymaps/led_test
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/helix/rev2/keymaps/led_test')
-rw-r--r--keyboards/helix/rev2/keymaps/led_test/config.h15
-rw-r--r--keyboards/helix/rev2/keymaps/led_test/led_test_init.c4
-rw-r--r--keyboards/helix/rev2/keymaps/led_test/rules.mk4
3 files changed, 19 insertions, 4 deletions
diff --git a/keyboards/helix/rev2/keymaps/led_test/config.h b/keyboards/helix/rev2/keymaps/led_test/config.h
index 6da6849a1..e2bdf2f32 100644
--- a/keyboards/helix/rev2/keymaps/led_test/config.h
+++ b/keyboards/helix/rev2/keymaps/led_test/config.h
@@ -23,4 +23,19 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
// place overrides here
+// If you need more program area, try select and reduce rgblight modes to use.
+
+// Selection of RGBLIGHT MODE to use.
+#if defined(LED_ANIMATIONS)
+ //#define RGBLIGHT_EFFECT_BREATHING
+ //#define RGBLIGHT_EFFECT_RAINBOW_MOOD
+ //#define RGBLIGHT_EFFECT_RAINBOW_SWIRL
+ //#define RGBLIGHT_EFFECT_SNAKE
+ //#define RGBLIGHT_EFFECT_KNIGHT
+ //#define RGBLIGHT_EFFECT_CHRISTMAS
+ //#define RGBLIGHT_EFFECT_STATIC_GRADIENT
+ #define RGBLIGHT_EFFECT_RGB_TEST // led_test keymap need only this.
+ //#define RGBLIGHT_EFFECT_ALTERNATING
+#endif
+
#endif /* CONFIG_USER_H */
diff --git a/keyboards/helix/rev2/keymaps/led_test/led_test_init.c b/keyboards/helix/rev2/keymaps/led_test/led_test_init.c
index 1d9cb4ebd..85f5d1aa7 100644
--- a/keyboards/helix/rev2/keymaps/led_test/led_test_init.c
+++ b/keyboards/helix/rev2/keymaps/led_test/led_test_init.c
@@ -5,7 +5,7 @@ void led_test_init(void) {
static int scan_count = 0;
if( scan_count == 2 ) {
rgblight_enable_noeeprom();
- rgblight_mode_noeeprom(35);
+ rgblight_mode_noeeprom(RGBLIGHT_MODE_RGB_TEST);
}
if( scan_count < 3 ) scan_count ++;
}
@@ -15,6 +15,6 @@ void led_test_init(void) {
// can use this?
void startup_user(void) {
rgblight_enable_noeeprom();
- rgblight_mode_noeeprom(35);
+ rgblight_mode_noeeprom(RGBLIGHT_MODE_RGB_TEST);
}
#endif
diff --git a/keyboards/helix/rev2/keymaps/led_test/rules.mk b/keyboards/helix/rev2/keymaps/led_test/rules.mk
index c7ee75c36..a9cd251bc 100644
--- a/keyboards/helix/rev2/keymaps/led_test/rules.mk
+++ b/keyboards/helix/rev2/keymaps/led_test/rules.mk
@@ -14,7 +14,7 @@ MIDI_ENABLE = no # MIDI controls
AUDIO_ENABLE = no # Audio output on port C6
UNICODE_ENABLE = no # Unicode
BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
-RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight.
SWAP_HANDS_ENABLE = no # Enable one-hand typing
define HELIX_CUSTOMISE_MSG
@@ -100,7 +100,7 @@ ifeq ($(strip $(IOS_DEVICE_ENABLE)), yes)
endif
ifeq ($(strip $(LED_ANIMATIONS)), yes)
- OPT_DEFS += -DRGBLIGHT_ANIMATIONS
+ OPT_DEFS += -DLED_ANIMATIONS
endif
ifeq ($(strip $(OLED_ENABLE)), yes)