aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/keebio/bdn9
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/keebio/bdn9')
-rw-r--r--keyboards/keebio/bdn9/config.h2
-rw-r--r--keyboards/keebio/bdn9/keymaps/codecoffeecode/config.h12
-rw-r--r--keyboards/keebio/bdn9/keymaps/codecoffeecode/keymap.c57
-rw-r--r--keyboards/keebio/bdn9/keymaps/codecoffeecode/rules.mk2
-rw-r--r--keyboards/keebio/bdn9/rules.mk2
5 files changed, 73 insertions, 2 deletions
diff --git a/keyboards/keebio/bdn9/config.h b/keyboards/keebio/bdn9/config.h
index 641dc5736..40c8a1d77 100644
--- a/keyboards/keebio/bdn9/config.h
+++ b/keyboards/keebio/bdn9/config.h
@@ -64,4 +64,4 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
#define LOCKING_SUPPORT_ENABLE
/* Locking resynchronize hack */
-#define LOCKING_RESYNC_ENABLE
+#define LOCKING_RESYNC_ENABLE \ No newline at end of file
diff --git a/keyboards/keebio/bdn9/keymaps/codecoffeecode/config.h b/keyboards/keebio/bdn9/keymaps/codecoffeecode/config.h
new file mode 100644
index 000000000..5b8b369bc
--- /dev/null
+++ b/keyboards/keebio/bdn9/keymaps/codecoffeecode/config.h
@@ -0,0 +1,12 @@
+#pragma once
+
+/* For USB nonsense in various OSs */
+#define TAP_CODE_DELAY 10
+
+/* For constant mouse speed */
+#define MOUSEKEY_DELAY 300
+#define MOUSEKEY_INTERVAL 50
+#define MOUSEKEY_MAX_SPEED 1
+#define MOUSEKEY_TIME_TO_MAX 0
+#define MOUSEKEY_WHEEL_MAX_SPEED 1
+#define MOUSEKEY_WHEEL_TIME_TO_MAX 0
diff --git a/keyboards/keebio/bdn9/keymaps/codecoffeecode/keymap.c b/keyboards/keebio/bdn9/keymaps/codecoffeecode/keymap.c
new file mode 100644
index 000000000..9747dbf22
--- /dev/null
+++ b/keyboards/keebio/bdn9/keymaps/codecoffeecode/keymap.c
@@ -0,0 +1,57 @@
+/* Copyright 2019 Danny Nguyen <danny@keeb.io>
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ /*
+ | Knob 1: Scrl Dn/Up | | Knob 2: Vol Dn/Up |
+ | Press: Mute | Up | Press: Play/Pause |
+ | Left | Down | Right |
+ | Media Previous | MO(1)| Media Next |
+ */
+ [0] = LAYOUT(
+ KC_MUTE, KC_UP, KC_MPLY,
+ KC_LEFT, KC_DOWN, KC_RIGHT,
+ KC_MPRV, MO(1), KC_MNXT
+ ),
+ /*
+ | RESET | Home | Media Stop |
+ | | End | |
+ | CTRL_END | | CTRL_HOME |
+ */
+ [1] = LAYOUT(
+ RESET , KC_HOME, KC_STOP,
+ _______, KC_END, _______,
+ LCTL(KC_END), _______, LCTL(KC_HOME)
+ ),
+};
+
+void encoder_update_user(uint8_t index, bool clockwise) {
+ if (index == 0) {
+ if (clockwise) {
+ tap_code(KC_MS_WH_UP);
+ } else {
+ tap_code(KC_MS_WH_DOWN);
+ }
+ }
+ else if (index == 1) {
+ if (clockwise) {
+ tap_code(KC_VOLU);
+ } else {
+ tap_code(KC_VOLD);
+ }
+ }
+}
diff --git a/keyboards/keebio/bdn9/keymaps/codecoffeecode/rules.mk b/keyboards/keebio/bdn9/keymaps/codecoffeecode/rules.mk
new file mode 100644
index 000000000..e910b7bea
--- /dev/null
+++ b/keyboards/keebio/bdn9/keymaps/codecoffeecode/rules.mk
@@ -0,0 +1,2 @@
+MOUSEKEY_ENABLE = yes
+CTPC = yes \ No newline at end of file
diff --git a/keyboards/keebio/bdn9/rules.mk b/keyboards/keebio/bdn9/rules.mk
index 8b4bb334e..a54833407 100644
--- a/keyboards/keebio/bdn9/rules.mk
+++ b/keyboards/keebio/bdn9/rules.mk
@@ -31,4 +31,4 @@ BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
AUDIO_ENABLE = no # Audio output on port C6
FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
HD44780_ENABLE = no # Enable support for HD44780 based LCDs (+400)
-ENCODER_ENABLE = yes
+ENCODER_ENABLE = yes \ No newline at end of file