aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/keebio/chocopad
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/keebio/chocopad')
-rw-r--r--keyboards/keebio/chocopad/README.md14
-rw-r--r--keyboards/keebio/chocopad/chocopad.c1
-rw-r--r--keyboards/keebio/chocopad/chocopad.h29
-rw-r--r--keyboards/keebio/chocopad/config.h47
-rw-r--r--keyboards/keebio/chocopad/info.json12
-rw-r--r--keyboards/keebio/chocopad/keymaps/default/config.h6
-rw-r--r--keyboards/keebio/chocopad/keymaps/default/keymap.c28
-rw-r--r--keyboards/keebio/chocopad/keymaps/default/rules.mk2
-rw-r--r--keyboards/keebio/chocopad/keymaps/khord/config.h6
-rw-r--r--keyboards/keebio/chocopad/keymaps/khord/keymap.c104
-rw-r--r--keyboards/keebio/chocopad/keymaps/khord/rules.mk2
-rw-r--r--keyboards/keebio/chocopad/rules.mk58
12 files changed, 309 insertions, 0 deletions
diff --git a/keyboards/keebio/chocopad/README.md b/keyboards/keebio/chocopad/README.md
new file mode 100644
index 000000000..3cdb3b3b9
--- /dev/null
+++ b/keyboards/keebio/chocopad/README.md
@@ -0,0 +1,14 @@
+Chocopad
+========
+
+A 4x4 macropad keyboard using Kailh PG1350 Lower Profile Choc switches.
+
+Keyboard Maintainer: Keebio
+Hardware Supported: Chocopad PCB, Arduino Pro Micro
+Hardware Availability: [Keebio](https://keeb.io)
+
+Make example for this keyboard (after setting up your build environment):
+
+ make keebio/chocopad:default
+
+See [build environment setup](https://docs.qmk.fm/#/getting_started_build_tools) then the [make instructions](https://docs.qmk.fm/#/getting_started_make_guide) for more information.
diff --git a/keyboards/keebio/chocopad/chocopad.c b/keyboards/keebio/chocopad/chocopad.c
new file mode 100644
index 000000000..f54753af5
--- /dev/null
+++ b/keyboards/keebio/chocopad/chocopad.c
@@ -0,0 +1 @@
+#include "chocopad.h"
diff --git a/keyboards/keebio/chocopad/chocopad.h b/keyboards/keebio/chocopad/chocopad.h
new file mode 100644
index 000000000..d37aefc57
--- /dev/null
+++ b/keyboards/keebio/chocopad/chocopad.h
@@ -0,0 +1,29 @@
+#pragma once
+
+#include "quantum.h"
+
+#define LAYOUT_ortho_4x4( \
+ A1, A2, A3, A4, \
+ B1, B2, B3, B4, \
+ C1, C2, C3, C4, \
+ D1, D2, D3, D4 \
+) { \
+ { A1, A2, A3, A4 }, \
+ { B1, B2, B3, B4 }, \
+ { C1, C2, C3, C4 }, \
+ { D1, D2, D3, D4 } \
+}
+
+// Used to create a keymap using only KC_ prefixed keys
+#define LAYOUT_kc( \
+ A1, A2, A3, A4, \
+ B1, B2, B3, B4, \
+ C1, C2, C3, C4, \
+ D1, D2, D3, D4 \
+) \
+ LAYOUT_ortho_4x4( \
+ KC_##A1, KC_##A2, KC_##A3, KC_##A4, \
+ KC_##B1, KC_##B2, KC_##B3, KC_##B4, \
+ KC_##C1, KC_##C2, KC_##C3, KC_##C4, \
+ KC_##D1, KC_##D2, KC_##D3, KC_##D4 \
+ )
diff --git a/keyboards/keebio/chocopad/config.h b/keyboards/keebio/chocopad/config.h
new file mode 100644
index 000000000..fb00ae70a
--- /dev/null
+++ b/keyboards/keebio/chocopad/config.h
@@ -0,0 +1,47 @@
+#ifndef CONFIG_H
+#define CONFIG_H
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xCB10
+#define PRODUCT_ID 0x1144
+#define DEVICE_VER 0x0100
+#define MANUFACTURER Keebio
+#define PRODUCT Chocopad
+#define DESCRIPTION 4x4 macropad using Kailh Choc low-profile switches
+
+/* key matrix size */
+#define MATRIX_ROWS 4
+#define MATRIX_COLS 4
+
+/* key matrix pins */
+#define MATRIX_ROW_PINS { D7, E6, B3, B2 }
+#define MATRIX_COL_PINS { D2, D4, F6, F5 }
+
+/* COL2ROW or ROW2COL */
+#define DIODE_DIRECTION COL2ROW
+
+/* number of backlight levels */
+#define BACKLIGHT_PIN B5
+#define BACKLIGHT_LEVELS 6
+
+/* Set 0 if debouncing isn't needed */
+#define DEBOUNCING_DELAY 5
+
+/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
+#define LOCKING_SUPPORT_ENABLE
+
+/* Locking resynchronize hack */
+#define LOCKING_RESYNC_ENABLE
+
+#ifdef RGB_DI_PIN
+#define RGBLIGHT_ANIMATIONS
+#define RGBLIGHT_HUE_STEP 8
+#define RGBLIGHT_SAT_STEP 8
+#define RGBLIGHT_VAL_STEP 8
+#endif
+#define RGB_DI_PIN D3
+#define RGBLED_NUM 4
+
+#endif
diff --git a/keyboards/keebio/chocopad/info.json b/keyboards/keebio/chocopad/info.json
new file mode 100644
index 000000000..c5a7d42bb
--- /dev/null
+++ b/keyboards/keebio/chocopad/info.json
@@ -0,0 +1,12 @@
+{
+ "keyboard_name": "Chocopad",
+ "url": "",
+ "maintainer": "qmk",
+ "width": 4,
+ "height": 4,
+ "layouts": {
+ "LAYOUT_ortho_4x4": {
+ "layout": [{"x":0, "y":0}, {"x":1, "y":0}, {"x":2, "y":0}, {"x":3, "y":0}, {"x":0, "y":1}, {"x":1, "y":1}, {"x":2, "y":1}, {"x":3, "y":1}, {"x":0, "y":2}, {"x":1, "y":2}, {"x":2, "y":2}, {"x":3, "y":2}, {"x":0, "y":3}, {"x":1, "y":3}, {"x":2, "y":3}, {"x":3, "y":3}]
+ }
+ }
+}
diff --git a/keyboards/keebio/chocopad/keymaps/default/config.h b/keyboards/keebio/chocopad/keymaps/default/config.h
new file mode 100644
index 000000000..7fa3bf328
--- /dev/null
+++ b/keyboards/keebio/chocopad/keymaps/default/config.h
@@ -0,0 +1,6 @@
+#ifndef CONFIG_USER_H
+#define CONFIG_USER_H
+
+#include "../../config.h"
+
+#endif
diff --git a/keyboards/keebio/chocopad/keymaps/default/keymap.c b/keyboards/keebio/chocopad/keymaps/default/keymap.c
new file mode 100644
index 000000000..7b4b752c9
--- /dev/null
+++ b/keyboards/keebio/chocopad/keymaps/default/keymap.c
@@ -0,0 +1,28 @@
+#include QMK_KEYBOARD_H
+
+#define _BASE 0
+#define _FN1 1
+#define _FN2 2
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+
+ [_BASE] = LAYOUT_ortho_4x4(
+ KC_PGUP, KC_HOME, KC_UP, KC_END , \
+ KC_PGDN, KC_LEFT, KC_DOWN, KC_RGHT, \
+ MO(_FN2), KC_VOLU, KC_MPLY, KC_MPRV, \
+ MO(_FN1), KC_VOLD, KC_MUTE, KC_MNXT \
+ ),
+ [_FN1] = LAYOUT_ortho_4x4(
+ KC_ESC, KC_P7, KC_P8, KC_P9, \
+ KC_TAB, KC_P4, KC_P5, KC_P6, \
+ KC_ENT, KC_P1, KC_P2, KC_P3, \
+ _______, KC_P0, KC_P0, KC_DOT \
+ ),
+ [_FN2] = LAYOUT_ortho_4x4(
+ RGB_TOG, RGB_HUI, RGB_SAI, RGB_VAI, \
+ RGB_MOD, RGB_HUD, RGB_SAD, RGB_VAD, \
+ _______, _______, _______, RESET, \
+ BL_STEP, _______, _______, _______ \
+ )
+
+};
diff --git a/keyboards/keebio/chocopad/keymaps/default/rules.mk b/keyboards/keebio/chocopad/keymaps/default/rules.mk
new file mode 100644
index 000000000..a81250cdf
--- /dev/null
+++ b/keyboards/keebio/chocopad/keymaps/default/rules.mk
@@ -0,0 +1,2 @@
+RGBLIGHT_ENABLE = yes
+
diff --git a/keyboards/keebio/chocopad/keymaps/khord/config.h b/keyboards/keebio/chocopad/keymaps/khord/config.h
new file mode 100644
index 000000000..7fa3bf328
--- /dev/null
+++ b/keyboards/keebio/chocopad/keymaps/khord/config.h
@@ -0,0 +1,6 @@
+#ifndef CONFIG_USER_H
+#define CONFIG_USER_H
+
+#include "../../config.h"
+
+#endif
diff --git a/keyboards/keebio/chocopad/keymaps/khord/keymap.c b/keyboards/keebio/chocopad/keymaps/khord/keymap.c
new file mode 100644
index 000000000..2c871c4e8
--- /dev/null
+++ b/keyboards/keebio/chocopad/keymaps/khord/keymap.c
@@ -0,0 +1,104 @@
+#include "chocopad.h"
+
+#define _BASE 0
+#define _FN1 1
+#define _FN2 2
+
+// Fillers to make layering more clear
+#define KC_ KC_TRNS
+#define KC_XX KC_NO
+
+#define KC_L1 LT(1, KC_P0)
+#define KC_L2 LT(2, KC_SPC)
+#define KC_RST RESET
+#define KC_BSTP BL_STEP
+#define KC_RTOG RGB_TOG
+#define KC_RMOD RGB_MOD
+#define KC_RHUI RGB_HUI
+#define KC_RHUD RGB_HUD
+#define KC_RSAI RGB_SAI
+#define KC_RSAD RGB_SAD
+#define KC_RVAI RGB_VAI
+#define KC_RVAD RGB_VAD
+#define KC_MAC1 ADMIN
+#define KC_MAC2 SMSPC
+#define KC_M192 M192
+#define KC_M255 M255
+
+enum custom_keycodes {
+ NUMPAD = SAFE_RANGE,
+ ADMIN,
+ SMSPC,
+ M192,
+ M255
+};
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+
+ [_BASE] = LAYOUT_kc(
+ //,----+----+----+----.
+ P7 , P8 , P9 ,BSPC,
+ //|----+----+----+----|
+ P4 , P5 , P6 ,TAB ,
+ //|----+----+----+----|
+ P1 , P2 , P3 ,PENT,
+ //|----+----+----+----|
+ L1 , L2 ,PDOT,PSLS
+ //`----+----+----+----'
+ ),
+
+ [_FN1] = LAYOUT_kc(
+ //,----+----+----+----.
+ ESC ,MAC1,MAC2,DEL ,
+ //|----+----+----+----|
+ LEFT,DOWN, UP ,RGHT,
+ //|----+----+----+----|
+ M192,M255, XX , XX ,
+ //|----+----+----+----|
+ , XX , , XX
+ //`----+----+----+----'
+ ),
+
+ [_FN2] = LAYOUT_kc(
+ //,----+----+----+----.
+ RST , XX , XX , XX ,
+ //|----+----+----+----|
+ RTOG,RHUI,RSAI,RVAI,
+ //|----+----+----+----|
+ RMOD,RHUD,RSAD,RVAD,
+ //|----+----+----+----|
+ BSTP, , XX , XX
+ //`----+----+----+----'
+ )
+
+};
+
+bool process_record_user(uint16_t keycode, keyrecord_t *record) {
+ switch (keycode) {
+ case ADMIN:
+ if (record->event.pressed) {
+ SEND_STRING("Administrator");
+ }
+ return false;
+ break;
+ case SMSPC:
+ if (record->event.pressed) {
+ SEND_STRING("Simspace1!");
+ }
+ return false;
+ break;
+ case M192:
+ if (record->event.pressed) {
+ SEND_STRING("192.168.");
+ }
+ return false;
+ break;
+ case M255:
+ if (record->event.pressed) {
+ SEND_STRING("255");
+ }
+ return false;
+ break;
+ }
+ return true;
+};
diff --git a/keyboards/keebio/chocopad/keymaps/khord/rules.mk b/keyboards/keebio/chocopad/keymaps/khord/rules.mk
new file mode 100644
index 000000000..a81250cdf
--- /dev/null
+++ b/keyboards/keebio/chocopad/keymaps/khord/rules.mk
@@ -0,0 +1,2 @@
+RGBLIGHT_ENABLE = yes
+
diff --git a/keyboards/keebio/chocopad/rules.mk b/keyboards/keebio/chocopad/rules.mk
new file mode 100644
index 000000000..39ce38e10
--- /dev/null
+++ b/keyboards/keebio/chocopad/rules.mk
@@ -0,0 +1,58 @@
+# MCU name
+MCU = atmega32u4
+
+# Processor frequency.
+# This will define a symbol, F_CPU, in all source code files equal to the
+# processor frequency in Hz. You can then use this symbol in your source code to
+# calculate timings. Do NOT tack on a 'UL' at the end, this will be done
+# automatically to create a 32-bit value in your source code.
+#
+# This will be an integer division of F_USB below, as it is sourced by
+# F_USB after it has run through any CPU prescalers. Note that this value
+# does not *change* the processor frequency - it should merely be updated to
+# reflect the processor speed set externally so that the code can use accurate
+# software delays.
+F_CPU = 16000000
+
+#
+# LUFA specific
+#
+# Target architecture (see library "Board Types" documentation).
+ARCH = AVR8
+
+# Input clock frequency.
+# This will define a symbol, F_USB, in all source code files equal to the
+# input clock frequency (before any prescaling is performed) in Hz. This value may
+# differ from F_CPU if prescaling is used on the latter, and is required as the
+# raw input clock is fed directly to the PLL sections of the AVR for high speed
+# clock generation for the USB and other AVR subsections. Do NOT tack on a 'UL'
+# at the end, this will be done automatically to create a 32-bit value in your
+# source code.
+#
+# If no clock division is performed on the input clock inside the AVR (via the
+# CPU clock adjust registers or the clock division fuses), this will be equal to F_CPU.
+F_USB = $(F_CPU)
+
+# Interrupt driven control endpoint task(+60)
+OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
+
+
+# Boot Section Size in *bytes*
+OPT_DEFS += -DBOOTLOADER_SIZE=4096
+
+
+# Build Options
+# comment out to disable the options.
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = no # Commands for debug and configuration
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
+AUDIO_ENABLE = no
+RGBLIGHT_ENABLE = yes
+
+LAYOUTS = ortho_4x4