aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/kingly_keys/little_foot
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/kingly_keys/little_foot')
-rw-r--r--keyboards/kingly_keys/little_foot/config.h58
-rw-r--r--keyboards/kingly_keys/little_foot/info.json16
-rw-r--r--keyboards/kingly_keys/little_foot/keymaps/default/keymap.c40
-rw-r--r--keyboards/kingly_keys/little_foot/little_foot.c1
-rw-r--r--keyboards/kingly_keys/little_foot/little_foot.h35
-rw-r--r--keyboards/kingly_keys/little_foot/readme.md17
-rw-r--r--keyboards/kingly_keys/little_foot/rules.mk25
7 files changed, 192 insertions, 0 deletions
diff --git a/keyboards/kingly_keys/little_foot/config.h b/keyboards/kingly_keys/little_foot/config.h
new file mode 100644
index 000000000..e0bd0daf9
--- /dev/null
+++ b/keyboards/kingly_keys/little_foot/config.h
@@ -0,0 +1,58 @@
+/* Copyright 2019 Garret G. (TheRoyalSweatshirt)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.#pragma once
+ */
+
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xFEED
+#define PRODUCT_ID 0x6060
+#define DEVICE_VER 0x0001
+#define MANUFACTURER Kingly-Keys
+#define PRODUCT The Little Foot
+#define DESCRIPTION A Mighty Small, 45-Percent, Ortholinear Keyboard.
+
+/* key matrix size */
+#define MATRIX_ROWS 5
+#define MATRIX_COLS 10
+
+/* key matrix pins */
+#define MATRIX_ROW_PINS { F6, B6, B2, B3, B1 }
+#define MATRIX_COL_PINS { F5, F7, B5, B4, E6, D7, C6, D4, D0, D1 }
+#define UNUSED_PINS
+
+/* COL2ROW or ROW2COL */
+#define DIODE_DIRECTION COL2ROW
+
+/* Set 0 if debouncing isn't needed */
+#define DEBOUNCE 5
+#define FORCE_NKRO
+
+/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
+#define LOCKING_SUPPORT_ENABLE
+
+/* Locking resynchronize hack */
+#define LOCKING_RESYNC_ENABLE
+
+/* ws2812 RGB LED */
+#define RGB_DI_PIN F4
+#define RGBLED_NUM 10 // Number of LEDs
+
+#define RGBLIGHT_ANIMATIONS
+#define RGBLIGHT_HUE_STEP 6
+#define RGBLIGHT_SAT_STEP 4
+#define RGBLIGHT_VAL_STEP 8
diff --git a/keyboards/kingly_keys/little_foot/info.json b/keyboards/kingly_keys/little_foot/info.json
new file mode 100644
index 000000000..6a8d50894
--- /dev/null
+++ b/keyboards/kingly_keys/little_foot/info.json
@@ -0,0 +1,16 @@
+{
+ "keyboard_name": "Little Foot",
+ "url": "",
+ "maintainer": "TheRoyalSweatshirt",
+ "width": 10,
+ "height": 5,
+ "layouts": {
+ "LAYOUT_split_space_base": {
+ "key_count": 44,
+ "layout": [{"x":0, "y":0}, {"x":1, "y":0}, {"x":2, "y":0}, {"x":3, "y":0}, {"x":4, "y":0}, {"x":5, "y":0}, {"x":6, "y":0}, {"x":7, "y":0}, {"x":8, "y":0}, {"x":9, "y":0}, {"x":0, "y":1}, {"x":1, "y":1}, {"x":2, "y":1}, {"x":3, "y":1}, {"x":4, "y":1}, {"x":5, "y":1}, {"x":6, "y":1}, {"x":7, "y":1}, {"x":8, "y":1}, {"x":9, "y":1}, {"x":0, "y":2}, {"x":1, "y":2}, {"x":2, "y":2}, {"x":3, "y":2}, {"x":4, "y":2}, {"x":5, "y":2}, {"x":6, "y":2}, {"x":7, "y":2}, {"x":8, "y":2}, {"x":9, "y":2}, {"x":0, "y":3}, {"x":1, "y":3}, {"x":2, "y":3}, {"x":3, "y":3}, {"x":4, "y":3}, {"x":5, "y":3}, {"x":6, "y":3}, {"x":7, "y":3}, {"x":8, "y":3}, {"x":9, "y":3}, {"x":1.5, "y":4, "w":1.5}, {"x":3, "y":4, "w":2}, {"x":5, "y":4, "w":2}, {"x":7, "y":4, "w":1.5}]
+ },
+ "LAYOUT_big_space_base": {
+ "key_count": 41,
+ "layout": [{"x":0, "y":0}, {"x":1, "y":0}, {"x":2, "y":0}, {"x":3, "y":0}, {"x":4, "y":0}, {"x":5, "y":0}, {"x":6, "y":0}, {"x":7, "y":0}, {"x":8, "y":0}, {"x":9, "y":0}, {"x":0, "y":1}, {"x":1, "y":1}, {"x":2, "y":1}, {"x":3, "y":1}, {"x":4, "y":1}, {"x":5, "y":1}, {"x":6, "y":1}, {"x":7, "y":1}, {"x":8, "y":1}, {"x":9, "y":1}, {"x":0, "y":2}, {"x":1, "y":2}, {"x":2, "y":2}, {"x":3, "y":2}, {"x":4, "y":2}, {"x":5, "y":2}, {"x":6, "y":2}, {"x":7, "y":2}, {"x":8, "y":2}, {"x":9, "y":2}, {"x":0, "y":3}, {"x":1, "y":3}, {"x":2, "y":3}, {"x":3, "y":3}, {"x":4, "y":3}, {"x":5, "y":3}, {"x":6, "y":3}, {"x":7, "y":3}, {"x":8, "y":3}, {"x":9, "y":3}, {"x":1.5, "y":4, "w":7}]
+ }
+}
diff --git a/keyboards/kingly_keys/little_foot/keymaps/default/keymap.c b/keyboards/kingly_keys/little_foot/keymaps/default/keymap.c
new file mode 100644
index 000000000..e85e0d6c4
--- /dev/null
+++ b/keyboards/kingly_keys/little_foot/keymaps/default/keymap.c
@@ -0,0 +1,40 @@
+
+#include QMK_KEYBOARD_H
+
+// Layer names
+enum{
+ // - Base layer:
+ _BASE,
+ // - Symbols, numbers, and functions:
+ _FN,
+ // - Alternate Function layer:
+ _LN
+};
+
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+
+ [_BASE] = LAYOUT_split_space_base(
+ KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0,
+ KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P,
+ KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_SCLN,
+ KC_Z, KC_X, KC_C, KC_V, KC_B, KC_N, KC_M, KC_COMM, KC_DOT, KC_ENT,
+ MO(_FN), KC_LSHIFT, KC_SPACE, RGB_MOD
+ ),
+
+ [_FN] = LAYOUT_split_space_base(
+ LT(_LN, KC_ESC), KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_MINS, KC_BSPC,
+ KC_TAB, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, LSFT(KC_MINS), KC_BSLS,
+ KC_LSFT, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_LBRC, KC_RBRC, KC_QUOT,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, RESET, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_LALT, KC_TRNS, KC_LCTRL
+ ),
+
+ [_LN] = LAYOUT_split_space_base(
+ KC_TRNS, KC_F1, KC_F2, KC_F3, KC_TRNS, KC_TRNS, KC_TRNS, KC_7, KC_8, KC_9,
+ KC_TRNS, KC_F4, KC_F5, KC_F6, KC_TRNS, KC_TRNS, KC_TRNS, KC_4, KC_5, KC_6,
+ KC_TRNS, KC_F7, KC_F8, KC_F9, KC_TRNS, KC_TRNS, KC_TRNS, KC_1, KC_2, KC_3,
+ KC_TRNS, KC_F10, KC_F11, KC_F12, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_0, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS
+ )
+};
diff --git a/keyboards/kingly_keys/little_foot/little_foot.c b/keyboards/kingly_keys/little_foot/little_foot.c
new file mode 100644
index 000000000..5513b113a
--- /dev/null
+++ b/keyboards/kingly_keys/little_foot/little_foot.c
@@ -0,0 +1 @@
+#include "little_foot.h"
diff --git a/keyboards/kingly_keys/little_foot/little_foot.h b/keyboards/kingly_keys/little_foot/little_foot.h
new file mode 100644
index 000000000..860eaeb8f
--- /dev/null
+++ b/keyboards/kingly_keys/little_foot/little_foot.h
@@ -0,0 +1,35 @@
+#pragma once
+
+#include "quantum.h"
+
+#define XXX KC_NO
+
+#define LAYOUT_split_space_base( \
+ k01, k02, k03, k04, k05, k06, k07, k08, k09, k010, \
+ k11, k12, k13, k14, k15, k16, k17, k18, k19, k110, \
+ k21, k22, k23, k24, k25, k26, k27, k28, k29, k210, \
+ k31, k32, k33, k34, k35, k36, k37, k38, k39, k310, \
+ k42, k46, k47, k49 \
+) \
+{ \
+ { k01, k02, k03, k04, k05, k06, k07, k08, k09, k010 }, \
+ { k11, k12, k13, k14, k15, k16, k17, k18, k19, k110 }, \
+ { k21, k22, k23, k24, k25, k26, k27, k28, k29, k210 }, \
+ { k31, k32, k33, k34, k35, k36, k37, k38, k39, k310 }, \
+ { XXX, k42, XXX, XXX, XXX, k46, k47, XXX, k49, XXX } \
+}
+
+#define LAYOUT_big_space_base( \
+ k01, k02, k03, k04, k05, k06, k07, k08, k09, k010, \
+ k11, k12, k13, k14, k15, k16, k17, k18, k19, k110, \
+ k21, k22, k23, k24, k25, k26, k27, k28, k29, k210, \
+ k31, k32, k33, k34, k35, k36, k37, k38, k39, k310, \
+ k46 \
+) \
+{ \
+ { k01, k02, k03, k04, k05, k06, k07, k08, k09, k010 }, \
+ { k11, k12, k13, k14, k15, k16, k17, k18, k19, k110 }, \
+ { k21, k22, k23, k24, k25, k26, k27, k28, k29, k210 }, \
+ { k31, k32, k33, k34, k35, k36, k37, k38, k39, k310 }, \
+ { XXX, k42, XXX, XXX, XXX, k46, XXX, XXX, k49, XXX } \
+}
diff --git a/keyboards/kingly_keys/little_foot/readme.md b/keyboards/kingly_keys/little_foot/readme.md
new file mode 100644
index 000000000..1052952cd
--- /dev/null
+++ b/keyboards/kingly_keys/little_foot/readme.md
@@ -0,0 +1,17 @@
+# Little Foot
+
+![Little_Foot](https://i.imgur.com/M0Usdtg.jpg)
+===
+
+A mighty small keyboard.
+
+Keyboard Maintainer: Garret G. - a.k.a. [The_Royal](https://www.reddit.com/user/The_Royal/) on Reddit, and [TheRoyalSweatshirt](https://github.com/TheRoyalSweatshirt) on GitHub
+Hardware Supported: Little_Foot Rev1.2 & Rev1.4, Pro-Micro, and Elite-C
+Hardware Availability: Through GB or Direct Message
+
+Make example for this keyboard (after setting up your build environment):
+
+ make kingly_keys/little_foot:default
+
+See the [build environment setup](https://docs.qmk.fm/#/getting_started_build_tools) and the [make instructions](https://docs.qmk.fm/#/getting_started_make_guide) for more information. Brand new to QMK? Start with our [Complete Newbs Guide](https://docs.qmk.fm/#/newbs).
+
diff --git a/keyboards/kingly_keys/little_foot/rules.mk b/keyboards/kingly_keys/little_foot/rules.mk
new file mode 100644
index 000000000..0c3011db9
--- /dev/null
+++ b/keyboards/kingly_keys/little_foot/rules.mk
@@ -0,0 +1,25 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# atmega32a bootloadHID
+BOOTLOADER = caterina
+
+# Build Options
+# comment out to disable the options.
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = no # Commands for debug and configuration
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+AUDIO_ENABLE = no
+RGBLIGHT_ENABLE = yes