aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/lets-split
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/lets-split')
-rw-r--r--keyboards/lets-split/Makefile73
-rw-r--r--keyboards/lets-split/config.h87
-rw-r--r--keyboards/lets-split/keymaps/default/keymap.c42
-rw-r--r--keyboards/lets-split/lets-split.c48
-rw-r--r--keyboards/lets-split/lets-split.h4
-rw-r--r--keyboards/lets-split/readme.md0
6 files changed, 0 insertions, 254 deletions
diff --git a/keyboards/lets-split/Makefile b/keyboards/lets-split/Makefile
deleted file mode 100644
index 247f978f0..000000000
--- a/keyboards/lets-split/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-
-
-# MCU name
-#MCU = at90usb1287
-MCU = atmega32u4
-
-# Processor frequency.
-# This will define a symbol, F_CPU, in all source code files equal to the
-# processor frequency in Hz. You can then use this symbol in your source code to
-# calculate timings. Do NOT tack on a 'UL' at the end, this will be done
-# automatically to create a 32-bit value in your source code.
-#
-# This will be an integer division of F_USB below, as it is sourced by
-# F_USB after it has run through any CPU prescalers. Note that this value
-# does not *change* the processor frequency - it should merely be updated to
-# reflect the processor speed set externally so that the code can use accurate
-# software delays.
-F_CPU = 16000000
-
-#
-# LUFA specific
-#
-# Target architecture (see library "Board Types" documentation).
-ARCH = AVR8
-
-# Input clock frequency.
-# This will define a symbol, F_USB, in all source code files equal to the
-# input clock frequency (before any prescaling is performed) in Hz. This value may
-# differ from F_CPU if prescaling is used on the latter, and is required as the
-# raw input clock is fed directly to the PLL sections of the AVR for high speed
-# clock generation for the USB and other AVR subsections. Do NOT tack on a 'UL'
-# at the end, this will be done automatically to create a 32-bit value in your
-# source code.
-#
-# If no clock division is performed on the input clock inside the AVR (via the
-# CPU clock adjust registers or the clock division fuses), this will be equal to F_CPU.
-F_USB = $(F_CPU)
-
-# Interrupt driven control endpoint task(+60)
-OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
-
-
-# Boot Section Size in *bytes*
-# Teensy halfKay 512
-# Teensy++ halfKay 1024
-# Atmel DFU loader 4096
-# LUFA bootloader 4096
-# USBaspLoader 2048
-OPT_DEFS += -DBOOTLOADER_SIZE=4096
-
-# Build Options
-# change to "no" to disable the options, or define them in the Makefile in
-# the appropriate keymap folder that will get included automatically
-#
-BOOTMAGIC_ENABLE ?= no # Virtual DIP switch configuration(+1000)
-MOUSEKEY_ENABLE ?= yes # Mouse keys(+4700)
-EXTRAKEY_ENABLE ?= yes # Audio control and System control(+450)
-CONSOLE_ENABLE ?= no # Console for debug(+400)
-COMMAND_ENABLE ?= yes # Commands for debug and configuration
-NKRO_ENABLE ?= no # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-BACKLIGHT_ENABLE ?= no # Enable keyboard backlight functionality
-MIDI_ENABLE ?= no # MIDI controls
-AUDIO_ENABLE ?= yes # Audio output on port C6
-UNICODE_ENABLE ?= no # Unicode
-BLUETOOTH_ENABLE ?= no # Enable Bluetooth with the Adafruit EZ-Key HID
-RGBLIGHT_ENABLE ?= no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
-
-# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
-SLEEP_LED_ENABLE ?= no # Breathing sleep LED during USB suspend
-
-ifndef QUANTUM_DIR
- include ../../Makefile
-endif \ No newline at end of file
diff --git a/keyboards/lets-split/config.h b/keyboards/lets-split/config.h
deleted file mode 100644
index 5b464147d..000000000
--- a/keyboards/lets-split/config.h
+++ /dev/null
@@ -1,87 +0,0 @@
-/*
-Copyright 2012 Jun Wako <wakojun@gmail.com>
-
-This program is free software: you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation, either version 2 of the License, or
-(at your option) any later version.
-
-This program is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-#ifndef CONFIG_H
-#define CONFIG_H
-
-#include "config_common.h"
-
-/* USB Device descriptor parameter */
-#define VENDOR_ID 0xFEED
-#define PRODUCT_ID 0x3060
-#define DEVICE_VER 0x0001
-#define MANUFACTURER Wootpatoot
-#define PRODUCT Lets Split
-#define DESCRIPTION A split keyboard for the cheap makers
-
-/* key matrix size */
-#define MATRIX_ROWS 4
-#define MATRIX_COLS 6
-
-#define MATRIX_ROW_PINS { B5, B4, E6, D7, }
-#define MATRIX_COL_PINS { F4, F5, F6, F7, B1, B3 }
-
-/* COL2ROW or ROW2COL */
-#define DIODE_DIRECTION COL2ROW
-
-/* define if matrix has ghost */
-//#define MATRIX_HAS_GHOST
-
-/* number of backlight levels */
-#define BACKLIGHT_LEVELS 3
-
-/* Set 0 if debouncing isn't needed */
-#define DEBOUNCING_DELAY 5
-
-/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
-#define LOCKING_SUPPORT_ENABLE
-/* Locking resynchronize hack */
-#define LOCKING_RESYNC_ENABLE
-
-/* key combination for command */
-#define IS_COMMAND() ( \
- keyboard_report->mods == (MOD_BIT(KC_LSHIFT) | MOD_BIT(KC_RSHIFT)) \
-)
-
-/* ws2812 RGB LED */
-#define ws2812_PORTREG PORTD
-#define ws2812_DDRREG DDRD
-#define ws2812_pin PD1
-#define RGBLED_NUM 28 // Number of LEDs
-#define RGBLIGHT_HUE_STEP 10
-#define RGBLIGHT_SAT_STEP 17
-#define RGBLIGHT_VAL_STEP 17
-
-/*
- * Feature disable options
- * These options are also useful to firmware size reduction.
- */
-
-/* disable debug print */
-// #define NO_DEBUG
-
-/* disable print */
-// #define NO_PRINT
-
-/* disable action features */
-//#define NO_ACTION_LAYER
-//#define NO_ACTION_TAPPING
-//#define NO_ACTION_ONESHOT
-//#define NO_ACTION_MACRO
-//#define NO_ACTION_FUNCTION
-
-#endif \ No newline at end of file
diff --git a/keyboards/lets-split/keymaps/default/keymap.c b/keyboards/lets-split/keymaps/default/keymap.c
deleted file mode 100644
index 00602394f..000000000
--- a/keyboards/lets-split/keymaps/default/keymap.c
+++ /dev/null
@@ -1,42 +0,0 @@
-#include "lets-split.h"
-#include "action_layer.h"
-
-#define BASE 0
-
-enum preonic_keycodes {
- KC_IDK = SAFE_RANGE,
- PM_RESET
-};
-
-// Fillers to make layering more clear
-#define _______ KC_TRNS
-#define XXXXXXX KC_NO
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
-
-[BASE] = {
- {KC_TAB, KC_Q, KC_W, KC_E, KC_R, KC_T },
- {KC_ESC, KC_A, KC_S, KC_D, KC_F, KC_G },
- {KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B },
- {KC_IDK, KC_LCTL, KC_LALT, KC_LGUI, KC_SPC, PM_RESET }
-}
-
-};
-
-bool process_record_user(uint16_t keycode, keyrecord_t *record) {
- switch (keycode) {
- case KC_IDK:
- if (record->event.pressed) {
- SEND_STRING("IDK. ");
- }
- return false;
- break;
- case PM_RESET:
- if (record->event.pressed) {
- promicro_bootloader_jmp(true);
- }
- return false;
- break;
- }
- return true;
-}; \ No newline at end of file
diff --git a/keyboards/lets-split/lets-split.c b/keyboards/lets-split/lets-split.c
deleted file mode 100644
index ee9872303..000000000
--- a/keyboards/lets-split/lets-split.c
+++ /dev/null
@@ -1,48 +0,0 @@
-#include "lets-split.h"
-
-#ifdef AUDIO_ENABLE
- float tone_startup[][2] = SONG(STARTUP_SOUND);
- float tone_goodbye[][2] = SONG(GOODBYE_SOUND);
-#endif
-
-void matrix_init_kb(void) {
-
- #ifdef AUDIO_ENABLE
- _delay_ms(20); // gets rid of tick
- PLAY_NOTE_ARRAY(tone_startup, false, 0);
- #endif
-
- // green led on
- DDRD |= (1<<5);
- PORTD &= ~(1<<5);
-
- // orange led on
- DDRB |= (1<<0);
- PORTB &= ~(1<<0);
-
- matrix_init_user();
-};
-
-void promicro_bootloader_jmp(bool program) {
-
- #ifdef AUDIO_ENABLE
- PLAY_NOTE_ARRAY(tone_goodbye, false, 0);
- _delay_ms(150);
- stop_all_notes();
- #endif
-
- uint16_t *const bootKeyPtr = (uint16_t *)0x0800;
-
- // Value used by Caterina bootloader use to determine whether to run the
- // sketch or the bootloader programmer.
- uint16_t bootKey = program ? 0x7777 : 0;
-
- *bootKeyPtr = bootKey;
-
- // setup watchdog timeout
- wdt_enable(WDTO_60MS);
-
- while(1) {} // wait for watchdog timer to trigger
-}
-
-
diff --git a/keyboards/lets-split/lets-split.h b/keyboards/lets-split/lets-split.h
deleted file mode 100644
index c82b95a37..000000000
--- a/keyboards/lets-split/lets-split.h
+++ /dev/null
@@ -1,4 +0,0 @@
-#include "quantum.h"
-#include <avr/wdt.h>
-
-void promicro_bootloader_jmp(bool program); \ No newline at end of file
diff --git a/keyboards/lets-split/readme.md b/keyboards/lets-split/readme.md
deleted file mode 100644
index e69de29bb..000000000
--- a/keyboards/lets-split/readme.md
+++ /dev/null