aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/planck/keymaps/piemod/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/planck/keymaps/piemod/rules.mk')
-rw-r--r--keyboards/planck/keymaps/piemod/rules.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/keyboards/planck/keymaps/piemod/rules.mk b/keyboards/planck/keymaps/piemod/rules.mk
index 1e48872e3..84cb02bd7 100644
--- a/keyboards/planck/keymaps/piemod/rules.mk
+++ b/keyboards/planck/keymaps/piemod/rules.mk
@@ -1,10 +1,18 @@
SUBPROJECT_DEFAULT = rev4
MOUSEKEY_ENABLE = yes
-BLUETOOTH_ENABLE = yes
EXTRAKEY_ENABLE = yes
AUDIO_ENABLE = yes
+ifeq ($(MCU),at90usb1286)
+BOOTMAGIC_ENABLE = no
+CONSOLE_ENABLE = no
+COMMAND_ENABLE = no
+BLUETOOTH_ENABLE = no
+else
+BLUETOOTH_ENABLE = yes
+endif
+
ifndef QUANTUM_DIR
include ../../../../Makefile
endif