aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/sol/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/sol/rules.mk')
-rw-r--r--keyboards/sol/rules.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/keyboards/sol/rules.mk b/keyboards/sol/rules.mk
index bafdd9c52..b7d689c03 100644
--- a/keyboards/sol/rules.mk
+++ b/keyboards/sol/rules.mk
@@ -1,5 +1,3 @@
-SRC += serial.c
-
# MCU name
#MCU = at90usb1287
MCU = atmega32u4
@@ -48,6 +46,9 @@ OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
# Custom local font file
OPT_DEFS += -DOLED_FONT_H=\"common/glcdfont.c\"
+SPLIT_KEYBOARD = yes
+ENCODER_ENABLE = yes
+
# Build Options
# change to "no" to disable the options, or define them in the Makefile in
# the appropriate keymap folder that will get included automatically
@@ -62,6 +63,4 @@ UNICODE_ENABLE = no # Unicode
BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
RGBLIGHT_ENABLE = yes # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
-CUSTOM_MATRIX = yes
-
DEFAULT_FOLDER = sol/rev1