aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/spaceman/2_milk/keymaps
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/spaceman/2_milk/keymaps')
-rw-r--r--keyboards/spaceman/2_milk/keymaps/binary/keymap.c8
-rw-r--r--keyboards/spaceman/2_milk/keymaps/binary/readme.md2
-rw-r--r--keyboards/spaceman/2_milk/keymaps/copypasta/keymap.c8
-rw-r--r--keyboards/spaceman/2_milk/keymaps/copypasta/readme.md2
-rw-r--r--keyboards/spaceman/2_milk/keymaps/default/keymap.c8
-rw-r--r--keyboards/spaceman/2_milk/keymaps/default/readme.md2
-rw-r--r--keyboards/spaceman/2_milk/keymaps/emoji/config.h2
-rw-r--r--keyboards/spaceman/2_milk/keymaps/emoji/keymap.c53
-rw-r--r--keyboards/spaceman/2_milk/keymaps/emoji/readme.md39
-rw-r--r--keyboards/spaceman/2_milk/keymaps/emoji/rules.mk2
-rw-r--r--keyboards/spaceman/2_milk/keymaps/excessbread/keymap.c8
-rw-r--r--keyboards/spaceman/2_milk/keymaps/excessbread/readme.md2
-rw-r--r--keyboards/spaceman/2_milk/keymaps/mikethetiger/keymap.c8
-rw-r--r--keyboards/spaceman/2_milk/keymaps/mikethetiger/readme.md1
-rw-r--r--keyboards/spaceman/2_milk/keymaps/mikethetiger/rules.mk13
-rw-r--r--keyboards/spaceman/2_milk/keymaps/mouse/keymap.c8
-rw-r--r--keyboards/spaceman/2_milk/keymaps/mouse/readme.md2
17 files changed, 168 insertions, 0 deletions
diff --git a/keyboards/spaceman/2_milk/keymaps/binary/keymap.c b/keyboards/spaceman/2_milk/keymaps/binary/keymap.c
new file mode 100644
index 000000000..c8df8e9ff
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/binary/keymap.c
@@ -0,0 +1,8 @@
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [0] = LAYOUT(
+ KC_P0,
+ KC_P1
+ )
+};
diff --git a/keyboards/spaceman/2_milk/keymaps/binary/readme.md b/keyboards/spaceman/2_milk/keymaps/binary/readme.md
new file mode 100644
index 000000000..5ebcbd3e5
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/binary/readme.md
@@ -0,0 +1,2 @@
+# Binary keymap
+0 and 1 that's it
diff --git a/keyboards/spaceman/2_milk/keymaps/copypasta/keymap.c b/keyboards/spaceman/2_milk/keymaps/copypasta/keymap.c
new file mode 100644
index 000000000..c82a6ff21
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/copypasta/keymap.c
@@ -0,0 +1,8 @@
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [0] = LAYOUT(
+ RCTL(KC_C),
+ RCTL(KC_V)
+ )
+};
diff --git a/keyboards/spaceman/2_milk/keymaps/copypasta/readme.md b/keyboards/spaceman/2_milk/keymaps/copypasta/readme.md
new file mode 100644
index 000000000..6c2f4e8fb
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/copypasta/readme.md
@@ -0,0 +1,2 @@
+# Copy/Paste Keymap
+![Picture](https://i.imgur.com/7LMZZrL.png)
diff --git a/keyboards/spaceman/2_milk/keymaps/default/keymap.c b/keyboards/spaceman/2_milk/keymaps/default/keymap.c
new file mode 100644
index 000000000..1f327eee9
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/default/keymap.c
@@ -0,0 +1,8 @@
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [0] = LAYOUT(
+ KC_Z,
+ KC_X
+ )
+};
diff --git a/keyboards/spaceman/2_milk/keymaps/default/readme.md b/keyboards/spaceman/2_milk/keymaps/default/readme.md
new file mode 100644
index 000000000..4482bce34
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/default/readme.md
@@ -0,0 +1,2 @@
+# Default keymap for 2% Milk
+![Picture](https://i.imgur.com/9PsZ6wa.png)
diff --git a/keyboards/spaceman/2_milk/keymaps/emoji/config.h b/keyboards/spaceman/2_milk/keymaps/emoji/config.h
new file mode 100644
index 000000000..90e4d6310
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/emoji/config.h
@@ -0,0 +1,2 @@
+#define UNICODE_SELECTED_MODES UC_LNX, UC_OSX, UC_WIN, UC_WINC
+#define TAPPING_TERM 300 \ No newline at end of file
diff --git a/keyboards/spaceman/2_milk/keymaps/emoji/keymap.c b/keyboards/spaceman/2_milk/keymaps/emoji/keymap.c
new file mode 100644
index 000000000..024a6a054
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/emoji/keymap.c
@@ -0,0 +1,53 @@
+#include QMK_KEYBOARD_H
+
+enum tapdance_keycodes {
+ TD_KEY_1,
+ TD_KEY_2,
+};
+
+void dance_key_one (qk_tap_dance_state_t *state, void *user_data) {
+ if (state->count == 1) {
+ send_unicode_hex_string("00AF 005C 005F 0028 30C4 0029 005F 002F 00AF"); // ¯\_(ツ)_/¯
+ SEND_STRING(SS_TAP(X_ENTER));
+ reset_tap_dance (state);
+ } else if (state->count == 2) {
+ cycle_unicode_input_mode(+1);
+ reset_tap_dance (state);
+ }
+}
+
+void dance_key_two (qk_tap_dance_state_t *state, void *user_data) {
+ if (state->count == 1) {
+ send_unicode_hex_string("0CA0 005F 0CA0"); // ಠ_ಠ
+ SEND_STRING(SS_TAP(X_ENTER));
+ reset_tap_dance (state);
+ } else if (state->count == 2) {
+ send_unicode_hex_string("0028 30CE 0CA0 75CA 0CA0 0029 30CE 5F61 253B 2501 253B"); // (ノಠ痊ಠ)ノ彡┻━┻
+ SEND_STRING(SS_TAP(X_ENTER));
+ reset_tap_dance (state);
+ } else if (state->count == 3) {
+ send_unicode_hex_string("256D 2229 256E 0028 002D 005F 002D 0029 256D 2229 256E"); // ╭∩╮(-_-)╭∩╮
+ SEND_STRING(SS_TAP(X_ENTER));
+ reset_tap_dance (state);
+ } else if (state->count == 4) {
+ send_unicode_hex_string("0028 3065 FFE3 0020 00B3 FFE3 0029 3065"); // (づ ̄ ³ ̄)づ
+ SEND_STRING(SS_TAP(X_ENTER));
+ reset_tap_dance (state);
+ } else if (state->count == 5) {
+ send_unicode_hex_string("0028 FE3A FE39 FE3A 0029"); // (︺︹︺)
+ SEND_STRING(SS_TAP(X_ENTER));
+ reset_tap_dance (state);
+ }
+}
+
+qk_tap_dance_action_t tap_dance_actions[] = {
+ [TD_KEY_1] = ACTION_TAP_DANCE_FN(dance_key_one),
+ [TD_KEY_2] = ACTION_TAP_DANCE_FN(dance_key_two),
+};
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [0] = LAYOUT(
+ TD(TD_KEY_1),
+ TD(TD_KEY_2)
+ ),
+};
diff --git a/keyboards/spaceman/2_milk/keymaps/emoji/readme.md b/keyboards/spaceman/2_milk/keymaps/emoji/readme.md
new file mode 100644
index 000000000..1d5a08730
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/emoji/readme.md
@@ -0,0 +1,39 @@
+# Emoji Keymap
+![Picture](https://i.imgur.com/1zEZ9Lq.png)
+
+# Unicode Setup
+
+Unicode input in QMK works by inputting a sequence of characters to the
+OS, sort of like a macro. Unfortunately, the way this is done differs
+for each platform. Specifically, each platform requires a different
+combination of keys to trigger Unicode input. Therefore, a
+corresponding input mode has to be set in QMK.
+
+Documentation: [Feature Unicode](https://beta.docs.qmk.fm/features/feature_unicode#input-modes)
+
+On this keymap the default unicode mode it's `UC_LNX`.
+You can change it permanently tapping 2 times the KeyOne to select the next mode.
+
+## Unicode Mode List
+- UC_LNX
+- UC_OSX
+- UC_WIN
+- UC_WINC
+
+# Keymap
+To add more functionality to this Minimal Keyboard,
+it's implemented the tap dance feature, so pressing the same key
+multiples times will produce different emojis.
+
+## Key One
+
+- 1 Tap: `¯\_(ツ)_/¯`
+- 2 Taps: Switch Unicode Input Type
+
+## Key Two
+
+- 1 Tap: `ಠ_ಠ`
+- 2 Taps: `(ノಠ痊ಠ)ノ彡┻━┻`
+- 3 Taps: `╭∩╮(-_-)╭∩╮`
+- 4 Taps: `(づ ̄ ³ ̄)づ`
+- 5 Taps: `(︺︹︺)` \ No newline at end of file
diff --git a/keyboards/spaceman/2_milk/keymaps/emoji/rules.mk b/keyboards/spaceman/2_milk/keymaps/emoji/rules.mk
new file mode 100644
index 000000000..7a64eb902
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/emoji/rules.mk
@@ -0,0 +1,2 @@
+UNICODE_ENABLE = yes # Unicode
+TAP_DANCE_ENABLE = yes # Tap Dance \ No newline at end of file
diff --git a/keyboards/spaceman/2_milk/keymaps/excessbread/keymap.c b/keyboards/spaceman/2_milk/keymaps/excessbread/keymap.c
new file mode 100644
index 000000000..a01b47f27
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/excessbread/keymap.c
@@ -0,0 +1,8 @@
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [0] = LAYOUT(
+ KC_LGUI,
+ KC_F11
+ )
+};
diff --git a/keyboards/spaceman/2_milk/keymaps/excessbread/readme.md b/keyboards/spaceman/2_milk/keymaps/excessbread/readme.md
new file mode 100644
index 000000000..a6535e62c
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/excessbread/readme.md
@@ -0,0 +1,2 @@
+# ExcessBread's keymap
+requested by excessbread
diff --git a/keyboards/spaceman/2_milk/keymaps/mikethetiger/keymap.c b/keyboards/spaceman/2_milk/keymaps/mikethetiger/keymap.c
new file mode 100644
index 000000000..20e2292f0
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/mikethetiger/keymap.c
@@ -0,0 +1,8 @@
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [0] = LAYOUT(
+ KC_VOLU,
+ KC_VOLD
+ )
+};
diff --git a/keyboards/spaceman/2_milk/keymaps/mikethetiger/readme.md b/keyboards/spaceman/2_milk/keymaps/mikethetiger/readme.md
new file mode 100644
index 000000000..677732b05
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/mikethetiger/readme.md
@@ -0,0 +1 @@
+# mikethetiger's keymap for 2% Milk
diff --git a/keyboards/spaceman/2_milk/keymaps/mikethetiger/rules.mk b/keyboards/spaceman/2_milk/keymaps/mikethetiger/rules.mk
new file mode 100644
index 000000000..b5f038ef2
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/mikethetiger/rules.mk
@@ -0,0 +1,13 @@
+# Build Options
+# comment out to disable the options.
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = no # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = yes # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Custom backlighting code is used, so this should not be enabled
+AUDIO_ENABLE = no # This can be enabled if a speaker is connected to the expansion port. Not compatible with RGBLIGHT below
+RGBLIGHT_ENABLE = yes # This can be enabled if a ws2812 strip is connected to the expansion port.
diff --git a/keyboards/spaceman/2_milk/keymaps/mouse/keymap.c b/keyboards/spaceman/2_milk/keymaps/mouse/keymap.c
new file mode 100644
index 000000000..a8ba44fb4
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/mouse/keymap.c
@@ -0,0 +1,8 @@
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [0] = LAYOUT(
+ KC_BTN1,
+ KC_BTN2
+ )
+};
diff --git a/keyboards/spaceman/2_milk/keymaps/mouse/readme.md b/keyboards/spaceman/2_milk/keymaps/mouse/readme.md
new file mode 100644
index 000000000..8ecb99edd
--- /dev/null
+++ b/keyboards/spaceman/2_milk/keymaps/mouse/readme.md
@@ -0,0 +1,2 @@
+# left and right mouse buttons
+requested by WanderingVagrant