aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/tkc1800/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/tkc1800/rules.mk')
-rw-r--r--keyboards/tkc1800/rules.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/keyboards/tkc1800/rules.mk b/keyboards/tkc1800/rules.mk
index 7cc3bbe20..fa90e9980 100644
--- a/keyboards/tkc1800/rules.mk
+++ b/keyboards/tkc1800/rules.mk
@@ -9,12 +9,13 @@ MCU = at90usb1286
# QMK DFU qmk-dfu
# ATmega32A bootloadHID
# ATmega328P USBasp
-BOOTLOADER = atmel-dfu
+BOOTLOADER = qmk-dfu
# Build Options
# change yes to no to disable
#
-BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
MOUSEKEY_ENABLE = yes # Mouse keys
EXTRAKEY_ENABLE = yes # Audio control and System control
CONSOLE_ENABLE = no # Console for debug
@@ -29,6 +30,4 @@ MIDI_ENABLE = no # MIDI controls
UNICODE_ENABLE = no # Unicode
BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
AUDIO_ENABLE = no # Audio output on port C6
-
-SRC = i2c.c \
- ssd1306.c
+OLED_DRIVER_ENABLE = yes \ No newline at end of file