aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/xd84/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/xd84/rules.mk')
-rw-r--r--keyboards/xd84/rules.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/keyboards/xd84/rules.mk b/keyboards/xd84/rules.mk
index 283d4babc..e0982e040 100644
--- a/keyboards/xd84/rules.mk
+++ b/keyboards/xd84/rules.mk
@@ -78,11 +78,11 @@ BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
AUDIO_ENABLE = no # Audio output on port C6
FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
HD44780_ENABLE = no # Enable support for HD44780 based LCDs (+400)
+LINK_TIME_OPTIMIZATION_ENABLE = yes
# custom matrix setup
CUSTOM_MATRIX = yes
-SRC = i2c_master.c custom_matrix_helper.c pca9555.c matrix.c
+SRC += custom_matrix_helper.c pca9555.c matrix.c
+QUANTUM_LIB_SRC += i2c_master.c
-EXTRAFLAGS += -flto
-
-LAYOUTS = 75_ansi 75_iso \ No newline at end of file
+LAYOUTS = 75_ansi 75_iso