aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ymdk/bface
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/ymdk/bface')
-rw-r--r--keyboards/ymdk/bface/config.h2
-rw-r--r--keyboards/ymdk/bface/rules.mk15
2 files changed, 2 insertions, 15 deletions
diff --git a/keyboards/ymdk/bface/config.h b/keyboards/ymdk/bface/config.h
index 9e5a9134f..2273b7e84 100644
--- a/keyboards/ymdk/bface/config.h
+++ b/keyboards/ymdk/bface/config.h
@@ -34,6 +34,8 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define MATRIX_COL_PINS { A0, A1, A2, A3, A4, A5, A6, A7, C7, C6, C5, C4, C3, C2, D7}
#define UNUSED_PINS
+#define DIODE_DIRECTION COL2ROW
+
#define NO_UART 1
#define BACKLIGHT_PIN D4
diff --git a/keyboards/ymdk/bface/rules.mk b/keyboards/ymdk/bface/rules.mk
index 7b829530b..f6f026cf3 100644
--- a/keyboards/ymdk/bface/rules.mk
+++ b/keyboards/ymdk/bface/rules.mk
@@ -1,18 +1,3 @@
-# Copyright 2019 Ethan Durrant (emdarcher)
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
# MCU name
MCU = atmega32a