aboutsummaryrefslogtreecommitdiffstats
path: root/ps2_vusb/Makefile.orig
diff options
context:
space:
mode:
Diffstat (limited to 'ps2_vusb/Makefile.orig')
-rw-r--r--ps2_vusb/Makefile.orig165
1 files changed, 0 insertions, 165 deletions
diff --git a/ps2_vusb/Makefile.orig b/ps2_vusb/Makefile.orig
deleted file mode 100644
index 2bd1ed584..000000000
--- a/ps2_vusb/Makefile.orig
+++ /dev/null
@@ -1,165 +0,0 @@
-# Name: Makefile
-# Project: hid-mouse example
-# Author: Christian Starkjohann
-# Creation Date: 2008-04-07
-# Tabsize: 4
-# Copyright: (c) 2008 by OBJECTIVE DEVELOPMENT Software GmbH
-# License: GNU GPL v2 (see License.txt), GNU GPL v3 or proprietary (CommercialLicense.txt)
-# This Revision: $Id: Makefile 692 2008-11-07 15:07:40Z cs $
-
-DEVICE = atmega168
-F_CPU = 16000000 # in Hz
-FUSE_L = # see below for fuse values for particular devices
-FUSE_H =
-#AVRDUDE = avrdude -c usbasp -p $(DEVICE) # edit this line for your programmer
-AVRDUDE = avrdude -P COM1 -b 19200 -c arduino -p $(DEVICE)
-
-CFLAGS = -Iusbdrv -I. -DDEBUG_LEVEL=1
-OBJECTS = usbdrv/usbdrv.o usbdrv/usbdrvasm.o usbdrv/oddebug.o main.o
-
-COMPILE = avr-gcc -Wall -Os -DF_CPU=$(F_CPU) $(CFLAGS) -mmcu=$(DEVICE)
-
-##############################################################################
-# Fuse values for particular devices
-##############################################################################
-# If your device is not listed here, go to
-# http://palmavr.sourceforge.net/cgi-bin/fc.cgi
-# and choose options for external crystal clock and no clock divider
-#
-################################## ATMega8 ##################################
-# ATMega8 FUSE_L (Fuse low byte):
-# 0x9f = 1 0 0 1 1 1 1 1
-# ^ ^ \ / \--+--/
-# | | | +------- CKSEL 3..0 (external >8M crystal)
-# | | +--------------- SUT 1..0 (crystal osc, BOD enabled)
-# | +------------------ BODEN (BrownOut Detector enabled)
-# +-------------------- BODLEVEL (2.7V)
-# ATMega8 FUSE_H (Fuse high byte):
-# 0xc9 = 1 1 0 0 1 0 0 1 <-- BOOTRST (boot reset vector at 0x0000)
-# ^ ^ ^ ^ ^ ^ ^------ BOOTSZ0
-# | | | | | +-------- BOOTSZ1
-# | | | | + --------- EESAVE (don't preserve EEPROM over chip erase)
-# | | | +-------------- CKOPT (full output swing)
-# | | +---------------- SPIEN (allow serial programming)
-# | +------------------ WDTON (WDT not always on)
-# +-------------------- RSTDISBL (reset pin is enabled)
-#
-############################## ATMega48/88/168 ##############################
-# ATMega*8 FUSE_L (Fuse low byte):
-# 0xdf = 1 1 0 1 1 1 1 1
-# ^ ^ \ / \--+--/
-# | | | +------- CKSEL 3..0 (external >8M crystal)
-# | | +--------------- SUT 1..0 (crystal osc, BOD enabled)
-# | +------------------ CKOUT (if 0: Clock output enabled)
-# +-------------------- CKDIV8 (if 0: divide by 8)
-# ATMega*8 FUSE_H (Fuse high byte):
-# 0xde = 1 1 0 1 1 1 1 0
-# ^ ^ ^ ^ ^ \-+-/
-# | | | | | +------ BODLEVEL 0..2 (110 = 1.8 V)
-# | | | | + --------- EESAVE (preserve EEPROM over chip erase)
-# | | | +-------------- WDTON (if 0: watchdog always on)
-# | | +---------------- SPIEN (allow serial programming)
-# | +------------------ DWEN (debug wire enable)
-# +-------------------- RSTDISBL (reset pin is enabled)
-#
-############################## ATTiny25/45/85 ###############################
-# ATMega*5 FUSE_L (Fuse low byte):
-# 0xef = 1 1 1 0 1 1 1 1
-# ^ ^ \+/ \--+--/
-# | | | +------- CKSEL 3..0 (clock selection -> crystal @ 12 MHz)
-# | | +--------------- SUT 1..0 (BOD enabled, fast rising power)
-# | +------------------ CKOUT (clock output on CKOUT pin -> disabled)
-# +-------------------- CKDIV8 (divide clock by 8 -> don't divide)
-# ATMega*5 FUSE_H (Fuse high byte):
-# 0xdd = 1 1 0 1 1 1 0 1
-# ^ ^ ^ ^ ^ \-+-/
-# | | | | | +------ BODLEVEL 2..0 (brownout trigger level -> 2.7V)
-# | | | | +---------- EESAVE (preserve EEPROM on Chip Erase -> not preserved)
-# | | | +-------------- WDTON (watchdog timer always on -> disable)
-# | | +---------------- SPIEN (enable serial programming -> enabled)
-# | +------------------ DWEN (debug wire enable)
-# +-------------------- RSTDISBL (disable external reset -> enabled)
-#
-################################ ATTiny2313 #################################
-# ATTiny2313 FUSE_L (Fuse low byte):
-# 0xef = 1 1 1 0 1 1 1 1
-# ^ ^ \+/ \--+--/
-# | | | +------- CKSEL 3..0 (clock selection -> crystal @ 12 MHz)
-# | | +--------------- SUT 1..0 (BOD enabled, fast rising power)
-# | +------------------ CKOUT (clock output on CKOUT pin -> disabled)
-# +-------------------- CKDIV8 (divide clock by 8 -> don't divide)
-# ATTiny2313 FUSE_H (Fuse high byte):
-# 0xdb = 1 1 0 1 1 0 1 1
-# ^ ^ ^ ^ \-+-/ ^
-# | | | | | +---- RSTDISBL (disable external reset -> enabled)
-# | | | | +-------- BODLEVEL 2..0 (brownout trigger level -> 2.7V)
-# | | | +-------------- WDTON (watchdog timer always on -> disable)
-# | | +---------------- SPIEN (enable serial programming -> enabled)
-# | +------------------ EESAVE (preserve EEPROM on Chip Erase -> not preserved)
-# +-------------------- DWEN (debug wire enable)
-
-
-# symbolic targets:
-help:
- @echo "This Makefile has no default rule. Use one of the following:"
- @echo "make hex ....... to build main.hex"
- @echo "make program ... to flash fuses and firmware"
- @echo "make fuse ...... to flash the fuses"
- @echo "make flash ..... to flash the firmware (use this on metaboard)"
- @echo "make clean ..... to delete objects and hex file"
-
-hex: main.hex
-
-program: flash fuse
-
-# rule for programming fuse bits:
-fuse:
- @[ "$(FUSE_H)" != "" -a "$(FUSE_L)" != "" ] || \
- { echo "*** Edit Makefile and choose values for FUSE_L and FUSE_H!"; exit 1; }
- $(AVRDUDE) -U hfuse:w:$(FUSE_H):m -U lfuse:w:$(FUSE_L):m
-
-# rule for uploading firmware:
-flash: main.hex
- $(AVRDUDE) -U flash:w:main.hex:i
-
-# rule for deleting dependent files (those which can be built by Make):
-clean:
- rm -f main.hex main.lst main.obj main.cof main.list main.map main.eep.hex main.elf *.o usbdrv/*.o main.s usbdrv/oddebug.s usbdrv/usbdrv.s
-
-# Generic rule for compiling C files:
-.c.o:
- $(COMPILE) -c $< -o $@
-
-# Generic rule for assembling Assembler source files:
-.S.o:
- $(COMPILE) -x assembler-with-cpp -c $< -o $@
-# "-x assembler-with-cpp" should not be necessary since this is the default
-# file type for the .S (with capital S) extension. However, upper case
-# characters are not always preserved on Windows. To ensure WinAVR
-# compatibility define the file type manually.
-
-# Generic rule for compiling C to assembler, used for debugging only.
-.c.s:
- $(COMPILE) -S $< -o $@
-
-# file targets:
-
-# Since we don't want to ship the driver multipe times, we copy it into this project:
-usbdrv:
- cp -r ../usbdrv .
-
-main.elf: usbdrv $(OBJECTS) # usbdrv dependency only needed because we copy it
- $(COMPILE) -o main.elf $(OBJECTS)
-
-main.hex: main.elf
- rm -f main.hex main.eep.hex
- avr-objcopy -j .text -j .data -O ihex main.elf main.hex
- avr-size main.hex
-
-# debugging targets:
-
-disasm: main.elf
- avr-objdump -d main.elf
-
-cpp:
- $(COMPILE) -E main.c