aboutsummaryrefslogtreecommitdiffstats
path: root/quantum
diff options
context:
space:
mode:
Diffstat (limited to 'quantum')
-rw-r--r--quantum/config_common.h3
-rw-r--r--quantum/mcu_selection.mk15
2 files changed, 18 insertions, 0 deletions
diff --git a/quantum/config_common.h b/quantum/config_common.h
index 4cfd74b0f..9861c8678 100644
--- a/quantum/config_common.h
+++ b/quantum/config_common.h
@@ -63,6 +63,9 @@
# define PINB_ADDRESS 0x3
# define PINC_ADDRESS 0x6
# define PIND_ADDRESS 0x9
+# elif defined(__AVR_ATtiny85__)
+# define ADDRESS_BASE 0x10
+# define PINB_ADDRESS 0x6
# else
# error "Pins are not defined"
# endif
diff --git a/quantum/mcu_selection.mk b/quantum/mcu_selection.mk
index ef7e8ae75..33de162bb 100644
--- a/quantum/mcu_selection.mk
+++ b/quantum/mcu_selection.mk
@@ -287,3 +287,18 @@ ifneq (,$(filter $(MCU),atmega328p))
NO_UART ?= yes
NO_SUSPEND_POWER_DOWN ?= yes
endif
+
+ifneq (,$(filter $(MCU),attiny85))
+ PROTOCOL = VUSB
+
+ # Processor frequency.
+ # This will define a symbol, F_CPU, in all source code files equal to the
+ # processor frequency in Hz. You can then use this symbol in your source code to
+ # calculate timings. Do NOT tack on a 'UL' at the end, this will be done
+ # automatically to create a 32-bit value in your source code.
+ F_CPU ?= 16500000
+
+ # unsupported features for now
+ NO_UART ?= yes
+ NO_SUSPEND_POWER_DOWN ?= yes
+endif