aboutsummaryrefslogtreecommitdiffstats
path: root/tmk_core/avr.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tmk_core/avr.mk')
-rw-r--r--tmk_core/avr.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/tmk_core/avr.mk b/tmk_core/avr.mk
index d5ca3a4dd..1525391a4 100644
--- a/tmk_core/avr.mk
+++ b/tmk_core/avr.mk
@@ -21,7 +21,9 @@ COMPILEFLAGS += -fdata-sections
COMPILEFLAGS += -fpack-struct
COMPILEFLAGS += -fshort-enums
-CFLAGS += $(COMPILEFLAGS)
+ASFLAGS += $(AVR_ASFLAGS)
+
+CFLAGS += $(COMPILEFLAGS) $(AVR_CFLAGS)
CFLAGS += -fno-inline-small-functions
CFLAGS += -fno-strict-aliasing