aboutsummaryrefslogtreecommitdiffstats
path: root/users/bcat/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'users/bcat/rules.mk')
-rw-r--r--users/bcat/rules.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/users/bcat/rules.mk b/users/bcat/rules.mk
index 107b470ed..6d3444b2c 100644
--- a/users/bcat/rules.mk
+++ b/users/bcat/rules.mk
@@ -1,3 +1,5 @@
+SRC += bcat.c
+
# Enable Bootmagic Lite to consistently reset to bootloader and clear EEPROM.
BOOTMAGIC_ENABLE = lite
@@ -16,3 +18,6 @@ SLEEP_LED_ENABLE = no
UCIS_ENABLE = no
UNICODE_ENABLE = no
UNICODEMAP_ENABLE = no
+
+# Enable link-time optimization to reduce binary size.
+LINK_TIME_OPTIMIZATION_ENABLE = yes