aboutsummaryrefslogtreecommitdiffstats
path: root/users/bocaj/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'users/bocaj/rules.mk')
-rw-r--r--users/bocaj/rules.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/users/bocaj/rules.mk b/users/bocaj/rules.mk
new file mode 100644
index 000000000..9ed8c250a
--- /dev/null
+++ b/users/bocaj/rules.mk
@@ -0,0 +1,33 @@
+SRC += bocaj.c \
+ process_records.c
+
+ifneq ("$(wildcard $(USER_PATH)/secrets.c)","")
+ SRC += secrets.c
+endif
+
+ifeq ($(strip $(TAP_DANCE_ENABLE)), yes)
+ SRC += tap_dances.c
+endif
+
+# Caused problems when building via docker on Mac OS
+# EXTRAFLAGS += -flto
+
+ifeq ($(strip $(NO_SECRETS)), yes)
+ OPT_DEFS += -DNO_SECRETS
+endif
+
+ifeq ($(strip $(MACROS_ENABLED)), yes)
+ OPT_DEFS += -DMACROS_ENABLED
+endif
+
+ifeq ($(strip $(UCIS_ENABLE)), yes)
+ SRC += send_unicode.c
+endif
+
+ifeq ($(strip $(UNICODEMAP_ENABLE)), yes)
+ SRC += send_unicode.c
+endif
+
+ifeq ($(strip $(UNICODE_ENABLE)), yes)
+ SRC += send_unicode.c
+endif