aboutsummaryrefslogtreecommitdiffstats
path: root/users/drashna/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'users/drashna/rules.mk')
-rw-r--r--users/drashna/rules.mk13
1 files changed, 7 insertions, 6 deletions
diff --git a/users/drashna/rules.mk b/users/drashna/rules.mk
index 4d55da803..051368ff5 100644
--- a/users/drashna/rules.mk
+++ b/users/drashna/rules.mk
@@ -2,9 +2,10 @@ SRC += drashna.c \
process_records.c
ifneq ($(PLATFORM),CHIBIOS)
- LTO_ENABLE = yes
+ LTO_ENABLE = yes
endif
SPACE_CADET_ENABLE = no
+GRAVE_ESC_ENABLE = no
ifneq ($(strip $(NO_SECRETS)), yes)
ifneq ("$(wildcard $(USER_PATH)/secrets.c)","")
@@ -19,10 +20,6 @@ ifeq ($(strip $(TAP_DANCE_ENABLE)), yes)
SRC += tap_dances.c
endif
-
-
-
-
ifeq ($(strip $(RGBLIGHT_ENABLE)), yes)
SRC += rgb_stuff.c
ifeq ($(strip $(INDICATOR_LIGHTS)), yes)
@@ -41,7 +38,7 @@ endif
RGB_MATRIX_ENABLE ?= no
ifneq ($(strip $(RGB_MATRIX_ENABLE)), no)
- SRC += rgb_stuff.c
+ SRC += rgb_matrix_stuff.c
endif
@@ -61,3 +58,7 @@ endif
ifeq ($(strip $(PROTOCOL)), VUSB)
NKRO_ENABLE = no
endif
+
+ifeq ($(strip $(OLED_DRIVER_ENABLE)), yes)
+ SRC += oled_stuff.c
+endif