aboutsummaryrefslogtreecommitdiffstats
path: root/users/ridingqwerty/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'users/ridingqwerty/rules.mk')
-rw-r--r--users/ridingqwerty/rules.mk20
1 files changed, 18 insertions, 2 deletions
diff --git a/users/ridingqwerty/rules.mk b/users/ridingqwerty/rules.mk
index 9c3846744..153e5ff90 100644
--- a/users/ridingqwerty/rules.mk
+++ b/users/ridingqwerty/rules.mk
@@ -1,8 +1,24 @@
-#LEADER_ENABLE = yes
-
SRC += ridingqwerty.c \
process_records.c
+BOOTMAGIC_ENABLE = lite
+CONSOLE_ENABLE = no
+COMMAND_ENABLE = no
+UNICODE_ENABLE = no # "yes" in Atreus default keymap, blocking UNICODEMAP_ENABLE
+UNICODEMAP_ENABLE = yes
+MOUSEKEY_ENABLE = no
+TAP_DANCE_ENABLE = yes
+AUTO_SHIFT_ENABLE = no
+
ifneq ("$(wildcard $(USER_PATH)/secrets.c)","")
SRC += secrets.c
endif
+
+ifeq ($(strip $(TAP_DANCE_ENABLE)), yes)
+ SRC += tapdances.c
+endif
+
+ifeq ($(strip $(UNICODEMAP_ENABLE)), yes)
+ SRC += unicode.c
+endif
+