aboutsummaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorGennadiy Civil <gennadiycivil@users.noreply.github.com>2017-12-20 15:57:28 -0500
committerGitHub <noreply@github.com>2017-12-20 15:57:28 -0500
commit0062e4869f07a3ef235703ddf63af604b712446c (patch)
tree6adfa1b9e075dfaee61a396b3e19f24cfdde0b08 /googlemock/CMakeLists.txt
parenta37eedc3c15e57cea81722eea3f97b2aeb1659cf (diff)
parente17907da8039d6491f951434f71677490176f72f (diff)
downloadgoogletest-0062e4869f07a3ef235703ddf63af604b712446c.tar.gz
googletest-0062e4869f07a3ef235703ddf63af604b712446c.tar.bz2
googletest-0062e4869f07a3ef235703ddf63af604b712446c.zip
Merge pull request #1357 from bryanzim/master
CMake fixes for paths with spaces
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index ead51bf3..21d61b13 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -112,11 +112,11 @@ endif()
# Install rules
if(INSTALL_GMOCK)
install(TARGETS gmock gmock_main
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
- install(DIRECTORY ${gmock_SOURCE_DIR}/include/gmock
- DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}"
+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}"
+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}")
+ install(DIRECTORY "${gmock_SOURCE_DIR}/include/gmock"
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
# configure and install pkgconfig files
configure_file(