aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.am24
1 files changed, 14 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index adc21d7f..3e11b328 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,16 +73,18 @@ test_gmock_link_test_SOURCES = \
test/gmock_link_test.h
test_gmock_link_test_LDADD = $(GTEST_LIBS) lib/libgmock_main.la lib/libgmock.la
-# Tests that fused gmock files compile and work.
-TESTS += test/gmock_fused_test
-check_PROGRAMS += test/gmock_fused_test
-test_gmock_fused_test_SOURCES = \
- fused-src/gmock-gtest-all.cc \
- fused-src/gmock/gmock.h \
- fused-src/gmock_main.cc \
- fused-src/gtest/gtest.h \
- test/gmock_test.cc
-test_gmock_fused_test_CPPFLAGS = -I"$(srcdir)/fused-src"
+if HAVE_PYTHON
+ # Tests that fused gmock files compile and work.
+ TESTS += test/gmock_fused_test
+ check_PROGRAMS += test/gmock_fused_test
+ test_gmock_fused_test_SOURCES = \
+ fused-src/gmock-gtest-all.cc \
+ fused-src/gmock/gmock.h \
+ fused-src/gmock_main.cc \
+ fused-src/gtest/gtest.h \
+ test/gmock_test.cc
+ test_gmock_fused_test_CPPFLAGS = -I"$(srcdir)/fused-src"
+endif
# Google Mock source files that we don't compile directly.
GMOCK_SOURCE_INGLUDES = \
@@ -169,6 +171,7 @@ EXTRA_DIST += \
msvc/2010/gmock_main.vcxproj \
msvc/2010/gmock_test.vcxproj
+if HAVE_PYTHON
# gmock_test.cc does not really depend on files generated by the
# fused-gmock-internal rule. However, gmock_test.o does, and it is
# important to include test/gmock_test.cc as part of this rule in order to
@@ -191,6 +194,7 @@ fused-gmock-internal: $(pkginclude_HEADERS) $(pkginclude_internal_HEADERS) \
maintainer-clean-local:
rm -rf "$(srcdir)/fused-src"
+endif
# Death tests may produce core dumps in the build directory. In case
# this happens, clean them to keep distcleancheck happy.