aboutsummaryrefslogtreecommitdiffstats
path: root/LUFA/Build/DMBS/DMBS/cppcheck.mk
diff options
context:
space:
mode:
authorDean Camera <dean@fourwalledcubicle.com>2016-04-03 13:52:00 +1000
committerDean Camera <dean@fourwalledcubicle.com>2016-04-03 13:52:00 +1000
commit51d3adfe1869e4a45c8368bb00a485be052eecdb (patch)
treead32af0201cf63faec46f70e20d1c7016b92e026 /LUFA/Build/DMBS/DMBS/cppcheck.mk
parent3069b7d9d2a01f7f1e68722e722fa8e868154585 (diff)
downloadlufa-51d3adfe1869e4a45c8368bb00a485be052eecdb.tar.gz
lufa-51d3adfe1869e4a45c8368bb00a485be052eecdb.tar.bz2
lufa-51d3adfe1869e4a45c8368bb00a485be052eecdb.zip
Update to latest version of DMBS.
Diffstat (limited to 'LUFA/Build/DMBS/DMBS/cppcheck.mk')
-rw-r--r--LUFA/Build/DMBS/DMBS/cppcheck.mk41
1 files changed, 0 insertions, 41 deletions
diff --git a/LUFA/Build/DMBS/DMBS/cppcheck.mk b/LUFA/Build/DMBS/DMBS/cppcheck.mk
index 2e0be12ad..70b9ed721 100644
--- a/LUFA/Build/DMBS/DMBS/cppcheck.mk
+++ b/LUFA/Build/DMBS/DMBS/cppcheck.mk
@@ -14,47 +14,6 @@ DMBS_BUILD_OPTIONAL_VARS += CPPCHECK_INCLUDES CPPCHECK_EXCLUDES CPPCHECK_MSG_T
DMBS_BUILD_PROVIDED_VARS +=
DMBS_BUILD_PROVIDED_MACROS +=
-# -----------------------------------------------------------------------------
-# DMBS CPPCheck Buildsystem Makefile Module.
-# -----------------------------------------------------------------------------
-# DESCRIPTION:
-# Provides a set of targets to scan a project with the free "cppcheck" static
-# analysis tool, to check for code errors at runtime
-# (see http://cppcheck.sourceforge.net).
-# -----------------------------------------------------------------------------
-# TARGETS:
-#
-# cppcheck - Scan the project with CPPCheck
-# cppcheck-config - Use CPPCheck to look for missing include files
-#
-# MANDATORY PARAMETERS:
-#
-# SRC - List of source files to statically analyze
-#
-# OPTIONAL PARAMETERS:
-#
-# CPPCHECK_INCLUDES - Extra include paths to search for missing
-# header files
-# CPPCHECK_EXCLUDES - Source file paths to exclude checking (can be
-# a path fragment if desired)
-# CPPCHECK_MSG_TEMPLATE - Template for cppcheck error and warning output
-# CPPCHECK_ENABLE - General cppcheck category checks to enable
-# CPPCHECK_SUPPRESS - Specific cppcheck warnings to disable by ID
-# CPPCHECK_FAIL_ON_WARNING - Set to Y to fail the build on cppcheck
-# warnings, N to continue even if warnings occur
-# CPPCHECK_QUIET - Enable cppcheck verbose or quiet output mode
-# CPPCHECK_FLAGS - Additional flags to pass to cppcheck
-#
-# PROVIDED VARIABLES:
-#
-# (None)
-#
-# PROVIDED MACROS:
-#
-# (None)
-#
-# -----------------------------------------------------------------------------
-
SHELL = /bin/sh
ERROR_IF_UNSET ?= $(if $(filter undefined, $(origin $(strip $(1)))), $(error Makefile $(strip $(1)) value not set))