aboutsummaryrefslogtreecommitdiffstats
path: root/LUFA/Build/HID_EEPROM_Loader/makefile
diff options
context:
space:
mode:
authorDean Camera <dean@fourwalledcubicle.com>2012-07-14 13:18:13 +0000
committerDean Camera <dean@fourwalledcubicle.com>2012-07-14 13:18:13 +0000
commitb7e3c86e4e5d4262a608163176d0b01c0cc54b29 (patch)
tree1a3e64fe61c730c56a8c808eafc2d5398a187c28 /LUFA/Build/HID_EEPROM_Loader/makefile
parentd4980e58d420bd509a4bd7996aee74c4fbb01cd9 (diff)
downloadlufa-b7e3c86e4e5d4262a608163176d0b01c0cc54b29.tar.gz
lufa-b7e3c86e4e5d4262a608163176d0b01c0cc54b29.tar.bz2
lufa-b7e3c86e4e5d4262a608163176d0b01c0cc54b29.zip
Rename build system module makefiles from "lufa.MODULE.in" to "lufa_MODULE.mk" to prevent makefile from assuming the include is an old style build rule, slowing down the build process.
Prevent the BUILD module from shell-executing multiple processes to determine the avr-size flags to speed up the build, unless the size rule is invoked. Add warnings and set warnings as errors to the SingleUSBModeTest build test makefile.
Diffstat (limited to 'LUFA/Build/HID_EEPROM_Loader/makefile')
-rw-r--r--LUFA/Build/HID_EEPROM_Loader/makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/LUFA/Build/HID_EEPROM_Loader/makefile b/LUFA/Build/HID_EEPROM_Loader/makefile
index 6226783ed..f6dcbea67 100644
--- a/LUFA/Build/HID_EEPROM_Loader/makefile
+++ b/LUFA/Build/HID_EEPROM_Loader/makefile
@@ -33,8 +33,8 @@ InputEEData.o: InputEEData.bin $(TARGET).o $(MAKEFILE_LIST)
avr-objcopy -I binary -O elf32-avr -B $(call FIND_AVR_SUBARCH) --rename-section .data=.progmem.data,contents,alloc,readonly,data $< $@
# Include LUFA build script makefiles
-include $(LUFA_PATH)/Build/lufa.core.in
-include $(LUFA_PATH)/Build/lufa.build.in
-include $(LUFA_PATH)/Build/lufa.cppcheck.in
-include $(LUFA_PATH)/Build/lufa.doxygen.in
-include $(LUFA_PATH)/Build/lufa.hid.in
+include $(LUFA_PATH)/Build/lufa_core.mk
+include $(LUFA_PATH)/Build/lufa_build.mk
+include $(LUFA_PATH)/Build/lufa_cppcheck.mk
+include $(LUFA_PATH)/Build/lufa_doxygen.mk
+include $(LUFA_PATH)/Build/lufa_hid.mk