aboutsummaryrefslogtreecommitdiffstats
path: root/LUFA/Build/lufa_dfu.mk
diff options
context:
space:
mode:
authorDean Camera <dean@fourwalledcubicle.com>2012-08-18 10:45:29 +0000
committerDean Camera <dean@fourwalledcubicle.com>2012-08-18 10:45:29 +0000
commit7375c789e1b85ef5eb280339559c0cc9ae8f3b87 (patch)
tree6f27faf9179718f6055be32e5e48057607f6aa76 /LUFA/Build/lufa_dfu.mk
parent3e50a59486d29752c938befdb906666e21851282 (diff)
downloadlufa-7375c789e1b85ef5eb280339559c0cc9ae8f3b87.tar.gz
lufa-7375c789e1b85ef5eb280339559c0cc9ae8f3b87.tar.bz2
lufa-7375c789e1b85ef5eb280339559c0cc9ae8f3b87.zip
Document build system targets. Add a rule to the BUILD module that is run if a source file does not exist to show an error to the user, rather than running the check-source rule before each build (slightly faster/more portable and the generated error is then a true make error).
Diffstat (limited to 'LUFA/Build/lufa_dfu.mk')
-rw-r--r--LUFA/Build/lufa_dfu.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/LUFA/Build/lufa_dfu.mk b/LUFA/Build/lufa_dfu.mk
index ba75f14a7..ddb7aab7a 100644
--- a/LUFA/Build/lufa_dfu.mk
+++ b/LUFA/Build/lufa_dfu.mk
@@ -62,12 +62,14 @@ MSG_COPY_CMD := ' [CP] :'
MSG_REMOVE_CMD := ' [RM] :'
MSG_DFU_CMD := ' [DFU] :'
+# Programs in the target FLASH memory using BATCHISP, the command line tool used by FLIP
flip: $(TARGET).hex $(MAKEFILE_LIST)
@echo $(MSG_DFU_CMD) Programming FLASH with batchisp using \"$<\"
batchisp -hardware usb -device $(MCU) -operation erase f
batchisp -hardware usb -device $(MCU) -operation loadbuffer $< program
batchisp -hardware usb -device $(MCU) -operation start reset 0
+# Programs in the target EEPROM memory using BATCHISP, the command line tool used by FLIP
flip-ee: $(TARGET).eep $(MAKEFILE_LIST)
@echo $(MSG_DFU_CMD) Copying EEP file to temporary file \"$<.hex\"
cp $< $<.hex
@@ -78,12 +80,14 @@ flip-ee: $(TARGET).eep $(MAKEFILE_LIST)
@echo $(MSG_DFU_CMD) Removing temporary file \"$<.hex\"
rm $<.hex
+# Programs in the target FLASH memory using DFU-PROGRAMMER
dfu: $(TARGET).hex $(MAKEFILE_LIST)
@echo $(MSG_DFU_CMD) Programming FLASH with dfu-programmer using \"$<\"
dfu-programmer $(MCU) erase
dfu-programmer $(MCU) flash $<
dfu-programmer $(MCU) reset
+# Programs in the target EEPROM memory using DFU-PROGRAMMER
dfu-ee: $(TARGET).eep $(MAKEFILE_LIST)
@echo $(MSG_DFU_CMD) Programming EEPROM with dfu-programmer using \"$<\"
dfu-programmer $(MCU) eeprom-flash $<