aboutsummaryrefslogtreecommitdiffstats
path: root/LUFA
diff options
context:
space:
mode:
authorDean Camera <dean@fourwalledcubicle.com>2013-03-28 09:30:37 +0000
committerDean Camera <dean@fourwalledcubicle.com>2013-03-28 09:30:37 +0000
commit8cd249c34240c2189b520c088afde936ec9201b3 (patch)
tree54efa43fc6c753ca4f6c121d9daec2295fb93660 /LUFA
parent4ba40977162ef46f328d49c4d48d7d8a0c6cddf0 (diff)
downloadlufa-8cd249c34240c2189b520c088afde936ec9201b3.tar.gz
lufa-8cd249c34240c2189b520c088afde936ec9201b3.tar.bz2
lufa-8cd249c34240c2189b520c088afde936ec9201b3.zip
Add BIN build system target information to the documentation.
Diffstat (limited to 'LUFA')
-rw-r--r--LUFA/Build/lufa_build.mk9
-rw-r--r--LUFA/DoxygenPages/BuildSystem.txt8
2 files changed, 11 insertions, 6 deletions
diff --git a/LUFA/Build/lufa_build.mk b/LUFA/Build/lufa_build.mk
index d99f8485b..828401096 100644
--- a/LUFA/Build/lufa_build.mk
+++ b/LUFA/Build/lufa_build.mk
@@ -7,7 +7,7 @@
#
LUFA_BUILD_MODULES += BUILD
-LUFA_BUILD_TARGETS += size symbol-sizes all lib elf hex lss clean mostlyclean
+LUFA_BUILD_TARGETS += size symbol-sizes all lib elf bin hex lss clean mostlyclean
LUFA_BUILD_MANDATORY_VARS += TARGET ARCH MCU SRC F_USB LUFA_PATH
LUFA_BUILD_OPTIONAL_VARS += BOARD OPTIMIZATION C_STANDARD CPP_STANDARD F_CPU C_FLAGS CPP_FLAGS ASM_FLAGS CC_FLAGS LD_FLAGS OBJDIR OBJECT_FILES DEBUG_TYPE DEBUG_LEVEL LINKER_RELAXATIONS
LUFA_BUILD_PROVIDED_VARS +=
@@ -28,7 +28,8 @@ LUFA_BUILD_PROVIDED_MACROS +=
# all - Build application and list size
# lib - Build and archive source files into a library
# elf - Build application ELF debug object file
-# hex - Build application HEX object files
+# bin - Build application BIN binary object file
+# hex - Build application HEX object file
# lss - Build application LSS assembly listing file
# clean - Remove all project intermediatary and binary
# output files
@@ -261,7 +262,7 @@ all: build_begin elf hex bin lss sym size build_end
lib: lib$(TARGET).a
elf: $(TARGET).elf
hex: $(TARGET).hex $(TARGET).eep
-bin: $(TARGET).bin $(TARGET).eep
+bin: $(TARGET).bin
lss: $(TARGET).lss
sym: $(TARGET).sym
@@ -323,7 +324,7 @@ $(OBJDIR)/%.o: %.S $(MAKEFILE_LIST)
# Extracts out the loadable EEPROM memory data from the project ELF file, and creates an Intel HEX format file of it
%.eep: %.elf
@echo $(MSG_OBJCPY_CMD) Extracting EEP file data from \"$<\"
- $(CROSS)-objcopy -j .eeprom --set-section-flags=.eeprom="alloc,load" --change-section-lma .eeprom=0 --no-change-warnings -O ihex $< $@ || exit 0
+ $(CROSS)-objcopy -O ihex -j .eeprom --set-section-flags=.eeprom="alloc,load" --change-section-lma .eeprom=0 --no-change-warnings $< $@ || exit 0
# Creates an assembly listing file from an input project ELF file, containing interleaved assembly and source data
%.lss: %.elf
diff --git a/LUFA/DoxygenPages/BuildSystem.txt b/LUFA/DoxygenPages/BuildSystem.txt
index 564033200..7aa357db7 100644
--- a/LUFA/DoxygenPages/BuildSystem.txt
+++ b/LUFA/DoxygenPages/BuildSystem.txt
@@ -88,6 +88,10 @@
* <td>Build and link the application into an ELF debug file.</td>
* </tr>
* <tr>
+ * <td><tt>bin</tt></td>
+ * <td>Build and link the application and produce a BIN binary file.</td>
+ * </tr>
+ * <tr>
* <td><tt>hex</tt></td>
* <td>Build and link the application and produce HEX and EEP binary files.</td>
* </tr>
@@ -916,7 +920,7 @@
* <td>Error &quot;<b><tt>Cannot build with OBJDIR parameter set - one or more object file name is not unique</tt></b>&quot; shown when compiling.</td>
* <td>When a project is built with a non-empty <tt>OBJDIR</tt> object directory name set, all input source files must have unique names, excluding extension and path.
* This means that input files that are named identically and differ only by their path or extension are invalid when this mode is used.</td>
- * </tr>
+ * </tr>
* <tr>
* <td>Error &quot;<b><tt>Source file does not exist: <i>{X}</i></tt></b>&quot; shown when compiling.</td>
* <td>The nominated input source file, specified in the user project's <tt>SRC</tt> parameter, could not be found. Ensure the source file exists and the absolute or
@@ -980,4 +984,4 @@
* </table>
*
* For troubleshooting other errors you encounter, please see \ref Sec_ProjectHelp.
- */ \ No newline at end of file
+ */