aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Bootloaders/HID/HostLoaderApp/Makefile6
-rw-r--r--LUFA/ManPages/FutureChanges.txt1
-rw-r--r--Projects/LEDNotifier/LEDNotifier.c10
3 files changed, 9 insertions, 8 deletions
diff --git a/Bootloaders/HID/HostLoaderApp/Makefile b/Bootloaders/HID/HostLoaderApp/Makefile
index ab450d254..7b2833e62 100644
--- a/Bootloaders/HID/HostLoaderApp/Makefile
+++ b/Bootloaders/HID/HostLoaderApp/Makefile
@@ -14,7 +14,7 @@ else ifeq ($(OS), WINDOWS)
CC = i586-mingw32msvc-gcc
CFLAGS ?= -O2 -Wall
hid_bootloader_cli.exe: hid_bootloader_cli.c
- $(CC) $(CFLAGS) -s -DUSE_WIN32 -o thid_bootloader_cli.exe hid_bootloader_cli.c -lhid -lsetupapi
+ $(CC) $(CFLAGS) -s -DUSE_WIN32 -o hid_bootloader_cli.exe hid_bootloader_cli.c -lhid -lsetupapi
else ifeq ($(OS), MACOSX)
@@ -29,11 +29,11 @@ else ifeq ($(OS), BSD) # works on NetBSD and OpenBSD
CC ?= gcct
CFLAGS ?= -O2 -Wall
hid_bootloader_cli: hid_bootloader_cli.c
- $(CC) $(CFLAGS) -s -DUSE_UHID -o teensy_loader_cli hid_bootloader_cli.c
+ $(CC) $(CFLAGS) -s -DUSE_UHID -o hid_bootloader_cli hid_bootloader_cli.c
endif
clean:
- rm -f thid_bootloader_cli hid_bootloader_cli.exe
+ rm -f hid_bootloader_cli hid_bootloader_cli.exe
diff --git a/LUFA/ManPages/FutureChanges.txt b/LUFA/ManPages/FutureChanges.txt
index 7c03b90f6..8212e027f 100644
--- a/LUFA/ManPages/FutureChanges.txt
+++ b/LUFA/ManPages/FutureChanges.txt
@@ -19,6 +19,7 @@
* -# Re-add interrupt Pipe/Endpoint support
* -# Investigate dynamically created device descriptors
* -# Re-add in software PDI/TPI support into the AVRISP-MKII project
+ * -# Add makefile includes to reduce boilerplate in user makefiles
* - Documentation/Support
* -# Add detailed overviews of how each demo works
* -# Add board overviews
diff --git a/Projects/LEDNotifier/LEDNotifier.c b/Projects/LEDNotifier/LEDNotifier.c
index baf3c1680..703b9f230 100644
--- a/Projects/LEDNotifier/LEDNotifier.c
+++ b/Projects/LEDNotifier/LEDNotifier.c
@@ -72,6 +72,11 @@ static volatile uint8_t SoftPWM_Channel2_Duty;
/** Duty cycle for the third software PWM channel */
static volatile uint8_t SoftPWM_Channel3_Duty;
+/** Standard file stream for the CDC interface when set up, so that the virtual CDC COM port can be
+ * used like any regular character stream in the C APIs
+ */
+static FILE USBSerialStream;
+
/** Interrupt handler for managing the software PWM channels for the LEDs */
ISR(TIMER0_COMPA_vect, ISR_BLOCK)
@@ -93,11 +98,6 @@ ISR(TIMER0_COMPA_vect, ISR_BLOCK)
LEDs_SetAllLEDs(LEDMask);
}
-/** Standard file stream for the CDC interface when set up, so that the virtual CDC COM port can be
- * used like any regular character stream in the C APIs
- */
-static FILE USBSerialStream;
-
/** Main program entry point. This routine contains the overall program flow, including initial
* setup of all components and the main program loop.
*/