aboutsummaryrefslogtreecommitdiffstats
path: root/Projects/XPLAINBridge/makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Projects/XPLAINBridge/makefile')
-rw-r--r--Projects/XPLAINBridge/makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Projects/XPLAINBridge/makefile b/Projects/XPLAINBridge/makefile
index f51ada5dc..33ac357ed 100644
--- a/Projects/XPLAINBridge/makefile
+++ b/Projects/XPLAINBridge/makefile
@@ -29,6 +29,14 @@ LD_FLAGS =
# Default target
all:
+# Since this project borrows files from the AVRISP-MKII project which may also have an
+# identical OBJDIR directory, we need to enforce the use of this project's object file
+# directory as the one where the build object files are to be stored by pre-pending the
+# absolute path of the current project to the OBJDIR variable.
+ifneq ($(OBJDIR),)
+ override OBJDIR:=$(shell pwd)/$(OBJDIR)
+endif
+
# Include LUFA build script makefiles
include $(LUFA_PATH)/Build/lufa_core.mk
include $(LUFA_PATH)/Build/lufa_sources.mk