aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/tinygl-0.4-ugfx/examples/Makefile
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-08-20 01:36:33 +1000
committerinmarket <andrewh@inmarket.com.au>2014-08-20 01:36:33 +1000
commit3b21507274aa4f98644382903ae529c1fc2c7bd4 (patch)
treebd977e47129c44adb20f0f72c891fa960c827d73 /3rdparty/tinygl-0.4-ugfx/examples/Makefile
parent301f134b9034170e6e26aa307e5ede741db1cf70 (diff)
downloaduGFX-3b21507274aa4f98644382903ae529c1fc2c7bd4.tar.gz
uGFX-3b21507274aa4f98644382903ae529c1fc2c7bd4.tar.bz2
uGFX-3b21507274aa4f98644382903ae529c1fc2c7bd4.zip
GL3D GWIN window + demo
Diffstat (limited to '3rdparty/tinygl-0.4-ugfx/examples/Makefile')
-rw-r--r--3rdparty/tinygl-0.4-ugfx/examples/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/3rdparty/tinygl-0.4-ugfx/examples/Makefile b/3rdparty/tinygl-0.4-ugfx/examples/Makefile
new file mode 100644
index 00000000..912243bb
--- /dev/null
+++ b/3rdparty/tinygl-0.4-ugfx/examples/Makefile
@@ -0,0 +1,29 @@
+include ../config.mk
+
+PROGS = mech texobj gears spin
+
+all: $(PROGS)
+
+clean:
+ rm -f core *.o *~ $(PROGS)
+
+mech: mech.o glu.o $(UI_OBJS) $(GL_DEPS)
+ $(CC) $(LFLAGS) $^ -o $@ $(GL_LIBS) $(UI_LIBS) -lm
+
+texobj: texobj.o $(UI_OBJS) $(GL_DEPS)
+ $(CC) $(LFLAGS) $^ -o $@ $(GL_LIBS) $(UI_LIBS) -lm
+
+gears: gears.o $(UI_OBJS) $(GL_DEPS)
+ $(CC) $(LFLAGS) $^ -o $@ $(GL_LIBS) $(UI_LIBS) -lm
+
+spin: spin.o $(UI_OBJS) $(GL_DEPS)
+ $(CC) $(LFLAGS) $^ -o $@ $(GL_LIBS) $(UI_LIBS) -lm
+
+.c.o:
+ $(CC) $(CFLAGS) $(GL_INCLUDES) $(UI_INCLUDES) -c $*.c
+
+mech.o: glu.h
+
+glu.o: glu.h
+
+ui.o: ui.h