aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2012-10-10 10:35:17 +0200
committerJoel Bodenmann <joel@unormal.org>2012-10-10 10:35:17 +0200
commit19afa19bd31a28afbca3666858c7a168bd5c9954 (patch)
tree37e5374adef90709262747d55391598337fd40b3
parentdc6f90d35a55bad642d75cbea15a02e029efda69 (diff)
downloaduGFX-19afa19bd31a28afbca3666858c7a168bd5c9954.tar.gz
uGFX-19afa19bd31a28afbca3666858c7a168bd5c9954.tar.bz2
uGFX-19afa19bd31a28afbca3666858c7a168bd5c9954.zip
SSD1289 cleanup
-rw-r--r--drivers/gdisp/SSD1289/gdisp_lld.c4
-rw-r--r--drivers/gdisp/SSD1289/gdisp_lld_config.h4
-rw-r--r--drivers/gdisp/SSD1289/readme.txt4
3 files changed, 8 insertions, 4 deletions
diff --git a/drivers/gdisp/SSD1289/gdisp_lld.c b/drivers/gdisp/SSD1289/gdisp_lld.c
index f270982d..8f3e0d5a 100644
--- a/drivers/gdisp/SSD1289/gdisp_lld.c
+++ b/drivers/gdisp/SSD1289/gdisp_lld.c
@@ -19,8 +19,8 @@
*/
/**
- * @file gdispSsd1289/gdisp_lld.c
- * @brief GDISP Graphics Driver subsystem low level driver source for the Ssd1289 display.
+ * @file drivers/gdisp/SSD1289/gdisp_lld.c
+ * @brief GDISP Graphics Driver subsystem low level driver source for the SSD1289 display.
*
* @addtogroup GDISP
* @{
diff --git a/drivers/gdisp/SSD1289/gdisp_lld_config.h b/drivers/gdisp/SSD1289/gdisp_lld_config.h
index 99884c29..9ae204bb 100644
--- a/drivers/gdisp/SSD1289/gdisp_lld_config.h
+++ b/drivers/gdisp/SSD1289/gdisp_lld_config.h
@@ -19,8 +19,8 @@
*/
/**
- * @file gdispSsd1289/gdisp_lld_config.h
- * @brief GDISP Graphic Driver subsystem low level driver header for the Ssd1289 display.
+ * @file drivers/gdisp/SSD1289/gdisp_lld_config.h
+ * @brief GDISP Graphic Driver subsystem low level driver header for the SSD1289 display.
*
* @addtogroup GDISP
* @{
diff --git a/drivers/gdisp/SSD1289/readme.txt b/drivers/gdisp/SSD1289/readme.txt
index b767576d..08aa4f60 100644
--- a/drivers/gdisp/SSD1289/readme.txt
+++ b/drivers/gdisp/SSD1289/readme.txt
@@ -2,14 +2,18 @@ To use this driver:
1. Add in your halconf.h:
a) #define HAL_USE_GDISP TRUE
+
b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
+
c) One (only) of:
#define GDISP_USE_GPIO
#define GDISP_USE_SPI
#define GDISP_USE_FSMC
+
d) All of the following (with appropriate values):
#define SCREEN_WIDTH 320
#define SCREEN_HEIGHT 240
2. To your makefile add the following lines:
include $(GFXLIB)/drivers/gdisp/SSD1289/gdisp_lld.mk
+