aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTectu <joel@unormal.org>2012-08-09 01:21:30 +0200
committerTectu <joel@unormal.org>2012-08-09 01:21:30 +0200
commit1c0212bb2b13624076fafb5acf627af858a4a27b (patch)
treeb85fe983fb3af5e56a0907545afca2602264163e
parent22d66771f2a9d85eaf96e5ae2fba4b4ac0f3bce3 (diff)
downloaduGFX-1c0212bb2b13624076fafb5acf627af858a4a27b.tar.gz
uGFX-1c0212bb2b13624076fafb5acf627af858a4a27b.tar.bz2
uGFX-1c0212bb2b13624076fafb5acf627af858a4a27b.zip
Revert "added touchpad driver structure for halext"
This reverts commit 22d66771f2a9d85eaf96e5ae2fba4b4ac0f3bce3.
-rw-r--r--halext/drivers/touchpad/touchpadXPT2046/readme.txt17
-rw-r--r--halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.c336
-rw-r--r--halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.mk6
-rw-r--r--halext/drivers/touchpad/touchpadXPT2046/touchpad_lld_config.h45
4 files changed, 0 insertions, 404 deletions
diff --git a/halext/drivers/touchpad/touchpadXPT2046/readme.txt b/halext/drivers/touchpad/touchpadXPT2046/readme.txt
deleted file mode 100644
index 83611acf..00000000
--- a/halext/drivers/touchpad/touchpadXPT2046/readme.txt
+++ /dev/null
@@ -1,17 +0,0 @@
-This low level driver is a test stub that doesn't talk to any
-real hardware. It is included to allow testing of the compilation
-process.
-
-Do not use this driver as a template for new drivers. Use the
- templates/gdispXXXXX directory for that.
-
-To use this driver:
-
-1. Add in your halconf.h:
- a) #define HAL_USE_GDISP TRUE
- b) Any optional high level driver defines (see gdisp.h)
- you want to compile test eg: GDISP_NEED_MULTITHREAD
-
-2. To your makefile add the following lines:
- include $(CHIBIOS)/os/halext/halext.mk
- include $(CHIBIOS)/os/halext/drivers/gdispTestStub/gdisp_lld.mk
diff --git a/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.c b/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.c
deleted file mode 100644
index 44431e30..00000000
--- a/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.c
+++ /dev/null
@@ -1,336 +0,0 @@
-/*
- ChibiOS/RT - Copyright (C) 2012
- Joel Bodenmann aka Tectu <joel@unormal.org>
-
- This file is part of ChibiOS-LCD-Driver.
-
- ChibiOS-LCD-Driver is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 3 of the License, or
- (at your option) any later version.
-
- ChibiOS-LCD-Driver is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-/**
- * @file gdispTestStub/gdisp_lld.c
- * @brief GDISP Graphics Driver subsystem low level driver source (stub).
- *
- * @addtogroup GDISP
- * @{
- */
-
-#include "ch.h"
-#include "hal.h"
-#include "gdisp.h"
-
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
-
-/*===========================================================================*/
-/* Driver local definitions. */
-/*===========================================================================*/
-
-#ifdef UNUSED
-#elif defined(__GNUC__)
-# define UNUSED(x) UNUSED_ ## x __attribute__((unused))
-#elif defined(__LCLINT__)
-# define UNUSED(x) /*@unused@*/ x
-#else
-# define UNUSED(x) x
-#endif
-
-/*===========================================================================*/
-/* Driver exported variables. */
-/*===========================================================================*/
-
-#if !defined(__DOXYGEN__)
- GDISPDriver GDISP;
-#endif
-
-/*===========================================================================*/
-/* Driver local variables. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver local functions. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver interrupt handlers. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver exported functions. */
-/*===========================================================================*/
-
-/* ---- Required Routines ---- */
-/*
- The following 2 routines are required.
- All other routines are optional.
-*/
-
-/**
- * @brief Low level GDISP driver initialization.
- *
- * @notapi
- */
-void gdisp_lld_init(void) {
- /* Initialise the GDISP structure */
- GDISP.Width = 128;
- GDISP.Height = 128;
- GDISP.Orientation = portrait;
- GDISP.Powermode = powerOff;
-}
-
-/**
- * @brief Draws a pixel on the display.
- *
- * @param[in] x X location of the pixel
- * @param[in] y Y location of the pixel
- * @param[in] color The color of the pixel
- *
- * @notapi
- */
-void gdisp_lld_drawpixel(coord_t UNUSED(x), coord_t UNUSED(y), color_t UNUSED(color)) {
-}
-
-/* ---- Optional Routines ---- */
-/*
- All the below routines are optional.
- Defining them will increase speed but everything
- will work if they are not defined.
- If you are not using a routine - turn it off using
- the appropriate GDISP_HARDWARE_XXXX macro.
- Don't bother coding for obvious similar routines if
- there is no performance penalty as the emulation software
- makes a good job of using similar routines.
- eg. If gdisp_lld_fillarea() is defined there is little
- point in defining gdisp_lld_clear() unless the
- performance bonus is significant.
- For good performance it is suggested to implement
- gdisp_lld_fillarea() and gdisp_lld_blitarea().
-*/
-
-#if GDISP_HARDWARE_CLEARS || defined(__DOXYGEN__)
- /**
- * @brief Clear the display.
- * @note Optional - The high level driver can emulate using software.
- *
- * @param[in] color The color of the pixel
- *
- * @notapi
- */
- void gdisp_lld_clear(color_t UNUSED(color)) {
- }
-#endif
-
-#if GDISP_HARDWARE_LINES || defined(__DOXYGEN__)
- /**
- * @brief Draw a line.
- * @note Optional - The high level driver can emulate using software.
- *
- * @param[in] x0, y0 The start of the line
- * @param[in] x1, y1 The end of the line
- * @param[in] color The color of the line
- *
- * @notapi
- */
- void gdisp_lld_drawline(coord_t UNUSED(x0), coord_t UNUSED(y0), coord_t UNUSED(x1), coord_t UNUSED(y1), color_t UNUSED(color)) {
- }
-#endif
-
-#if GDISP_HARDWARE_FILLS || defined(__DOXYGEN__)
- /**
- * @brief Fill an area with a color.
- * @note Optional - The high level driver can emulate using software.
- *
- * @param[in] x, y The start filled area
- * @param[in] cx, cy The width and height to be filled
- * @param[in] color The color of the fill
- *
- * @notapi
- */
- void gdisp_lld_fillarea(coord_t UNUSED(x), coord_t UNUSED(y), coord_t UNUSED(cx), coord_t UNUSED(cy), color_t UNUSED(color)) {
- }
-#endif
-
-#if GDISP_HARDWARE_BITFILLS || defined(__DOXYGEN__)
- /**
- * @brief Fill an area with a bitmap.
- * @note Optional - The high level driver can emulate using software.
- *
- * @param[in] x, y The start filled area
- * @param[in] cx, cy The width and height to be filled
- * @param[in] buffer The pixels to use to fill the area.
- *
- * @notapi
- */
- void gdisp_lld_blitarea(coord_t UNUSED(x), coord_t UNUSED(y), coord_t UNUSED(cx), coord_t UNUSED(cy), pixel_t *UNUSED(buffer)) {
- }
-#endif
-
-/* Circular Drawing Functions */
-#if (GDISP_NEED_CIRCLE && GDISP_HARDWARE_CIRCLES) || defined(__DOXYGEN__)
- /**
- * @brief Draw a circle.
- * @note Optional - The high level driver can emulate using software.
- * @note If GDISP_NEED_CLIPPING is defined this routine MUST behave
- * correctly if the circle is over the edges of the screen.
- *
- * @param[in] x, y The centre of the circle
- * @param[in] radius The radius of the circle
- * @param[in] color The color of the circle
- *
- * @notapi
- */
- void gdisp_lld_drawcircle(coord_t UNUSED(x), coord_t UNUSED(y), coord_t UNUSED(radius), color_t UNUSED(color)) {
- }
-#endif
-
-#if (GDISP_NEED_CIRCLE && GDISP_HARDWARE_CIRCLEFILLS) || defined(__DOXYGEN__)
- /**
- * @brief Create a filled circle.
- * @note Optional - The high level driver can emulate using software.
- * @note If GDISP_NEED_CLIPPING is defined this routine MUST behave
- * correctly if the circle is over the edges of the screen.
- *
- * @param[in] x, y The centre of the circle
- * @param[in] radius The radius of the circle
- * @param[in] color The color of the circle
- *
- * @notapi
- */
- void gdisp_lld_fillcircle(coord_t UNUSED(x), coord_t UNUSED(y), coord_t UNUSED(radius), color_t UNUSED(color)) {
- }
-#endif
-
-#if (GDISP_NEED_ELLIPSE && GDISP_HARDWARE_ELLIPSES) || defined(__DOXYGEN__)
- /**
- * @brief Draw an ellipse.
- * @note Optional - The high level driver can emulate using software.
- * @note If GDISP_NEED_CLIPPING is defined this routine MUST behave
- * correctly if the ellipse is over the edges of the screen.
- *
- * @param[in] x, y The centre of the ellipse
- * @param[in] a, b The dimensions of the ellipse
- * @param[in] color The color of the ellipse
- *
- * @notapi
- */
- void gdisp_lld_drawellipse(coord_t UNUSED(x), coord_t UNUSED(y), coord_t UNUSED(a), coord_t UNUSED(b), color_t UNUSED(color)) {
- }
-#endif
-
-#if (GDISP_NEED_ELLIPSE && GDISP_HARDWARE_ELLIPSEFILLS) || defined(__DOXYGEN__)
- /**
- * @brief Create a filled ellipse.
- * @note Optional - The high level driver can emulate using software.
- * @note If GDISP_NEED_CLIPPING is defined this routine MUST behave
- * correctly if the ellipse is over the edges of the screen.
- *
- * @param[in] x, y The centre of the ellipse
- * @param[in] a, b The dimensions of the ellipse
- * @param[in] color The color of the ellipse
- *
- * @notapi
- */
- void gdisp_lld_fillellipse(coord_t UNUSED(x), coord_t UNUSED(y), coord_t UNUSED(a), coord_t UNUSED(b), color_t UNUSED(color)) {
- }
-#endif
-
-#if (GDISP_NEED_TEXT && GDISP_HARDWARE_TEXT) || defined(__DOXYGEN__)
- /**
- * @brief Draw a character using a transparent background.
- * @note Optional - The high level driver can emulate using software.
- *
- * @param[in] x, y The top-left corner of the text
- * @param[in] c The character to print
- * @param[in] color The color of the character
- *
- * @notapi
- */
- void gdisp_lld_drawchar(coord_t UNUSED(x), coord_t UNUSED(y), char UNUSED(c), font_t UNUSED(font), color_t UNUSED(color)) {
- }
-#endif
-
-#if (GDISP_NEED_TEXT && GDISP_HARDWARE_TEXTFILLS) || defined(__DOXYGEN__)
- /**
- * @brief Draw a character using a filled background.
- * @note Optional - The high level driver can emulate using software.
- *
- * @param[in] x, y The top-left corner of the text
- * @param[in] c The character to print
- * @param[in] color The color of the character
- * @param[in] bgcolor The background color
- *
- * @notapi
- */
- void gdisp_lld_fillchar(coord_t UNUSED(x), coord_t UNUSED(y), char UNUSED(c), font_t UNUSED(font), color_t UNUSED(color), color_t UNUSED(bgcolor)) {
- }
-#endif
-
-#if (GDISP_NEED_PIXELREAD && GDISP_HARDWARE_PIXELREAD) || defined(__DOXYGEN__)
- /**
- * @brief Get the color of a particular pixel.
- * @note Optional.
- * @note If x,y is off the screen, the result is undefined.
- *
- * @param[in] x, y The start of the text
- *
- * @notapi
- */
- color_t gdisp_lld_getpixelcolor(coord_t UNUSED(x), coord_t UNUSED(y)) {
- return 0;
- }
-#endif
-
-#if (GDISP_NEED_SCROLL && GDISP_HARDWARE_SCROLL) || defined(__DOXYGEN__)
- /**
- * @brief Scroll vertically a section of the screen.
- * @note Optional.
- * @note If x,y + cx,cy is off the screen, the result is undefined.
- * @note If lines is >= cy, it is equivelent to a area fill with bgcolor.
- *
- * @param[in] x, y The start of the area to be scrolled
- * @param[in] cx, cy The size of the area to be scrolled
- * @param[in] lines The number of lines to scroll (Can be positive or negative)
- * @param[in] bgcolor The color to fill the newly exposed area.
- *
- * @notapi
- */
- void gdisp_lld_verticalscroll(coord_t UNUSED(x), coord_t UNUSED(y), coord_t UNUSED(cx), coord_t UNUSED(cy), int UNUSED(lines), color_t UNUSED(bgcolor)) {
- }
-#endif
-
-#if (GDISP_NEED_CONTROL && GDISP_HARDWARE_CONTROL) || defined(__DOXYGEN__)
- /**
- * @brief Driver Control
- * @detail Unsupported control codes are ignored.
- * @note The value parameter should always be typecast to (void *).
- * @note There are some predefined and some specific to the low level driver.
- * @note GDISP_CONTROL_POWER - Takes a gdisp_powermode_t
- * GDISP_CONTROL_ORIENTATION - Takes a gdisp_orientation_t
- * GDISP_CONTROL_BACKLIGHT - Takes an int from 0 to 100. For a driver
- * that only supports off/on anything other
- * than zero is on.
- * GDISP_CONTROL_CONTRAST - Takes an int from 0 to 100.
- * GDISP_CONTROL_LLD - Low level driver control constants start at
- * this value.
- *
- * @param[in] what What to do.
- * @param[in] value The value to use (always cast to a void *).
- *
- * @notapi
- */
- void gdisp_lld_control(int UNUSED(what), void *UNUSED(value)) {
- }
-#endif
-
-#endif /* HAL_USE_GDISP */
-/** @} */
diff --git a/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.mk b/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.mk
deleted file mode 100644
index e97deff8..00000000
--- a/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.mk
+++ /dev/null
@@ -1,6 +0,0 @@
-# List the required driver.
-HLSRC += $(LCDLIB)/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.c
-
-# Required include directories
-HALINC += $(LCDLIB)/halext/drivers/touchpad/touchpadXPT2046
-
diff --git a/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld_config.h b/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld_config.h
deleted file mode 100644
index 675d997a..00000000
--- a/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld_config.h
+++ /dev/null
@@ -1,45 +0,0 @@
-/*
- ChibiOS/RT - Copyright (C) 2012
- Joel Bodenmann aka Tectu <joel@unormal.org>
-
- This file is part of ChibiOS-LCD-Driver.
-
- ChibiOS-LCD-Driver is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 3 of the License, or
- (at your option) any later version.
-
- ChibiOS-LCD-Driver is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-/**
- * @file touchpadXPT2046/touchpad_lld_config.h
- * @brief Touchppad Driver subsystem low level driver.
- *
- * @addtogroup TOUCHPAD
- * @{
- */
-
-#ifndef _TOUCHPAD_LLD_CONFIG_H
-#define _TOUCHPAD_LLD_CONFIG_H
-
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
-
-/*===========================================================================*/
-/* Driver hardware support. */
-/*===========================================================================*/
-
-#define TOUCHPAD_X_DIRECTION TRUE
-#define TOUCHPAD_Y_DIRECTION TRUE
-#define TOUCHPAD_Z_DIRECTION TRUE /* pressure measurement */
-
-#endif /* HAL_USE_TOUCHPAD */
-
-#endif /* _TOUCHPAD_LLD_CONFIG_H */
-/** @} */