aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2013-01-11 15:04:40 +0100
committerJoel Bodenmann <joel@unormal.org>2013-01-11 15:04:40 +0100
commit66bb4ecb853fd3a35fd3154811c70aa1ff316937 (patch)
treeb5044720ce7e590c8bcbc9c6f641ecf0b8055be8
parentdae721900b75d7b8e78bc35e79c4288934bba79d (diff)
parent249a1b345f1064957a6fd187fcdfbbcd3c1fecad (diff)
downloaduGFX-66bb4ecb853fd3a35fd3154811c70aa1ff316937.tar.gz
uGFX-66bb4ecb853fd3a35fd3154811c70aa1ff316937.tar.bz2
uGFX-66bb4ecb853fd3a35fd3154811c70aa1ff316937.zip
Merge branch 'tdisp'
-rw-r--r--demos/modules/gdisp/gdisp_basics/gfxconf.h (renamed from demos/modules/gdisp_basics/gfxconf.h)0
-rw-r--r--demos/modules/gdisp/gdisp_basics/main.c (renamed from demos/modules/gdisp_basics/main.c)0
-rw-r--r--demos/modules/gdisp/gdisp_circles/gfxconf.h (renamed from demos/modules/gdisp_circles/gfxconf.h)0
-rw-r--r--demos/modules/gdisp/gdisp_circles/main.c (renamed from demos/modules/gdisp_circles/main.c)0
-rw-r--r--demos/modules/gdisp/gdisp_text/gfxconf.h (renamed from demos/modules/gdisp_text/gfxconf.h)0
-rw-r--r--demos/modules/gdisp/gdisp_text/main.c (renamed from demos/modules/gdisp_text/main.c)0
-rw-r--r--demos/modules/tdisp/gfxconf.h55
-rw-r--r--demos/modules/tdisp/main.c49
-rw-r--r--drivers/tdisp/HD44780/tdisp_lld.c90
-rw-r--r--drivers/tdisp/HD44780/tdisp_lld.mk6
-rw-r--r--drivers/tdisp/HD44780/tdisp_lld_board_example.h64
-rw-r--r--drivers/tdisp/HD44780/tdisp_lld_config.h44
-rw-r--r--gfx.mk1
-rw-r--r--gfxconf.example.h23
-rw-r--r--include/gfx.h2
-rw-r--r--include/tdisp/lld/tdisp_lld.h52
-rw-r--r--include/tdisp/options.h84
-rw-r--r--include/tdisp/tdisp.h134
-rw-r--r--src/tdisp/tdisp.c113
-rw-r--r--src/tdisp/tdisp.mk2
20 files changed, 711 insertions, 8 deletions
diff --git a/demos/modules/gdisp_basics/gfxconf.h b/demos/modules/gdisp/gdisp_basics/gfxconf.h
index 498046b4..498046b4 100644
--- a/demos/modules/gdisp_basics/gfxconf.h
+++ b/demos/modules/gdisp/gdisp_basics/gfxconf.h
diff --git a/demos/modules/gdisp_basics/main.c b/demos/modules/gdisp/gdisp_basics/main.c
index fa0bef45..fa0bef45 100644
--- a/demos/modules/gdisp_basics/main.c
+++ b/demos/modules/gdisp/gdisp_basics/main.c
diff --git a/demos/modules/gdisp_circles/gfxconf.h b/demos/modules/gdisp/gdisp_circles/gfxconf.h
index 00d88e48..00d88e48 100644
--- a/demos/modules/gdisp_circles/gfxconf.h
+++ b/demos/modules/gdisp/gdisp_circles/gfxconf.h
diff --git a/demos/modules/gdisp_circles/main.c b/demos/modules/gdisp/gdisp_circles/main.c
index 45764d4f..45764d4f 100644
--- a/demos/modules/gdisp_circles/main.c
+++ b/demos/modules/gdisp/gdisp_circles/main.c
diff --git a/demos/modules/gdisp_text/gfxconf.h b/demos/modules/gdisp/gdisp_text/gfxconf.h
index a928806b..a928806b 100644
--- a/demos/modules/gdisp_text/gfxconf.h
+++ b/demos/modules/gdisp/gdisp_text/gfxconf.h
diff --git a/demos/modules/gdisp_text/main.c b/demos/modules/gdisp/gdisp_text/main.c
index 4dc45f71..4dc45f71 100644
--- a/demos/modules/gdisp_text/main.c
+++ b/demos/modules/gdisp/gdisp_text/main.c
diff --git a/demos/modules/tdisp/gfxconf.h b/demos/modules/tdisp/gfxconf.h
new file mode 100644
index 00000000..5077e010
--- /dev/null
+++ b/demos/modules/tdisp/gfxconf.h
@@ -0,0 +1,55 @@
+/**
+ * This file has a different license to the rest of the GFX system.
+ * You can copy, modify and distribute this file as you see fit.
+ * You do not need to publish your source modifications to this file.
+ * The only thing you are not permitted to do is to relicense it
+ * under a different license.
+ */
+
+#ifndef _GFXCONF_H
+#define _GFXCONF_H
+
+/* GFX sub-systems to turn on */
+#define GFX_USE_TDISP TRUE
+#define GFX_USE_GDISP FALSE
+#define GFX_USE_GWIN FALSE
+#define GFX_USE_GEVENT FALSE
+#define GFX_USE_GTIMER FALSE
+#define GFX_USE_GINPUT FALSE
+
+/* Features for the GDISP subsystem */
+#define GDISP_NEED_VALIDATION FALSE
+#define GDISP_NEED_CLIP FALSE
+#define GDISP_NEED_TEXT FALSE
+#define GDISP_NEED_CIRCLE FALSE
+#define GDISP_NEED_ELLIPSE FALSE
+#define GDISP_NEED_ARC FALSE
+#define GDISP_NEED_SCROLL FALSE
+#define GDISP_NEED_PIXELREAD FALSE
+#define GDISP_NEED_CONTROL FALSE
+#define GDISP_NEED_MULTITHREAD FALSE
+#define GDISP_NEED_ASYNC FALSE
+#define GDISP_NEED_MSGAPI FALSE
+
+/* Features for the TDISP subsystem */
+#define TDISP_NEED_4BIT_MODE TRUE
+#define TDISP_NEED_8BIT_MODE FALSE
+
+/* Builtin Fonts */
+#define GDISP_INCLUDE_FONT_SMALL FALSE
+#define GDISP_INCLUDE_FONT_LARGER FALSE
+#define GDISP_INCLUDE_FONT_UI1 FALSE
+#define GDISP_INCLUDE_FONT_UI2 FALSE
+#define GDISP_INCLUDE_FONT_LARGENUMBERS FALSE
+
+/* GWIN */
+#define GWIN_NEED_CONSOLE FALSE
+#define GWIN_NEED_GRAPH FALSE
+#define GWIN_NEED_BUTTON FALSE
+#define GWIN_NEED_DIAL FALSE
+
+/* GINPUT */
+#define GINPUT_NEED_MOUSE FALSE
+
+#endif /* _GFXCONF_H */
+
diff --git a/demos/modules/tdisp/main.c b/demos/modules/tdisp/main.c
new file mode 100644
index 00000000..b67b3b8c
--- /dev/null
+++ b/demos/modules/tdisp/main.c
@@ -0,0 +1,49 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#include "ch.h"
+#include "hal.h"
+#include "gfx.h"
+
+int main(void) {
+ halInit();
+ chSysInit();
+
+ tdispInit();
+
+ tdispHome();
+ tdispClear();
+
+ tdispGotoXY(4, 0);
+ tdispDrawChar('H');
+ tdispDrawChar('D');
+ tdispDrawChar('4');
+ tdispDrawChar('4');
+ tdispDrawChar('7');
+ tdispDrawChar('8');
+ tdispDrawChar('0');
+
+ tdispDrawStringLocation(0, 1, "chibios-gfx.com");
+
+ while(TRUE) {
+ chThdSleepMilliseconds(250);
+ }
+}
+
diff --git a/drivers/tdisp/HD44780/tdisp_lld.c b/drivers/tdisp/HD44780/tdisp_lld.c
new file mode 100644
index 00000000..2e152977
--- /dev/null
+++ b/drivers/tdisp/HD44780/tdisp_lld.c
@@ -0,0 +1,90 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/tdisp/HD44780/tdisp_lld.c
+ * @brief TDISP driver subsystem low level driver source for the HD44780 display
+ *
+ * @addtogroup TDISP
+ * @{
+ */
+
+#include "ch.h"
+#include "hal.h"
+#include "gfx.h"
+
+#if GFX_USE_TDISP /*|| defined(__DOXYGEN__)*/
+
+#include "tdisp_lld_board_example.h"
+
+static void _writeData(uint8_t data) {
+ write_bus(data);
+
+ setpin_e(TRUE);
+ chThdSleepMicroseconds(1);
+ setpin_e(FALSE);
+ chThdSleepMicroseconds(5);
+}
+
+void TDISP_LLD(write_cmd)(uint8_t data) {
+ setpin_rs(FALSE);
+ setpin_rw(FALSE);
+
+ #if TDISP_NEED_4BIT_MODE
+ _writeData(data>>4);
+ #endif
+ _writeData(data);
+}
+
+void TDISP_LLD(write_data)(uint8_t data) {
+ setpin_rs(TRUE);
+ setpin_rw(FALSE);
+
+ #if TDISP_NEED_4BIT_MODE
+ _writeData(data>>4);
+ #endif
+ _writeData(data);
+}
+
+bool_t TDISP_LLD(init)(void) {
+ /* initialise MCU hardware */
+ init_board();
+
+ /* wait some time */
+ chThdSleepMilliseconds(50);
+
+ TDISP_LLD(write_cmd)(0x38);
+ chThdSleepMilliseconds(64);
+
+ TDISP_LLD(write_cmd)(0x0f);
+ chThdSleepMicroseconds(50);
+
+ TDISP_LLD(write_cmd)(0x01);
+ chThdSleepMilliseconds(5);
+
+ TDISP_LLD(write_cmd)(0x06);
+ chThdSleepMicroseconds(50);
+
+ return TRUE;
+}
+
+#endif /* GFX_USE_TDISP */
+/** @} */
+
diff --git a/drivers/tdisp/HD44780/tdisp_lld.mk b/drivers/tdisp/HD44780/tdisp_lld.mk
new file mode 100644
index 00000000..88780bea
--- /dev/null
+++ b/drivers/tdisp/HD44780/tdisp_lld.mk
@@ -0,0 +1,6 @@
+# List the required driver.
+GFXSRC += $(GFXLIB)/drivers/tdisp/HD44780/tdisp_lld.c
+
+# Required include directories
+GFXINC += $(GFXLIB)/drivers/tdisp/HD44780
+
diff --git a/drivers/tdisp/HD44780/tdisp_lld_board_example.h b/drivers/tdisp/HD44780/tdisp_lld_board_example.h
new file mode 100644
index 00000000..3f5c47d7
--- /dev/null
+++ b/drivers/tdisp/HD44780/tdisp_lld_board_example.h
@@ -0,0 +1,64 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/tdisp/HD44780/tdisp_lld_board_example.h
+ * @brief TDISP driver subsystem board interface for the HD44780 display
+ *
+ * @addtogroup TDISP
+ * @{
+ */
+
+#ifndef _TDISP_LLD_BOARD_H
+#define _TDISP_LLD_BOARD_H
+
+void init_board(void) {
+ palSetGroupMode(GPIOE, PAL_WHOLE_PORT, 0, PAL_MODE_OUTPUT_PUSHPULL);
+ palSetGroupMode(GPIOG, PAL_WHOLE_PORT, 0, PAL_MODE_OUTPUT_PUSHPULL);
+}
+
+void setpin_e(bool_t state) {
+ if(state)
+ palSetPad(GPIOE, 2);
+ else
+ palClearPad(GPIOE, 2);
+}
+
+void setpin_rs(bool_t state) {
+ if(state)
+ palSetPad(GPIOE, 0);
+ else
+ palClearPad(GPIOE, 0);
+}
+
+void setpin_rw(bool_t state) {
+ if(state)
+ palSetPad(GPIOE, 1);
+ else
+ palClearPad(GPIOE, 1);
+}
+
+void write_bus(uint8_t data) {
+ palWritePort(GPIOG, data);
+}
+
+#endif /* _TDISP_LLD_BOARD_H */
+/** @} */
+
diff --git a/drivers/tdisp/HD44780/tdisp_lld_config.h b/drivers/tdisp/HD44780/tdisp_lld_config.h
new file mode 100644
index 00000000..7ea80ea2
--- /dev/null
+++ b/drivers/tdisp/HD44780/tdisp_lld_config.h
@@ -0,0 +1,44 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/tdisp/HD44780/tdisp_lld_config.h
+ * @brief TDISP Driver subsystem low level driver header for the HD44780 display.
+ *
+ * @addtogroup TDISP
+ * @{
+ */
+
+#ifndef _TDISP_LLD_CONFIG_H
+#define _TDISP_LLD_CONFIG_H
+
+#if GFX_USE_TDISP
+
+/*===========================================================================*/
+/* Driver hardware support. */
+/*===========================================================================*/
+
+#define TDISP_DRIVER_NAME "HD44780"
+#define TDISP_LLD(x) tdisp_lld_##x##_HD44780
+
+#endif /* GFX_USE_TDISP */
+
+#endif /* _TDISP_LLD_CONFIG_H */
+/** @} */
diff --git a/gfx.mk b/gfx.mk
index 545e3157..c4bb23b2 100644
--- a/gfx.mk
+++ b/gfx.mk
@@ -7,6 +7,7 @@ GFXINC += $(GFXLIB)/include
GFXSRC +=
include $(GFXLIB)/src/gdisp/gdisp.mk
+include $(GFXLIB)/src/tdisp/tdisp.mk
include $(GFXLIB)/src/gevent/gevent.mk
include $(GFXLIB)/src/gtimer/gtimer.mk
include $(GFXLIB)/src/gwin/gwin.mk
diff --git a/gfxconf.example.h b/gfxconf.example.h
index 7bcdab43..82345c2d 100644
--- a/gfxconf.example.h
+++ b/gfxconf.example.h
@@ -14,14 +14,15 @@
#ifndef _GFXCONF_H
#define _GFXCONF_H
-/* GFX sub-systems to turn on */
+/* GFX subsystems to turn on */
#define GFX_USE_GDISP FALSE
+#define GFX_USE_TDISP FALSE
#define GFX_USE_GWIN FALSE
#define GFX_USE_GEVENT FALSE
#define GFX_USE_GTIMER FALSE
#define GFX_USE_GINPUT FALSE
-/* Features for the GDISP sub-system. */
+/* Features for the GDISP subsystem */
#define GDISP_NEED_VALIDATION TRUE
#define GDISP_NEED_CLIP TRUE
#define GDISP_NEED_TEXT TRUE
@@ -35,7 +36,7 @@
#define GDISP_NEED_ASYNC FALSE
#define GDISP_NEED_MSGAPI FALSE
-/* Builtin Fonts */
+/* GDISP - builtin fonts */
#define GDISP_OLD_FONT_DEFINITIONS FALSE
#define GDISP_INCLUDE_FONT_SMALL TRUE
#define GDISP_INCLUDE_FONT_LARGER TRUE
@@ -43,24 +44,30 @@
#define GDISP_INCLUDE_FONT_UI2 TRUE
#define GDISP_INCLUDE_FONT_LARGENUMBERS TRUE
-/* Features for the GWIN sub-system. */
+/* TDISP options */
+#define TDISP_COLUMNS 16
+#define TDISP_ROWS 2
+#define TDISP_NEED_4BIT_MODE FALSE
+#define TDISP_NEED_8BIT_MODE FALSE
+
+/* Features for the GWIN subsystem. */
#define GWIN_NEED_BUTTON FALSE
#define GWIN_NEED_CONSOLE FALSE
#define GWIN_NEED_GRAPH FALSE
-/* Features for the GEVENT sub-system. */
+/* Features for the GEVENT subsystem. */
#define GEVENT_ASSERT_NO_RESOURCE FALSE
-/* Features for the GTIMER sub-system. */
+/* Features for the GTIMER subsystem. */
/* NONE */
-/* Features for the GINPUT sub-system. */
+/* Features for the GINPUT subsystem. */
#define GINPUT_NEED_MOUSE FALSE
#define GINPUT_NEED_KEYBOARD FALSE
#define GINPUT_NEED_TOGGLE FALSE
#define GINPUT_NEED_DIAL FALSE
-/* Optional Parameters for various sub-systems */
+/* Optional Parameters for various subsystems */
/*
#define GDISP_MAX_FONT_HEIGHT 16
#define GEVENT_MAXIMUM_SIZE 32
diff --git a/include/gfx.h b/include/gfx.h
index 9dfe681a..b6107de6 100644
--- a/include/gfx.h
+++ b/include/gfx.h
@@ -94,6 +94,7 @@
#include "gdisp/options.h"
#include "gwin/options.h"
#include "ginput/options.h"
+#include "tdisp/options.h"
/**
* Inter-dependancy safety checks on the sub-systems.
@@ -109,6 +110,7 @@
#include "gdisp/gdisp.h"
#include "gwin/gwin.h"
#include "ginput/ginput.h"
+#include "tdisp/tdisp.h"
#endif /* _GFX_H */
/** @} */
diff --git a/include/tdisp/lld/tdisp_lld.h b/include/tdisp/lld/tdisp_lld.h
new file mode 100644
index 00000000..a8f2e4b1
--- /dev/null
+++ b/include/tdisp/lld/tdisp_lld.h
@@ -0,0 +1,52 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file include/tdisp/lld/tdisp_lld.h
+ * @brief TDISP driver subsystem low level driver header.
+ *
+ * @addtogroup TDISP
+ * @{
+ */
+
+#ifndef _TDISP_LLD_H
+#define _TDISP_LLD_H
+
+#if GFX_USE_TDISP || defined(__DOXYGEN__)
+
+#include "tdisp_lld_config.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+extern bool_t foo(void);
+extern void write_cmd(uint8_t data);
+extern void write_data(uint8_t data);
+
+#ifdef __cplusplus
+}
+#endif
+
+#endif /* GFX_USE_TDISP */
+
+#endif /* _TDISP_LLD_H */
+/** @} */
+
diff --git a/include/tdisp/options.h b/include/tdisp/options.h
new file mode 100644
index 00000000..a7bab720
--- /dev/null
+++ b/include/tdisp/options.h
@@ -0,0 +1,84 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file include/tdisp/options.h
+ * @brief TDISP sub-system options header file.
+ *
+ * @addtogroup TDISP
+ * @{
+ */
+
+#ifndef _TDISP_OPTIONS_H
+#define _TDISP_OPTIONS_H
+
+/**
+ * @name TDISP configuration
+ * @{
+ */
+
+ /**
+ * @brief How many rows of characters the TDISP provides
+ */
+ #ifndef TDISP_ROWS
+ #define TDISP_ROWS 2
+ #endif
+
+ /**
+ * @brief How many columns of characters the TDISP provides
+ */
+ #ifndef TDISP_COLUMNS
+ #define TDISP_COLUMNS 16
+ #endif
+
+/** @} */
+
+/**
+ * @name TDISP interface configuration
+ * @note Only one of these interfaces can be selected at a time!
+ * @{
+ */
+ /**
+ * @brief Use the 4-bit paralle interface
+ */
+ #ifndef TDISP_NEED_4BIT_MODE
+ #define TDISP_NEED_4BIT_MODE FALSE
+ #endif
+
+ /**
+ * @brief Use the 8-bit parallel interface
+ */
+ #ifndef TDISP_NEED_8BIT_MODE
+ #define TDISP_NEED_8BIT_MODE FALSE
+ #endif
+
+ #if (!TDISP_NEED_4BIT_MODE && !TDISP_NEED_8BIT_MODE)
+ #error "Either TDISP_NEED_4BIT_MODE or TDISP_NEED_8BIT_MODE needs to be set to TRUE in your gfxconf.h!"
+ #endif
+
+ #if (TDISP_NEED_4BIT_MODE && TDISP_NEED_8BIT_MODE)
+ #error "Only TDISP_NEED_4BIT_MODE or TDISP_NEED_8BIT_MODE can be set to TRUE, not both at one!"
+ #endif
+
+/** @} */
+
+#endif /* _TDISP_OPTIONS_H */
+/** @} */
+
diff --git a/include/tdisp/tdisp.h b/include/tdisp/tdisp.h
new file mode 100644
index 00000000..58de7af2
--- /dev/null
+++ b/include/tdisp/tdisp.h
@@ -0,0 +1,134 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file include/tdisp/tdisp.h
+ * @brief TDISP Graphic Driver subsystem header file.
+ *
+ * @addtogroup TDISP
+ *
+ * @details The TDISP module provides high level abstraction to interface pixel oriented graphic displays.
+ *
+ * @pre GFX_USE_TDISP must be set to TRUE in gfxconf.h
+ *
+ * @{
+ */
+
+#ifndef _TDISP_H
+#define _TDISP_H
+
+#include "gfx.h"
+
+#if GFX_USE_TDISP || defined(__DOXYGEN__)
+
+/* Include the low level driver information */
+#include "tdisp/lld/tdisp_lld.h"
+
+/**
+ * @name TDISP display attributes
+ * @{
+ */
+#define TDISP_ON 0x01
+#define TDISP_OFF 0x02
+#define TDISP_CURSOR_ON 0x03
+#define TDISP_CURSOR_OFF 0x04
+#define TDISP_CURSOR_BLINK_ON 0x05
+#define TDISP_CURSOR_BLINK_OFF 0x06
+/** @} */
+
+/**
+ * @brief TDISP driver initialisation
+ * @note This function is not implicitly invoked by @p halInit().
+ * It must be called manually.
+ *
+ * @return TRUE if success, FALSE otherwise
+ *
+ * @init
+ */
+bool_t tdispInit(void);
+
+/**
+ * @brief Control different display properties
+ * @note Multiple attributes can be passed using the OR operator.
+ * @note Example: TDISP_DISPLAY_ON | TDISP_CURSOR_BLINK
+ *
+ * @param[in] attributes The attributes
+ */
+void tdispSetAttributes(uint8_t attributes);
+
+/**
+ * @brief Clears the display
+ */
+void tdispClear(void);
+
+/**
+ * @brief Sets the cursor to it's home position ( 0/0 )
+ */
+void tdispHome(void);
+
+/**
+ * @brief Set cursor to a certain position
+ *
+ * @param[in] col The column
+ * @param[in] row The row
+ */
+void tdispGotoXY(coord_t col, coord_t row);
+
+/**
+ * @brief Draws a single character at the current cursor position
+ *
+ * @param[in] c The character to be drawn
+ */
+void tdispDrawChar(char c);
+
+/**
+ * @brief Draws a string at the current cursor position
+ *
+ * @param[in] s The string to be drawn
+ */
+void tdispDrawString(char *s);
+
+/**
+ * @brief Draws a single character at a given position
+ * @note This function manipulates the cursor position and it will not be
+ * reset to it's original state
+ *
+ * @param[in] col The column
+ * @param[in] row The row
+ * @param[in] c The character to be drawn
+ */
+void tdispDrawCharLocation(coord_t col, coord_t row, char c);
+
+/**
+ * @brief Draws a string at a given position
+ * @note This function manipulates the cursor position and it will not be
+ * reset to it's original state
+ *
+ * @param[in] col The column
+ * @param[in] row The row
+ * @param[in] s The string to be drawn
+ */
+void tdispDrawStringLocation(coord_t col, coord_t row, char *s);
+
+#endif /* GFX_USE_TDISP */
+
+#endif /* _TDISP_H */
+/** @} */
+
diff --git a/src/tdisp/tdisp.c b/src/tdisp/tdisp.c
new file mode 100644
index 00000000..d57bae56
--- /dev/null
+++ b/src/tdisp/tdisp.c
@@ -0,0 +1,113 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file src/tdisp/tdisp.c
+ * @brief TDISP Driver code.
+ *
+ * @addtogroup TDISP
+ * @{
+ */
+#include "ch.h"
+#include "hal.h"
+#include "gfx.h"
+
+#if GFX_USE_TDISP || defined(__DOXYGEN__)
+
+static uint8_t _displaycontrol;
+
+bool_t tdispInit(void) {
+ bool_t ret;
+
+ ret = TDISP_LLD(init)();
+
+ return ret;
+}
+
+void tdispSetAttributes(uint8_t attributes) {
+ switch(attributes) {
+ case TDISP_ON:
+ _displaycontrol |= 0x04;
+ TDISP_LLD(write_cmd)(0x08 | _displaycontrol);
+ break;
+ case TDISP_OFF:
+ _displaycontrol &=~ 0x04;
+ TDISP_LLD(write_cmd)(0x08 | _displaycontrol);
+ break;
+ case TDISP_CURSOR_ON:
+ _displaycontrol |= 0x02;
+ TDISP_LLD(write_cmd)(0x08 | _displaycontrol);
+ break;
+ case TDISP_CURSOR_OFF:
+ _displaycontrol &=~ 0x02;
+ TDISP_LLD(write_cmd)(0x08 | _displaycontrol);
+ break;
+ case TDISP_CURSOR_BLINK_ON:
+ _displaycontrol |= 0x00;
+ TDISP_LLD(write_cmd)(0x08 | _displaycontrol);
+ break;
+ case TDISP_CURSOR_BLINK_OFF:
+ _displaycontrol &=~ 0x00;
+ TDISP_LLD(write_cmd)(0x08 | _displaycontrol);
+ break;
+ }
+}
+
+void tdispClear(void) {
+ TDISP_LLD(write_cmd)(0x01);
+}
+
+void tdispHome(void) {
+ TDISP_LLD(write_cmd)(0x02);
+}
+
+void tdispGotoXY(coord_t col, coord_t row) {
+ uint8_t row_offsets[] = { 0x00, 0x40, 0x14, 0x54 };
+
+ if(row >= TDISP_ROWS)
+ row = TDISP_ROWS - 1;
+
+ TDISP_LLD(write_cmd)(0x80 | (col + row_offsets[row]));
+}
+
+void tdispDrawChar(char c) {
+ TDISP_LLD(write_data)(c);
+}
+
+void tdispDrawString(char *s) {
+ char c;
+
+ while(c = *s++)
+ tdispDrawChar(c);
+}
+
+void tdispDrawCharLocation(coord_t col, coord_t row, char c) {
+ tdispGotoXY(col, row);
+ tdispDrawChar(c);
+}
+
+void tdispDrawStringLocation(coord_t col, coord_t row, char *s) {
+ tdispGotoXY(col, row);
+ tdispDrawString(s);
+}
+
+#endif /* GFX_USE_TDISP */
+/** @} */
+
diff --git a/src/tdisp/tdisp.mk b/src/tdisp/tdisp.mk
new file mode 100644
index 00000000..a33fa34a
--- /dev/null
+++ b/src/tdisp/tdisp.mk
@@ -0,0 +1,2 @@
+GFXSRC += $(GFXLIB)/src/tdisp/tdisp.c
+