aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2013-10-28 10:48:09 +1000
committerinmarket <andrewh@inmarket.com.au>2013-10-28 10:48:09 +1000
commit9e5ed28f98e7b0b3dbd46df7a62568dbaffab92a (patch)
tree4c700436e1d78f576d5e79a74a7b69b6e2742639
parent26f4bec2be1ebfc8edf66d33cb8edb04d3b1049a (diff)
downloaduGFX-9e5ed28f98e7b0b3dbd46df7a62568dbaffab92a.tar.gz
uGFX-9e5ed28f98e7b0b3dbd46df7a62568dbaffab92a.tar.bz2
uGFX-9e5ed28f98e7b0b3dbd46df7a62568dbaffab92a.zip
New ILI9341 driver - not working fully yet (some display issues)
-rw-r--r--drivers/gdisp/ILI9341/ILI9341.h87
-rw-r--r--drivers/gdisp/ILI9341/board_ILI9341_mikromedia.h130
-rw-r--r--drivers/gdisp/ILI9341/board_ILI9341_template.h154
-rw-r--r--drivers/gdisp/ILI9341/gdisp_lld.c373
-rw-r--r--drivers/gdisp/ILI9341/gdisp_lld.mk2
-rw-r--r--drivers/gdisp/ILI9341/gdisp_lld_config.h36
6 files changed, 782 insertions, 0 deletions
diff --git a/drivers/gdisp/ILI9341/ILI9341.h b/drivers/gdisp/ILI9341/ILI9341.h
new file mode 100644
index 00000000..bace6907
--- /dev/null
+++ b/drivers/gdisp/ILI9341/ILI9341.h
@@ -0,0 +1,87 @@
+
+#define LCD_VERTICAL_MAX 320
+#define LCD_HORIZONTAL_MAX 240
+
+#define ILI9341_DEVICE_CODE_READ_REG 0x00
+#define ILI9341_SOFT_RESET_REG 0x01
+#define ILI9341_IDENTINFO_R_REG 0x04
+#define ILI9341_STATUS_R_REG 0x09
+#define ILI9341_POWERMODE_R_REG 0x0A
+#define ILI9341_MADCTL_R_REG 0x0B
+#define ILI9341_PIXFORMAT_R_REG 0x0C
+#define ILI9341_IMGFORMAT_R_REG 0x0D
+#define ILI9341_SIGMODE_R_REG 0x0E
+#define ILI9341_SD_RESULT_R_REG 0x0F
+#define ILI9341_SLEEP_ENTER_REG 0x10
+#define ILI9341_SLEEP_OUT_REG 0x11
+#define ILI9341_PARTIALMODE_REG 0x12
+#define ILI9341_NORDISPMODE_REG 0x13
+#define ILI9341_INVERSIONOFF_REG 0x20
+#define ILI9341_INVERSIONON_REG 0x21
+#define ILI9341_GAMMASET_REG 0x26
+#define ILI9341_DISPLAYOFF_REG 0x28
+#define ILI9341_DISPLAYON_REG 0x29
+#define ILI9341_COLADDRSET_REG 0x2A
+#define ILI9341_PAGEADDRSET_REG 0x2B
+#define ILI9341_MEMORYWRITE_REG 0x2C
+#define ILI9341_COLORSET_REG 0x2D
+#define ILI9341_MEMORYREAD_REG 0x2E
+#define ILI9341_PARTIALAREA_REG 0x30
+#define ILI9341_VERTSCROLL_REG 0x33
+#define ILI9341_TEAREFFECTLINEOFF_REG 0x34
+#define ILI9341_TEAREFFECTLINEON_REG 0x35
+#define ILI9341_MEMACCESS_REG 0x36
+#define ILI9341_VERSCRSRART_REG 0x37
+#define ILI9341_IDLEMODEOFF_REG 0x38
+#define ILI9341_IDLEMODEON_REG 0x39
+#define ILI9341_PIXFORMATSET_REG 0x3A
+#define ILI9341_WRITEMEMCONTINUE_REG 0x3C
+#define ILI9341_READMEMCONTINUE_REG 0x3E
+#define ILI9341_SETTEATSCAN_REG 0x44
+#define ILI9341_GETSCANLINE_REG 0x45
+#define ILI9341_WRITEBRIGHT_REG 0x51
+#define ILI9341_READBRIGHT_REG 0x52
+#define ILI9341_WRITECTRL_REG 0x53
+#define ILI9341_READCTRL_REG 0x54
+#define ILI9341_WRITECABC_REG 0x55
+#define ILI9341_READCABC_REG 0x56
+#define ILI9341_WRITECABCMB_REG 0x5E
+#define ILI9341_READCABCMB_REG 0x5F
+#define ILI9341_RGB_ISCTL_REG 0xB0
+#define ILI9341_FRAMECTL_NOR_REG 0xB1
+#define ILI9341_FRAMECTL_IDLE_REG 0xB2
+#define ILI9341_FRAMECTL_PARTIAL_REG 0xB3
+#define ILI9341_INVERCTL_REG 0xB4
+#define ILI9341_BLANKPORCTL_REG 0xB5
+#define ILI9341_FUNCTONCTL_REG 0xB6
+#define ILI9341_ENTRYMODE_REG 0xB7
+#define ILI9341_BLIGHTCTL1_REG 0xB8
+#define ILI9341_BLIGHTCTL2_REG 0xB9
+#define ILI9341_BLIGHTCTL3_REG 0xBA
+#define ILI9341_BLIGHTCTL4_REG 0xBB
+#define ILI9341_BLIGHTCTL5_REG 0xBC
+#define ILI9341_BLIGHTCTL7_REG 0xBE
+#define ILI9341_BLIGHTCTL8_REG 0xBF
+#define ILI9341_POWERCTL1_REG 0xC0
+#define ILI9341_POWERCTL2_REG 0xC1
+#define ILI9341_VCOMCTL1_REG 0xC5
+#define ILI9341_VCOMCTL2_REG 0xC7
+#define ILI9341_POWERCTLA_REG 0xCB
+#define ILI9341_POWERCTLB_REG 0xCF
+#define ILI9341_NVMEMWRITE_REG 0xD0
+#define ILI9341_NVMEMPROTECTKEY_REG 0xD1
+#define ILI9341_NVMEMSTATUS_REG 0xD2
+#define ILI9341_READID4_REG 0xD3
+#define ILI9341_READID1_REG 0xDA
+#define ILI9341_READID2_REG 0xDB
+#define ILI9341_READID3_REG 0xDC
+#define ILI9341_POSGAMMACORRECTION_REG 0xE0
+#define ILI9341_NEGGAMMACORRECTION_REG 0xE1
+#define ILI9341_DIGGAMCTL1_REG 0xE2
+#define ILI9341_DIGGAMCTL2_REG 0xE3
+#define ILI9341_DIVTIMCTL_A_REG 0xE8
+#define ILI9341_DIVTIMCTL_B_REG 0xEA
+#define ILI9341_POWONSEQCTL_REG 0xED
+#define ILI9341_ENABLE_3G_REG 0xF2
+#define ILI9341_INTERFCTL_REG 0xF6
+#define ILI9341_PUMPRATIOCTL_REG 0xF7
diff --git a/drivers/gdisp/ILI9341/board_ILI9341_mikromedia.h b/drivers/gdisp/ILI9341/board_ILI9341_mikromedia.h
new file mode 100644
index 00000000..a0eed13b
--- /dev/null
+++ b/drivers/gdisp/ILI9341/board_ILI9341_mikromedia.h
@@ -0,0 +1,130 @@
+/*
+ * This file is subject to the terms of the GFX License. If a copy of
+ * the license was not distributed with this file, you can obtain one at:
+ *
+ * http://ugfx.org/license.html
+ */
+
+/**
+ * @file drivers/gdisp/ILI9341/board_ILI9341_mikromedia.h
+ * @brief GDISP Graphics Driver subsystem low level driver source for the ILI9341 display.
+ */
+
+#ifndef _GDISP_LLD_BOARD_H
+#define _GDISP_LLD_BOARD_H
+
+// For a multiple display configuration we would put all this in a structure and then
+// set g->board to that structure.
+#define SET_CS palSetPad(GPIOE, GPIOE_LCD_CS);
+#define CLR_CS palClearPad(GPIOE, GPIOE_LCD_CS);
+#define SET_RS palSetPad(GPIOE, GPIOE_LCD_RS);
+#define CLR_RS palClearPad(GPIOE, GPIOE_LCD_RS);
+#define SET_WR palSetPad(GPIOE, GPIOE_PMWR);
+#define CLR_WR palClearPad(GPIOE, GPIOE_PMWR);
+#define SET_RD palSetPad(GPIOE, GPIOE_PMRD);
+#define CLR_RD palClearPad(GPIOE, GPIOE_PMRD);
+
+static inline void init_board(GDisplay *g) {
+
+ // As we are not using multiple displays we set g->board to NULL as we don't use it.
+ g->board = 0;
+
+ switch(g->controllerdisplay) {
+ case 0: // Set up for Display 0
+ /* Configure the pins to a well know state */
+ SET_RS;
+ SET_RD;
+ SET_WR;
+ CLR_CS;
+
+ /* Hardware reset */
+ palSetPad(GPIOE, GPIOE_LCD_RST);
+ chThdSleepMilliseconds(100);
+ palClearPad(GPIOE, GPIOE_LCD_RST);
+ chThdSleepMilliseconds(100);
+ palSetPad(GPIOE, GPIOE_LCD_RST);
+ chThdSleepMilliseconds(100);
+ break;
+ }
+}
+
+static inline void post_init_board(GDisplay *g) {
+ (void) g;
+}
+
+static inline void setpin_reset(GDisplay *g, bool_t state) {
+ (void) g;
+ if(state) {
+ // reset lcd
+ palClearPad(GPIOE, GPIOE_LCD_RST);
+ } else {
+ palSetPad(GPIOE, GPIOE_LCD_RST);
+ }
+}
+
+static inline void set_backlight(GDisplay *g, uint8_t percent) {
+ (void) g;
+ // TODO: can probably pwm this
+ if(percent) {
+ // turn back light on
+ palSetPad(GPIOE, GPIOE_LCD_BLED);
+ } else {
+ // turn off
+ palClearPad(GPIOE, GPIOE_LCD_BLED);
+ }
+}
+
+static inline void acquire_bus(GDisplay *g) {
+ (void) g;
+}
+
+static inline void release_bus(GDisplay *g) {
+ (void) g;
+}
+
+/**
+ * @brief Short delay
+ *
+ * @param[in] dly Length of delay
+ *
+ * @notapi
+ */
+static inline void ili9341_delay(uint16_t dly) {
+ static uint16_t i;
+ for(i = 0; i < dly; i++)
+ asm("nop");
+}
+
+static inline void write_index(GDisplay *g, uint16_t index) {
+ (void) g;
+ palWriteGroup(GPIOE, 0x00FF, 0, index);
+ CLR_RS; CLR_WR; ili9341_delay(1); SET_WR; ili9341_delay(1); SET_RS;
+}
+
+static inline void write_data(GDisplay *g, uint16_t data) {
+ (void) g;
+ palWriteGroup(GPIOE, 0x00FF, 0, data);
+ CLR_WR; ili9341_delay(1); SET_WR; ili9341_delay(1);
+}
+
+static inline void setreadmode(GDisplay *g) {
+ (void) g;
+ // change pin mode to digital input
+ palSetGroupMode(GPIOE, PAL_WHOLE_PORT, 0, PAL_MODE_INPUT);
+}
+
+static inline void setwritemode(GDisplay *g) {
+ (void) g;
+ // change pin mode back to digital output
+ palSetGroupMode(GPIOE, PAL_WHOLE_PORT, 0, PAL_MODE_OUTPUT_PUSHPULL);
+}
+
+static inline uint16_t read_data(GDisplay *g) {
+ CLR_RD;
+ value = palReadPort(GPIOE);
+ value = palReadPort(GPIOE);
+ SET_RD;
+ return value;
+}
+
+#endif /* _GDISP_LLD_BOARD_H */
diff --git a/drivers/gdisp/ILI9341/board_ILI9341_template.h b/drivers/gdisp/ILI9341/board_ILI9341_template.h
new file mode 100644
index 00000000..b8f55dc1
--- /dev/null
+++ b/drivers/gdisp/ILI9341/board_ILI9341_template.h
@@ -0,0 +1,154 @@
+/*
+ * This file is subject to the terms of the GFX License. If a copy of
+ * the license was not distributed with this file, you can obtain one at:
+ *
+ * http://ugfx.org/license.html
+ */
+
+/**
+ * @file drivers/gdisp/ILI9341/board_ILI9341_template.h
+ * @brief GDISP Graphic Driver subsystem board interface for the ILI9341 display.
+ *
+ * @addtogroup GDISP
+ * @{
+ */
+
+#ifndef _GDISP_LLD_BOARD_H
+#define _GDISP_LLD_BOARD_H
+
+/**
+ * @brief Initialise the board for the display.
+ *
+ * @param[in] g The GDisplay structure
+ *
+ * @note Set the g->board member to whatever is appropriate. For multiple
+ * displays this might be a pointer to the appropriate register set.
+ *
+ * @notapi
+ */
+static inline void init_board(GDisplay *g) {
+ (void) g;
+}
+
+/**
+ * @brief After the initialisation.
+ *
+ * @param[in] g The GDisplay structure
+ *
+ * @notapi
+ */
+static inline void post_init_board(GDisplay *g) {
+ (void) g;
+}
+
+/**
+ * @brief Set or clear the lcd reset pin.
+ *
+ * @param[in] g The GDisplay structure
+ * @param[in] state TRUE = lcd in reset, FALSE = normal operation
+ *
+ * @notapi
+ */
+static inline void setpin_reset(GDisplay *g, bool_t state) {
+ (void) g;
+ (void) state;
+}
+
+/**
+ * @brief Set the lcd back-light level.
+ *
+ * @param[in] g The GDisplay structure
+ * @param[in] percent 0 to 100%
+ *
+ * @notapi
+ */
+static inline void set_backlight(GDisplay *g, uint8_t percent) {
+ (void) g;
+ (void) percent;
+}
+
+/**
+ * @brief Take exclusive control of the bus
+ *
+ * @param[in] g The GDisplay structure
+ *
+ * @notapi
+ */
+static inline void acquire_bus(GDisplay *g) {
+ (void) g;
+}
+
+/**
+ * @brief Release exclusive control of the bus
+ *
+ * @param[in] g The GDisplay structure
+ *
+ * @notapi
+ */
+static inline void release_bus(GDisplay *g) {
+ (void) g;
+}
+
+/**
+ * @brief Send data to the index register.
+ *
+ * @param[in] g The GDisplay structure
+ * @param[in] index The index register to set
+ *
+ * @notapi
+ */
+static inline void write_index(GDisplay *g, uint16_t index) {
+ (void) g;
+ (void) index;
+}
+
+/**
+ * @brief Send data to the lcd.
+ *
+ * @param[in] g The GDisplay structure
+ * @param[in] data The data to send
+ *
+ * @notapi
+ */
+static inline void write_data(GDisplay *g, uint16_t data) {
+ (void) g;
+ (void) data;
+}
+
+/**
+ * @brief Set the bus in read mode
+ *
+ * @param[in] g The GDisplay structure
+ *
+ * @notapi
+ */
+static inline void setreadmode(GDisplay *g) {
+ (void) g;
+}
+
+/**
+ * @brief Set the bus back into write mode
+ *
+ * @param[in] g The GDisplay structure
+ *
+ * @notapi
+ */
+static inline void setwritemode(GDisplay *g) {
+ (void) g;
+}
+
+/**
+ * @brief Read data from the lcd.
+ * @return The data from the lcd
+ *
+ * @param[in] g The GDisplay structure
+ *
+ * @notapi
+ */
+static inline uint16_t read_data(GDisplay *g) {
+ (void) g;
+ return 0;
+}
+
+#endif /* _GDISP_LLD_BOARD_H */
+/** @} */
diff --git a/drivers/gdisp/ILI9341/gdisp_lld.c b/drivers/gdisp/ILI9341/gdisp_lld.c
new file mode 100644
index 00000000..e5c4b7d0
--- /dev/null
+++ b/drivers/gdisp/ILI9341/gdisp_lld.c
@@ -0,0 +1,373 @@
+/*
+ * This file is subject to the terms of the GFX License. If a copy of
+ * the license was not distributed with this file, you can obtain one at:
+ *
+ * http://ugfx.org/license.html
+ */
+
+/**
+ * @file drivers/gdisp/ILI9341/gdisp_lld.c
+ * @brief GDISP Graphics Driver subsystem low level driver source for
+ * the ILI9341 and compatible HVGA display
+ */
+
+#include "gfx.h"
+
+#if GFX_USE_GDISP
+
+#if defined(GDISP_SCREEN_HEIGHT)
+ #warning "GDISP: This low level driver does not support setting a screen size. It is being ignored."
+ #undef GISP_SCREEN_HEIGHT
+#endif
+#if defined(GDISP_SCREEN_WIDTH)
+ #warning "GDISP: This low level driver does not support setting a screen size. It is being ignored."
+ #undef GDISP_SCREEN_WIDTH
+#endif
+
+#define GDISP_DRIVER_VMT GDISPVMT_ILI9341
+#include "../drivers/gdisp/ILI9341/gdisp_lld_config.h"
+#include "gdisp/lld/gdisp_lld.h"
+
+#include "board_ILI9341.h"
+
+/*===========================================================================*/
+/* Driver local definitions. */
+/*===========================================================================*/
+
+#ifndef GDISP_SCREEN_HEIGHT
+ #define GDISP_SCREEN_HEIGHT 320
+#endif
+#ifndef GDISP_SCREEN_WIDTH
+ #define GDISP_SCREEN_WIDTH 240
+#endif
+#ifndef GDISP_INITIAL_CONTRAST
+ #define GDISP_INITIAL_CONTRAST 50
+#endif
+#ifndef GDISP_INITIAL_BACKLIGHT
+ #define GDISP_INITIAL_BACKLIGHT 100
+#endif
+
+#include "../drivers/gdisp/ILI9341/ILI9341.h"
+
+/*===========================================================================*/
+/* Driver local functions. */
+/*===========================================================================*/
+
+// Some common routines and macros
+#define dummy_read(g) { volatile uint16_t dummy; dummy = read_data(g); (void) dummy; }
+#define write_reg(g, reg, data) { write_index(g, reg); write_data(g, data); }
+#define write_data16(g, data) { write_data(g, data >> 8); write_data(g, (uint8_t)data); }
+#define delay(us) gfxSleepMicroseconds(us)
+#define delayms(ms) gfxSleepMilliseconds(ms)
+
+static inline void set_cursor(GDisplay *g) {
+ write_index(g, 0x2A);
+ write_data(g, (g->p.x >> 8));
+ write_data(g, (uint8_t) g->p.x);
+ write_data(g, (g->p.x) >> 8);
+ write_data(g, (uint8_t) (g->p.x));
+
+ write_index(g, 0x2B);
+ write_data(g, (g->p.y >> 8));
+ write_data(g, (uint8_t) g->p.y);
+ write_data(g, (g->p.y) >> 8);
+ write_data(g, (uint8_t) (g->p.y));
+
+ write_index(g, 0x2C);
+}
+
+static void set_viewport(GDisplay *g) {
+ write_index(g, 0x2A);
+ write_data(g, (g->p.x >> 8));
+ write_data(g, (uint8_t) g->p.x);
+ write_data(g, (g->p.x + g->p.cx - 1) >> 8);
+ write_data(g, (uint8_t) (g->p.x + g->p.cx - 1));
+
+ write_index(g, 0x2B);
+ write_data(g, (g->p.y >> 8));
+ write_data(g, (uint8_t) g->p.y);
+ write_data(g, (g->p.y + g->p.cy - 1) >> 8);
+ write_data(g, (uint8_t) (g->p.y + g->p.cy - 1));
+}
+
+/*===========================================================================*/
+/* Driver exported functions. */
+/*===========================================================================*/
+
+LLDSPEC bool_t gdisp_lld_init(GDisplay *g) {
+ // No private area for this controller
+ g->priv = 0;
+
+ // Initialise the board interface
+ init_board(g);
+
+ // Hardware reset
+ setpin_reset(g, TRUE);
+ gfxSleepMilliseconds(20);
+ setpin_reset(g, FALSE);
+ gfxSleepMilliseconds(20);
+
+ // Get the bus for the following initialisation commands
+ acquire_bus(g);
+
+ write_index(g, 0x01); //software reset
+ chThdSleepMilliseconds(5);
+ write_index(g, 0x28);
+ // display off
+ //---------------------------------------------------------
+ // magic?
+ write_index(g, 0xcf);
+ write_data(g, 0x00);
+ write_data(g, 0x83);
+ write_data(g, 0x30);
+
+ write_index(g, 0xed);
+ write_data(g, 0x64);
+ write_data(g, 0x03);
+ write_data(g, 0x12);
+ write_data(g, 0x81);
+ write_index(g, 0xe8);
+ write_data(g, 0x85);
+ write_data(g, 0x01);
+ write_data(g, 0x79);
+ write_index(g, 0xcb);
+ write_data(g, 0x39);
+ write_data(g, 0x2c);
+ write_data(g, 0x00);
+ write_data(g, 0x34);
+ write_data(g, 0x02);
+ write_index(g, 0xf7);
+ write_data(g, 0x20);
+ write_index(g, 0xea);
+ write_data(g, 0x00);
+ write_data(g, 0x00);
+ //------------power control------------------------------
+ write_index(g, 0xc0); //power control
+ write_data(g, 0x26);
+ write_index(g, 0xc1); //power control
+ write_data(g, 0x11);
+ //--------------VCOM
+ write_index(g, 0xc5); //vcom control
+ write_data(g, 0x35);//35
+ write_data(g, 0x3e);//3E
+ write_index(g, 0xc7); //vcom control
+ write_data(g, 0xbe); // 0x94
+ //------------memory access control------------------------
+ write_index(g, 0x36);
+ // memory access control
+ write_data(g, 0x48); //0048 my,mx,mv,ml,BGR,mh,0.0
+ write_index(g, 0x3a); // pixel format set
+ write_data(g, 0x55);//16bit /pixel
+ //----------------- frame rate------------------------------
+ write_index(g, 0xb1);
+ // frame rate
+ write_data(g, 0x00);
+ write_data(g, 0x1B); //70
+ //----------------Gamma---------------------------------
+ write_index(g, 0xf2); // 3Gamma Function Disable
+ write_data(g, 0x08);
+ write_index(g, 0x26);
+ write_data(g, 0x01); // gamma set 4 gamma curve 01/02/04/08
+
+ write_index(g, 0xE0); //positive gamma correction
+ write_data(g, 0x1f);
+ write_data(g, 0x1a);
+ write_data(g, 0x18);
+ write_data(g, 0x0a);
+ write_data(g, 0x0f);
+ write_data(g, 0x06);
+ write_data(g, 0x45);
+ write_data(g, 0x87);
+ write_data(g, 0x32);
+ write_data(g, 0x0a);
+ write_data(g, 0x07);
+ write_data(g, 0x02);
+ write_data(g, 0x07);
+ write_data(g, 0x05);
+ write_data(g, 0x00);
+ write_index(g, 0xE1); //negamma correction
+ write_data(g, 0x00);
+ write_data(g, 0x25);
+ write_data(g, 0x27);
+ write_data(g, 0x05);
+ write_data(g, 0x10);
+ write_data(g, 0x09);
+ write_data(g, 0x3a);
+ write_data(g, 0x78);
+ write_data(g, 0x4d);
+ write_data(g, 0x05);
+ write_data(g, 0x18);
+ write_data(g, 0x0d);
+ write_data(g, 0x38);
+ write_data(g, 0x3a);
+ write_data(g, 0x1f);
+ //--------------ddram ---------------------
+ write_index(g, 0x2a);
+ // column set
+ // size = 239
+ write_data(g, 0x00);
+ write_data(g, 0x00);
+ write_data(g, 0x00);
+ write_data(g, 0xEF);
+ write_index(g, 0x2b);
+ // page address set
+ // size = 319
+ write_data(g, 0x00);
+ write_data(g, 0x00);
+ write_data(g, 0x01);
+ write_data(g, 0x3F);
+ // write_index(g, 0x34);
+ //write_index(g, 0x35);
+ // tearing effect off
+ // tearing effect on
+ // write_index(g, 0xb4); // display inversion
+ // write_data(g, 0x00);
+ write_index(g, 0xb7); //entry mode set
+ write_data(g, 0x07);
+ //-----------------display---------------------
+ write_index(g, 0xb6);
+ // display function control
+ write_data(g, 0x0a);
+ write_data(g, 0x82);
+ write_data(g, 0x27);
+ write_data(g, 0x00);
+ write_index(g, 0x11); //sleep out
+ chThdSleepMilliseconds(100);
+ write_index(g, 0x29); // display on
+ chThdSleepMilliseconds(100);
+
+ // Finish Init
+ post_init_board(g);
+
+ // Release the bus
+ release_bus(g);
+
+ /* Turn on the back-light */
+ set_backlight(g, GDISP_INITIAL_BACKLIGHT);
+
+ /* Initialise the GDISP structure */
+ g->g.Width = GDISP_SCREEN_WIDTH;
+ g->g.Height = GDISP_SCREEN_HEIGHT;
+ g->g.Orientation = GDISP_ROTATE_0;
+ g->g.Powermode = powerOn;
+ g->g.Backlight = GDISP_INITIAL_BACKLIGHT;
+ g->g.Contrast = GDISP_INITIAL_CONTRAST;
+ return TRUE;
+}
+
+#if GDISP_HARDWARE_STREAM_WRITE
+ LLDSPEC void gdisp_lld_write_start(GDisplay *g) {
+ acquire_bus(g);
+ set_viewport(g);
+ #if !GDISP_HARDWARE_STREAM_POS
+ set_cursor(g);
+ #endif
+ }
+ LLDSPEC void gdisp_lld_write_color(GDisplay *g) {
+ write_data16(g, g->p.color);
+ }
+ LLDSPEC void gdisp_lld_write_stop(GDisplay *g) {
+ release_bus(g);
+ }
+ #if GDISP_HARDWARE_STREAM_POS
+ LLDSPEC void gdisp_lld_write_pos(GDisplay *g) {
+ set_cursor(g);
+ }
+ #endif
+#endif
+
+#if GDISP_HARDWARE_STREAM_READ
+ LLDSPEC void gdisp_lld_read_start(GDisplay *g) {
+ acquire_bus(g);
+ set_viewport(g);
+ set_cursor(g);
+ setreadmode(g);
+ dummy_read(g);
+ }
+ LLDSPEC color_t gdisp_lld_read_color(GDisplay *g) {
+ return read_data(g);
+ }
+ LLDSPEC void gdisp_lld_read_stop(GDisplay *g) {
+ setwritemode(g);
+ release_bus(g);
+ }
+#endif
+
+#if GDISP_NEED_CONTROL && GDISP_HARDWARE_CONTROL
+ LLDSPEC void gdisp_lld_control(GDisplay *g) {
+ switch(g->p.x) {
+ case GDISP_CONTROL_POWER:
+ if (g->g.Powermode == (powermode_t)g->p.ptr)
+ return;
+ switch((powermode_t)g->p.ptr) {
+ case powerOff:
+ case powerSleep:
+ case powerDeepSleep:
+ acquire_bus(g);
+ write_reg(g, 0x0010, 0x0001); /* enter sleep mode */
+ release_bus(g);
+ break;
+ case powerOn:
+ acquire_bus(g);
+ write_reg(g, 0x0010, 0x0000); /* leave sleep mode */
+ release_bus(g);
+ break;
+ default:
+ return;
+ }
+ g->g.Powermode = (powermode_t)g->p.ptr;
+ return;
+
+ case GDISP_CONTROL_ORIENTATION:
+ if (g->g.Orientation == (orientation_t)g->p.ptr)
+ return;
+ switch((orientation_t)g->p.ptr) {
+ case GDISP_ROTATE_0:
+ acquire_bus(g);
+ write_reg(g, 0x36, 0x00); /* X and Y axes non-inverted */
+ release_bus(g);
+ g->g.Height = GDISP_SCREEN_HEIGHT;
+ g->g.Width = GDISP_SCREEN_WIDTH;
+ break;
+ case GDISP_ROTATE_90:
+ acquire_bus(g);
+ write_reg(g, 0x36, 0x20); /* Invert X and Y axes */
+ release_bus(g);
+ g->g.Height = GDISP_SCREEN_WIDTH;
+ g->g.Width = GDISP_SCREEN_HEIGHT;
+ break;
+ case GDISP_ROTATE_180:
+ acquire_bus(g);
+ write_reg(g, 0x36, 0x80); /* X and Y axes non-inverted */
+ release_bus(g);
+ g->g.Height = GDISP_SCREEN_HEIGHT;
+ g->g.Width = GDISP_SCREEN_WIDTH;
+ break;
+ case GDISP_ROTATE_270:
+ acquire_bus(g);
+ write_reg(g, 0x36, 0xE0); /* Invert X and Y axes */
+ release_bus(g);
+ g->g.Height = GDISP_SCREEN_WIDTH;
+ g->g.Width = GDISP_SCREEN_HEIGHT;
+ break;
+ default:
+ return;
+ }
+ g->g.Orientation = (orientation_t)g->p.ptr;
+ return;
+
+ case GDISP_CONTROL_BACKLIGHT:
+ if ((unsigned)g->p.ptr > 100)
+ g->p.ptr = (void *)100;
+ set_backlight(g, (unsigned)g->p.ptr);
+ g->g.Backlight = (unsigned)g->p.ptr;
+ return;
+
+ //case GDISP_CONTROL_CONTRAST:
+ default:
+ return;
+ }
+ }
+#endif
+
+#endif /* GFX_USE_GDISP */
diff --git a/drivers/gdisp/ILI9341/gdisp_lld.mk b/drivers/gdisp/ILI9341/gdisp_lld.mk
new file mode 100644
index 00000000..8c44fc85
--- /dev/null
+++ b/drivers/gdisp/ILI9341/gdisp_lld.mk
@@ -0,0 +1,2 @@
+GFXINC += $(GFXLIB)/drivers/gdisp/ILI9341
+GFXSRC += $(GFXLIB)/drivers/gdisp/ILI9341/gdisp_lld.c
diff --git a/drivers/gdisp/ILI9341/gdisp_lld_config.h b/drivers/gdisp/ILI9341/gdisp_lld_config.h
new file mode 100644
index 00000000..8246934d
--- /dev/null
+++ b/drivers/gdisp/ILI9341/gdisp_lld_config.h
@@ -0,0 +1,36 @@
+/*
+ * This file is subject to the terms of the GFX License. If a copy of
+ * the license was not distributed with this file, you can obtain one at:
+ *
+ * http://ugfx.org/license.html
+ */
+
+/**
+ * @file drivers/gdisp/ILI9481/gdisp_lld_config.h
+ * @brief GDISP Graphics Driver subsystem low level driver source for
+ * the ILI9481 and compatible HVGA display
+ *
+ * @addtogroup GDISP
+ * @{
+ */
+
+#ifndef _GDISP_LLD_CONFIG_H
+#define _GDISP_LLD_CONFIG_H
+
+#if GFX_USE_GDISP
+
+/*===========================================================================*/
+/* Driver hardware support. */
+/*===========================================================================*/
+
+#define GDISP_HARDWARE_STREAM_WRITE TRUE
+//#define GDISP_HARDWARE_STREAM_READ TRUE
+//#define GDISP_HARDWARE_STREAM_POS TRUE
+#define GDISP_HARDWARE_CONTROL TRUE
+
+#define GDISP_PIXELFORMAT GDISP_PIXELFORMAT_RGB565
+
+#endif /* GFX_USE_GDISP */
+
+#endif /* _GDISP_LLD_CONFIG_H */
+/** @} */