aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-03-20 23:31:10 +1000
committerinmarket <andrewh@inmarket.com.au>2014-03-20 23:31:10 +1000
commite4d6884bca6ca422115765dab60039bd6296ccab (patch)
tree4ecde58f0b69af4039fb1a3ecd10d2f2fe06cf65
parentea5a1b849df6e5085a92957ad387f9e653674415 (diff)
downloaduGFX-e4d6884bca6ca422115765dab60039bd6296ccab.tar.gz
uGFX-e4d6884bca6ca422115765dab60039bd6296ccab.tar.bz2
uGFX-e4d6884bca6ca422115765dab60039bd6296ccab.zip
Cause the gaudio/gadc driver (currently broken) to include the GADC framework if it is included in the make.
-rw-r--r--demos/modules/gaudio/oscilloscope/gfxconf.h1
-rw-r--r--drivers/gaudio/gadc/driver.mk4
2 files changed, 4 insertions, 1 deletions
diff --git a/demos/modules/gaudio/oscilloscope/gfxconf.h b/demos/modules/gaudio/oscilloscope/gfxconf.h
index 2caa1da9..8e20ce0b 100644
--- a/demos/modules/gaudio/oscilloscope/gfxconf.h
+++ b/demos/modules/gaudio/oscilloscope/gfxconf.h
@@ -45,7 +45,6 @@
#define GFX_USE_GDISP TRUE
#define GFX_USE_GWIN TRUE
#define GFX_USE_GTIMER TRUE
-//#define GFX_USE_GADC TRUE
#define GFX_USE_GAUDIO TRUE
/* Features for the GDISP sub-system. */
diff --git a/drivers/gaudio/gadc/driver.mk b/drivers/gaudio/gadc/driver.mk
index 4d79da25..8e943577 100644
--- a/drivers/gaudio/gadc/driver.mk
+++ b/drivers/gaudio/gadc/driver.mk
@@ -3,3 +3,7 @@ GFXSRC += $(GFXLIB)/drivers/gaudio/gadc/gaudio_record_lld.c
# Required include directories
GFXINC += $(GFXLIB)/drivers/gaudio/gadc
+
+# Make sure the GADC sub-system is turned on
+GFXDEFS += -DGFX_USE_GADC=TRUE
+