aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTectu <joel@unormal.org>2012-08-13 04:49:55 +0200
committerTectu <joel@unormal.org>2012-08-13 04:49:55 +0200
commiteb4d5be986c4fa3f08c3325174067ebbc348f59f (patch)
tree22fcf05c499318bf9e0364d630260f389395a0db
parente27d04d002a40f3b514eeeb60d374df6a8a1280c (diff)
downloaduGFX-eb4d5be986c4fa3f08c3325174067ebbc348f59f.tar.gz
uGFX-eb4d5be986c4fa3f08c3325174067ebbc348f59f.tar.bz2
uGFX-eb4d5be986c4fa3f08c3325174067ebbc348f59f.zip
readme update
-rw-r--r--readme1.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/readme1.txt b/readme1.txt
index 907c7eb4..e2d33c18 100644
--- a/readme1.txt
+++ b/readme1.txt
@@ -5,17 +5,20 @@ To include any of these functions/drivers in your project...
2/ In your project Makefile (amongst similiar lines but after the hal line) add the line...
include $(LCDLIB)/lcd.mk
- 3/ In your project Makefile add the makefiles for any specific drivers you want e.g
+ 3/ Add $(LCDSRC) and $(LCDINC) to your SRCS and INCDIR of your projects Makefile
+
+ 4/ In your project Makefile add the makefiles for any specific drivers you want e.g
include $(LCDLIB)/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.mk
- include $(LCDLIB)/halext/drivers/gdispNokia6610/gdisp_lld.mk
+ include $(LCDLIB)/halext/drivers/gdisp/gdispNokia6610/gdisp_lld.mk
- 4/ In your project halconf.h turn on the support you want eg.
+ 5/ In your project halconf.h turn on the support you want eg.
/**
* @brief Enables the Touchpad subsystem.
*/
#if !defined(HAL_USE_TOUCHPAD) || defined(__DOXYGEN__)
#define HAL_USE_TOUCHPAD TRUE
#endif
+
/**
* @brief Enables the GDISP subsystem.
*/
@@ -24,5 +27,6 @@ To include any of these functions/drivers in your project...
/* Any driver specific defines required go here. The below line is an example. */
#define GDISP_NEED_MULTITHREAD TRUE
#endif
- 5/ Do a make clean.
+
+ 6/ Do a make clean.