aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/Embest-STM32-DMSTF4BB/example_chibios_2.x/Makefile
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@seriouslyembedded.com>2015-08-29 16:35:34 +0200
committerJoel Bodenmann <joel@seriouslyembedded.com>2015-08-29 16:35:34 +0200
commit4c6e2433a5d7e72e037322d2e521da4d846f1aef (patch)
tree18d27674dad7db0be18f93c6097ed49aaba1c9e2 /boards/base/Embest-STM32-DMSTF4BB/example_chibios_2.x/Makefile
parent3f7ded913d87dc9cbbbd99ccc5ec9c11fd775aa5 (diff)
downloaduGFX-4c6e2433a5d7e72e037322d2e521da4d846f1aef.tar.gz
uGFX-4c6e2433a5d7e72e037322d2e521da4d846f1aef.tar.bz2
uGFX-4c6e2433a5d7e72e037322d2e521da4d846f1aef.zip
Updating ChibiOS 3.x build system support
Diffstat (limited to 'boards/base/Embest-STM32-DMSTF4BB/example_chibios_2.x/Makefile')
-rw-r--r--boards/base/Embest-STM32-DMSTF4BB/example_chibios_2.x/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/boards/base/Embest-STM32-DMSTF4BB/example_chibios_2.x/Makefile b/boards/base/Embest-STM32-DMSTF4BB/example_chibios_2.x/Makefile
index 922282d8..4fcda523 100644
--- a/boards/base/Embest-STM32-DMSTF4BB/example_chibios_2.x/Makefile
+++ b/boards/base/Embest-STM32-DMSTF4BB/example_chibios_2.x/Makefile
@@ -13,20 +13,19 @@
# uGFX settings
# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
- GFXLIB = /path/to/your/ugfx
+ GFXLIB = ../path/to/ugfx
GFXBOARD = Embest-STM32-DMSTF4BB
GFXDEMO = modules/gdisp/basics
# ChibiOS settings
ifeq ($(OPT_OS),chibios)
- # See $(GFXLIB)/tools/gmake_scripts/os_chibios.mk for the list of variables
- CHIBIOS = /path/to/your/chibios
+ # See $(GFXLIB)/tools/gmake_scripts/os_chibios_x.mk for the list of variables
+ CHIBIOS = ../path/to/chibios
+ CHIBIOS_VERSION = 2
CHIBIOS_BOARD =
CHIBIOS_PLATFORM = STM32F4xx
CHIBIOS_PORT = GCC/ARMCMx/STM32F4xx
CHIBIOS_LDSCRIPT = STM32F407xG.ld
- # We define a non standard board script as this is not a standard ChibiOS supported board
- include $(GFXLIB)/boards/base/$(GFXBOARD)/chibios_board/board.mk
endif
##############################################################################################
@@ -40,7 +39,7 @@ CXXFLAGS = -fno-rtti
ASFLAGS =
LDFLAGS =
-SRC =
+SRC = board.c
OBJS =
DEFS =
LIBS =