aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/Linux-Framebuffer/example
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-04 17:12:33 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-04 17:12:53 +1000
commitbbc7b6e039d179c92fe53a6ad522131e64412432 (patch)
tree807640879bc2dc873f52a2a82aecffb9261ec872 /boards/base/Linux-Framebuffer/example
parente6882aa5f4382e25535e0e78ac5f5d18e581eb1b (diff)
downloaduGFX-bbc7b6e039d179c92fe53a6ad522131e64412432.tar.gz
uGFX-bbc7b6e039d179c92fe53a6ad522131e64412432.tar.bz2
uGFX-bbc7b6e039d179c92fe53a6ad522131e64412432.zip
Update to makefiles to support ChibiOS v3, making ARM thumb targets, CPU specific flags etc
Also put license in the gmake master scripts.
Diffstat (limited to 'boards/base/Linux-Framebuffer/example')
-rw-r--r--boards/base/Linux-Framebuffer/example/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/boards/base/Linux-Framebuffer/example/Makefile b/boards/base/Linux-Framebuffer/example/Makefile
index 76b2022a..fb0c1b7a 100644
--- a/boards/base/Linux-Framebuffer/example/Makefile
+++ b/boards/base/Linux-Framebuffer/example/Makefile
@@ -13,6 +13,8 @@
OPT_LINK_OPTIMIZE = yes
OPT_NONSTANDARD_FLAGS = no
OPT_OS = linux
+ # Change this next setting (or add the explicit compiler flags) if you are not compiling for x86 linux
+ OPT_CPU = x86
# uGFX settings
# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
@@ -30,13 +32,13 @@
ARCH =
SRCFLAGS = -ggdb -O0
-SRCFLAGS+= -m32
CFLAGS =
CXXFLAGS =
ASFLAGS =
LDFLAGS =
SRC =
+OBJS =
DEFS =
LIBS =
INCPATH =