aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/OSX
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-04 17:12:33 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-04 17:12:53 +1000
commitbbc7b6e039d179c92fe53a6ad522131e64412432 (patch)
tree807640879bc2dc873f52a2a82aecffb9261ec872 /boards/base/OSX
parente6882aa5f4382e25535e0e78ac5f5d18e581eb1b (diff)
downloaduGFX-bbc7b6e039d179c92fe53a6ad522131e64412432.tar.gz
uGFX-bbc7b6e039d179c92fe53a6ad522131e64412432.tar.bz2
uGFX-bbc7b6e039d179c92fe53a6ad522131e64412432.zip
Update to makefiles to support ChibiOS v3, making ARM thumb targets, CPU specific flags etc
Also put license in the gmake master scripts.
Diffstat (limited to 'boards/base/OSX')
-rw-r--r--boards/base/OSX/example/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/boards/base/OSX/example/Makefile b/boards/base/OSX/example/Makefile
index 956608ff..5bbcb5df 100644
--- a/boards/base/OSX/example/Makefile
+++ b/boards/base/OSX/example/Makefile
@@ -24,7 +24,7 @@
# OSX settings
# See $(GFXLIB)/tools/gmake_scripts/os_osx.mk for the list of variables
OSX_SDK = /Developer/SDKs/MacOSX10.7.sdk
- OSX_ARCH = -mmacosx-version-min=10.3 -arch i386
+ OSX_ARCH = -mmacosx-version-min=10.3
##############################################################################################
# Set these for your project
@@ -32,13 +32,13 @@
ARCH =
SRCFLAGS = -ggdb -O0
-SRCFLAGS+= -m32
CFLAGS =
CXXFLAGS =
ASFLAGS =
LDFLAGS =
SRC =
+OBJS =
DEFS =
LIBS =
INCPATH =