aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/OSX
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-01 00:44:40 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-01 00:45:02 +1000
commitf90ea57bff091832c7b52b3825057ac20ded1f01 (patch)
tree83d8e0e8b9917584e7f216470cd0fb8efa1a975e /boards/base/OSX
parentb1b00b1cc9780db403bba2f21837fef20b9d8e8c (diff)
downloaduGFX-f90ea57bff091832c7b52b3825057ac20ded1f01.tar.gz
uGFX-f90ea57bff091832c7b52b3825057ac20ded1f01.tar.bz2
uGFX-f90ea57bff091832c7b52b3825057ac20ded1f01.zip
First ARM build to use the new makefile plus makefile updates
Diffstat (limited to 'boards/base/OSX')
-rw-r--r--boards/base/OSX/example/Makefile43
1 files changed, 25 insertions, 18 deletions
diff --git a/boards/base/OSX/example/Makefile b/boards/base/OSX/example/Makefile
index d3502528..956608ff 100644
--- a/boards/base/OSX/example/Makefile
+++ b/boards/base/OSX/example/Makefile
@@ -4,33 +4,39 @@
# Settings
#
-# See $(GFXLIB)/tools/gmake_scripts/readme.txt for the meaning of these variables
-OPT_VERBOSE_COMPILE = no
-OPT_GENERATE_LISTINGS = yes
-OPT_GENERATE_MAP = yes
-OPT_COPY_EXE = no
-OPT_NATIVEOS = osx
-OPT_OS = osx
-
-# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the meaning of these variables
-GFXLIB = ../uGFX
-GFXBOARD = OSX
-#GFXDRIVERS = multiple/uGFXnet
-GFXDEMO = modules/gdisp/basics
+# General settings
+ # See $(GFXLIB)/tools/gmake_scripts/readme.txt for the list of variables
+ OPT_VERBOSE_COMPILE = no
+ OPT_GENERATE_LISTINGS = yes
+ OPT_GENERATE_MAP = yes
+ OPT_COPY_EXE = no
+ OPT_LINK_OPTIMIZE = yes
+ OPT_NONSTANDARD_FLAGS = no
+ OPT_OS = osx
+
+# uGFX settings
+ # See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
+ GFXLIB = ../uGFX
+ GFXBOARD = OSX
+ #GFXDRIVERS = multiple/uGFXnet
+ GFXDEMO = modules/gdisp/basics
+
+# OSX settings
+ # See $(GFXLIB)/tools/gmake_scripts/os_osx.mk for the list of variables
+ OSX_SDK = /Developer/SDKs/MacOSX10.7.sdk
+ OSX_ARCH = -mmacosx-version-min=10.3 -arch i386
##############################################################################################
# Set these for your project
#
-OSX_SDK = /Developer/SDKs/MacOSX10.7.sdk
-OSX_ARCH = -mmacosx-version-min=10.3 -arch i386
-
ARCH =
-SRCFLAGS = -m32 -ggdb -O0 -fomit-frame-pointer -Wall -Wextra -Wstrict-prototypes -fverbose-asm -isysroot $(OSX_SDK) $(OSX_ARCH)
+SRCFLAGS = -ggdb -O0
+SRCFLAGS+= -m32
CFLAGS =
CXXFLAGS =
ASFLAGS =
-LDFLAGS = -pthread -Wl,-syslibroot,$(OSX_SDK) $(OSX_ARCH)
+LDFLAGS =
SRC =
DEFS =
@@ -43,5 +49,6 @@ LIBPATH =
#
include $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk
+include $(GFXLIB)/tools/gmake_scripts/os_$(OPT_OS).mk
include $(GFXLIB)/tools/gmake_scripts/compiler_gcc.mk
# *** EOF ***