aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-04 17:12:33 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-04 17:12:33 +1000
commit2151935b3a89fdf357181f6f1161c1c0c1dde1f0 (patch)
treefa8cac4a2ffc994dd91de3fbc6f4090677ddf65e /boards/base/Olimex-SAM7EX256-GE8/example/Makefile
parent5d3ab261c0f994b25013f73b4fd9794d81740da7 (diff)
downloaduGFX-2151935b3a89fdf357181f6f1161c1c0c1dde1f0.tar.gz
uGFX-2151935b3a89fdf357181f6f1161c1c0c1dde1f0.tar.bz2
uGFX-2151935b3a89fdf357181f6f1161c1c0c1dde1f0.zip
Update to makefiles to support ChibiOS v3, making ARM thumb targets, CPU specific flags etc
Also put license in the gmake master scripts.
Diffstat (limited to 'boards/base/Olimex-SAM7EX256-GE8/example/Makefile')
-rw-r--r--boards/base/Olimex-SAM7EX256-GE8/example/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/boards/base/Olimex-SAM7EX256-GE8/example/Makefile b/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
index aa11abad..9130ed5a 100644
--- a/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
+++ b/boards/base/Olimex-SAM7EX256-GE8/example/Makefile
@@ -14,6 +14,8 @@
OPT_NONSTANDARD_FLAGS = no
OPT_NATIVEOS = chibios
OPT_OS = chibios
+ OPT_THUMB = no
+ OPT_CPU = at91sam7
# uGFX settings
# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
@@ -30,9 +32,7 @@ ifeq ($(OPT_OS),chibios)
CHIBIOS_PLATFORM = AT91SAM7
CHIBIOS_PORT = GCC/ARM/AT91SAM7
CHIBIOS_DEFS =
- #CHIBIOS_LDSCRIPT = $(PORTLD)/AT91SAM7X256.ld
- # We define a non standard linker script here just to give us some more stack space
- CHIBIOS_LDSCRIPT = linker.ld
+ CHIBIOS_LDSCRIPT = AT91SAM7X256.ld
endif
##############################################################################################
@@ -41,18 +41,20 @@ endif
ARCH = arm-none-eabi-
SRCFLAGS = -ggdb -O0
-SRCFLAGS+= -mcpu=arm7tdmi -mabi=apcs-gnu -mno-thumb-interwork
CFLAGS =
CXXFLAGS = -fno-rtti
ASFLAGS =
-LDFLAGS = -mcpu=arm7tdmi
+LDFLAGS =
SRC =
+OBJS =
DEFS =
LIBS =
INCPATH =
LIBPATH =
-LDSCRIPT =
+
+# We override the standard ChibiOS linker script here just to give us some more stack space
+LDSCRIPT = linker.ld
##############################################################################################
# These should be at the end