aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-12-31 12:28:10 +1000
committerinmarket <andrewh@inmarket.com.au>2014-12-31 12:28:10 +1000
commit57c14b74e4d2bca53a02b58bbe4c4aafc868e187 (patch)
treeffa37c22d412e8252a37342af9bbb99a82fc0c42 /boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile
parenta5b80da2077047ddee8e8c75d84b2d2b156f8f2d (diff)
downloaduGFX-57c14b74e4d2bca53a02b58bbe4c4aafc868e187.tar.gz
uGFX-57c14b74e4d2bca53a02b58bbe4c4aafc868e187.tar.bz2
uGFX-57c14b74e4d2bca53a02b58bbe4c4aafc868e187.zip
Add Chibios v3 example files for the STM32F429iDiscovery board.
Diffstat (limited to 'boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile')
-rw-r--r--boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile b/boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile
new file mode 100644
index 00000000..217d1d24
--- /dev/null
+++ b/boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile
@@ -0,0 +1,58 @@
+# Possible Targets: all clean Debug cleanDebug Release cleanRelease
+
+##############################################################################################
+# Settings
+#
+
+# General settings
+ # See $(GFXLIB)/tools/gmake_scripts/readme.txt for the list of variables
+ OPT_OS = chibios
+ OPT_THUMB = yes
+ OPT_LINK_OPTIMIZE = yes
+ OPT_CPU = stm32m4
+
+# uGFX settings
+ # See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
+ GFXLIB = ../uGFX
+ GFXBOARD = STM32F429i-Discovery
+ GFXDEMO = modules/gdisp/basics
+
+# ChibiOS settings
+ifeq ($(OPT_OS),chibios)
+ # See $(GFXLIB)/tools/gmake_scripts/os_chibios.mk for the list of variables
+ CHIBIOS = ../ChibiOS3
+ CHIBIOS_VERSION = 3
+ CHIBIOS_BOARD = ST_STM32F429I_DISCOVERY
+ CHIBIOS_CPUCLASS = ARMCMx
+ CHIBIOS_PLATFORM = STM32/STM32F4xx
+ CHIBIOS_PORT = stm32f4xx
+ CHIBIOS_LDSCRIPT = STM32F407xG.ld
+endif
+
+##############################################################################################
+# Set these for your project
+#
+
+ARCH = arm-none-eabi-
+SRCFLAGS = -ggdb -O0
+CFLAGS =
+CXXFLAGS = -fno-rtti
+ASFLAGS =
+LDFLAGS =
+
+SRC =
+OBJS =
+DEFS =
+LIBS =
+INCPATH =
+LIBPATH =
+LDSCRIPT =
+
+##############################################################################################
+# These should be at the end
+#
+
+include $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk
+include $(GFXLIB)/tools/gmake_scripts/os_$(OPT_OS).mk
+include $(GFXLIB)/tools/gmake_scripts/compiler_gcc.mk
+# *** EOF ***