aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/STM32F746-Discovery/example_raw32/Makefile
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2015-10-05 11:23:31 +1000
committerinmarket <andrewh@inmarket.com.au>2015-10-05 11:23:31 +1000
commitd4ef20f47ece19d3a6072d708b9ce316497e00e0 (patch)
tree08f8d522ceecc1f45cbb98a6436c60d4926a5621 /boards/base/STM32F746-Discovery/example_raw32/Makefile
parente699e549ac015cfe40da0134095a05254978bd47 (diff)
downloaduGFX-d4ef20f47ece19d3a6072d708b9ce316497e00e0.tar.gz
uGFX-d4ef20f47ece19d3a6072d708b9ce316497e00e0.tar.bz2
uGFX-d4ef20f47ece19d3a6072d708b9ce316497e00e0.zip
Support for ChibiOS3 (master branch only currently) for the STM32F729-Discovery board.
Not working yet.
Diffstat (limited to 'boards/base/STM32F746-Discovery/example_raw32/Makefile')
-rw-r--r--boards/base/STM32F746-Discovery/example_raw32/Makefile40
1 files changed, 20 insertions, 20 deletions
diff --git a/boards/base/STM32F746-Discovery/example_raw32/Makefile b/boards/base/STM32F746-Discovery/example_raw32/Makefile
index dee0f01a..b0f8344a 100644
--- a/boards/base/STM32F746-Discovery/example_raw32/Makefile
+++ b/boards/base/STM32F746-Discovery/example_raw32/Makefile
@@ -15,38 +15,38 @@
# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
GFXLIB = ../ugfx
GFXBOARD = STM32F746-Discovery
- GFXDEMO = modules/gdisp/basics
+ GFXDEMO = modules/gdisp/streaming
#GFXDRIVERS =
+ GFXSINGLEMAKE = no
# ChibiOS settings
-# Note: not supported by ChibiOS yet!
ifeq ($(OPT_OS),chibios)
- # See $(GFXLIB)/tools/gmake_scripts/os_chibios.mk for the list of variables
- CHIBIOS = ../ChibiOS
- CHIBIOS_BOARD = ST_STM32F746_DISCOVERY
- CHIBIOS_PLATFORM = STM32F7xx
- CHIBIOS_PORT = GCC/ARMCMx/STM32F7xx
- CHIBIOS_LDSCRIPT = STM32F746.ld
-
- #CHIBIOS = ../ChibiOS3
- #CHIBIOS_VERSION = 3
- #CHIBIOS_BOARD = ST_STM32F746_DISCOVERY
- #CHIBIOS_CPUCLASS = ARMCMx
- #CHIBIOS_PLATFORM = STM32/STM32F7xx
- #CHIBIOS_PORT = stm32f7xx
- #CHIBIOS_LDSCRIPT = STM32F746.ld
+ # See $(GFXLIB)/tools/gmake_scripts/os_chibios_3.mk for the list of variables
+ CHIBIOS = ../ChibiOS-Master
+ CHIBIOS_VERSION = 3
+ CHIBIOS_CPUCLASS = ARMCMx
+ CHIBIOS_PLATFORM = STM32
+ CHIBIOS_DEVICE_FAMILY = STM32F7xx
+ CHIBIOS_STARTUP = startup_stm32f7xx
+ CHIBIOS_PORT = v7m
+ CHIBIOS_LDSCRIPT = STM32F746xG.ld
+ CHIBIOS_BOARD = ST_STM32F746G_DISCOVERY
+ #CHIBIOS_PROCESS_STACKSIZE = 0x400
+ #CHIBIOS_EXCEPTIONS_STACKSIZE = 0x400
endif
-# Raw32 settings
+#Special - Required for the drivers for this discovery board.
+STMHAL = ../STM32/STM32F7xx_HAL_Driver
+
+#Special - Required for Raw32
CMSIS = ../STM32/CMSIS
-HAL = ../STM32/STM32F7xx_HAL_Driver
##############################################################################################
# Set these for your project
#
ARCH = arm-none-eabi-
-SRCFLAGS = -ggdb -O0
+SRCFLAGS = -ggdb -O1
CFLAGS =
CXXFLAGS = -fno-rtti
ASFLAGS =
@@ -55,7 +55,7 @@ LDFLAGS =
SRC =
OBJS =
-DEFS = GFX_OS_HEAP_SIZE=40960
+DEFS = GFX_OS_HEAP_SIZE=40960
LIBS =
INCPATH =