aboutsummaryrefslogtreecommitdiffstats
path: root/boards
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-07-09 14:26:16 +1000
committerinmarket <andrewh@inmarket.com.au>2014-07-09 14:26:16 +1000
commit34cc5e029a21784bf2eeb17f3c22f3914326d982 (patch)
tree11aff816fbf33e21d5acf42ffbaf2622cc7fdb25 /boards
parent85fe4a96728b8f53cfa16068675e819f7cdc3162 (diff)
downloaduGFX-34cc5e029a21784bf2eeb17f3c22f3914326d982.tar.gz
uGFX-34cc5e029a21784bf2eeb17f3c22f3914326d982.tar.bz2
uGFX-34cc5e029a21784bf2eeb17f3c22f3914326d982.zip
eCos Synthetic framebuffer is now a supported "base" board.
Diffstat (limited to 'boards')
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/board.mk5
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/board_framebuffer.h (renamed from boards/addons/gdisp/board_framebuffer_eCos.h)3
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/example/Makefile165
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/example/readme.txt7
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/readme.txt11
5 files changed, 189 insertions, 2 deletions
diff --git a/boards/base/eCos-Synthetic-Framebuffer/board.mk b/boards/base/eCos-Synthetic-Framebuffer/board.mk
new file mode 100644
index 00000000..d4e9ebe1
--- /dev/null
+++ b/boards/base/eCos-Synthetic-Framebuffer/board.mk
@@ -0,0 +1,5 @@
+GFXINC += $(GFXLIB)/boards/base/eCos-Synthetic-Framebuffer
+GFXSRC +=
+GFXDEFS += -DGFX_USE_OS_ECOS=TRUE
+
+include $(GFXLIB)/drivers/gdisp/framebuffer/driver.mk
diff --git a/boards/addons/gdisp/board_framebuffer_eCos.h b/boards/base/eCos-Synthetic-Framebuffer/board_framebuffer.h
index 90226b5d..e8e46131 100644
--- a/boards/addons/gdisp/board_framebuffer_eCos.h
+++ b/boards/base/eCos-Synthetic-Framebuffer/board_framebuffer.h
@@ -20,7 +20,7 @@
#endif
// Uncomment this if your frame buffer device requires flushing ("Synch" in eCos speak)
-//#define GDISP_HARDWARE_FLUSH TRUE
+#define GDISP_HARDWARE_FLUSH TRUE
#ifdef GDISP_DRIVER_VMT
@@ -28,7 +28,6 @@
// SET THIS HERE!!!
// This must also match the pixel format above
- //#define FRAMEBUF 640x480x16
#define FRAMEBUF fb0
static void board_init(GDisplay *g, fbInfo *fbi) {
diff --git a/boards/base/eCos-Synthetic-Framebuffer/example/Makefile b/boards/base/eCos-Synthetic-Framebuffer/example/Makefile
new file mode 100644
index 00000000..e30e1c92
--- /dev/null
+++ b/boards/base/eCos-Synthetic-Framebuffer/example/Makefile
@@ -0,0 +1,165 @@
+#
+# !!!! Do NOT edit this makefile with an editor which replace tabs by spaces !!!!
+#
+##############################################################################################
+#
+# On command line:
+#
+# make INSTALL_DIR=/path/to/ecos/install all = Create project
+#
+# make clean = Clean project files.
+#
+# To rebuild project do "make clean" and "make all".
+#
+
+##############################################################################################
+# Start of default section
+#
+
+INSTALL_DIR=$$(INSTALL_DIR) # override on make command line
+
+include $(INSTALL_DIR)/include/pkgconf/ecos.mak
+
+CC = $(ECOS_COMMAND_PREFIX)gcc
+AS = $(CC) -x assembler-with-cpp
+CXX = $(CC)
+LD = $(CC)
+CFLAGS = -I$(INSTALL_DIR)/include
+CXXFLAGS = $(CFLAGS) -g
+LDFLAGS = -nostartfiles -L$(INSTALL_DIR)/lib -Ttarget.ld
+
+# List all default C defines here, like -D_DEBUG=1
+DDEFS =
+
+# List all default ASM defines here, like -D_DEBUG=1
+DADEFS =
+
+# List all default directories to look for include files here
+DINCDIR =
+
+# List the default directory to look for the libraries here
+DLIBDIR =
+
+# List all default libraries here
+DLIBS =
+
+#
+# End of default section
+##############################################################################################
+
+##############################################################################################
+# Start of user section
+#
+
+# Define project name here
+PROJECT = ugfx_over_ecos
+
+# Imported source files and paths for uGFX
+GFXLIB = ../ugfx
+
+include ${GFXLIB}/gfx.mk
+include ${GFXLIB}/boards/base/eCos-Synthetic-Framebuffer/board.mk
+
+# Where is our source code - alter these for your project.
+# Either just include the demo makefile or add your own definitions
+include $(GFXLIB)/demos/modules/gdisp/basics/demo.mk
+
+#MYFILES =
+#MYCSRC =
+#MYDEFS =
+
+# List all user C define here, like -D_DEBUG=1
+UDEFS = $(MYDEFS) $(GFXDEFS)
+
+# Define ASM defines here
+UADEFS =
+
+# List C source files here
+SRC = $(GFXSRC) \
+ $(MYCSRC)
+
+# List ASM source files here
+ASRC =
+
+# List all user directories here
+UINCDIR = $(MYFILES) $(GFXINC)
+
+# List the user directory to look for the libraries here
+ULIBDIR =
+
+# List all user libraries here
+ULIBS =
+
+# Define optimisation level here
+OPT = -ggdb -O0 -fomit-frame-pointer
+
+#
+# End of user defines
+##############################################################################################
+
+INCDIR = $(patsubst %,-I%,$(DINCDIR) $(UINCDIR))
+LIBDIR = $(patsubst %,-L%,$(DLIBDIR) $(ULIBDIR))
+DEFS = $(DDEFS) $(UDEFS)
+ADEFS = $(DADEFS) $(UADEFS)
+OBJS = $(ASRC:.s=.o) $(SRC:.c=.o)
+LIBS = $(DLIBS) $(ULIBS)
+
+ASFLAGS = -Wa,-amhls=$(<:.s=.lst) $(ADEFS)
+CPFLAGS = $(OPT) -Wall -Wextra -Wstrict-prototypes -fverbose-asm $(DEFS)
+
+ifeq ($(HOST_OSX),yes)
+ ifeq ($(OSX_SDK),)
+ OSX_SDK = /Developer/SDKs/MacOSX10.7.sdk
+ endif
+ ifeq ($(OSX_ARCH),)
+ OSX_ARCH = -mmacosx-version-min=10.3 -arch i386
+ endif
+
+ CPFLAGS += -isysroot $(OSX_SDK) $(OSX_ARCH)
+ LDFLAGS = -Wl -Map=$(PROJECT).map,-syslibroot,$(OSX_SDK),$(LIBDIR)
+ LIBS += $(OSX_ARCH)
+else
+ # Linux, or other
+ CPFLAGS += -m32 -Wa,-alms=$(<:.c=.lst) -I$(INSTALL_DIR)/include
+ LDFLAGS = -g -nostdlib -m32 -Wl,-Map=$(PROJECT).map,--cref,--no-warn-mismatch $(LIBDIR) -nostartfiles -L$(INSTALL_DIR)/lib -Ttarget.ld
+endif
+
+# Generate dependency information
+CPFLAGS += -MD -MP -MF .dep/$(@F).d
+
+#
+# makefile rules
+#
+
+all: $(OBJS) $(PROJECT)
+
+%.o : %.c
+ $(CC) -c $(CPFLAGS) -I . $(INCDIR) $< -o $@
+
+%.o : %.s
+ $(AS) -c $(ASFLAGS) $< -o $@
+
+$(PROJECT): $(OBJS)
+ $(CC) $(OBJS) $(LDFLAGS) $(LIBS) -o $@
+
+gcov:
+ -mkdir gcov
+ $(COV) -u $(subst /,\,$(SRC))
+ -mv *.gcov ./gcov
+
+clean:
+ -rm -f $(OBJS)
+ -rm -f $(PROJECT)
+ -rm -f $(PROJECT).map
+ -rm -f $(SRC:.c=.c.bak)
+ -rm -f $(SRC:.c=.lst)
+ -rm -f $(ASRC:.s=.s.bak)
+ -rm -f $(ASRC:.s=.lst)
+ -rm -fR .dep
+
+#
+# Include the dependency files, should be the last of the makefile
+#
+-include $(shell mkdir .dep 2>/dev/null) $(wildcard .dep/*)
+
+# *** EOF ***
diff --git a/boards/base/eCos-Synthetic-Framebuffer/example/readme.txt b/boards/base/eCos-Synthetic-Framebuffer/example/readme.txt
new file mode 100644
index 00000000..ca841f5b
--- /dev/null
+++ b/boards/base/eCos-Synthetic-Framebuffer/example/readme.txt
@@ -0,0 +1,7 @@
+Copy these files into your own project directory and alter them to suite.
+
+Notes:
+
+1/ Look at the MYFILES definition and the MYCSRC definition.
+2/ To run please install eCos synthetic framebuffer according to the documentation.
+3/ Call application ./ugfx_over_ecos -io \ No newline at end of file
diff --git a/boards/base/eCos-Synthetic-Framebuffer/readme.txt b/boards/base/eCos-Synthetic-Framebuffer/readme.txt
new file mode 100644
index 00000000..6bb1c32b
--- /dev/null
+++ b/boards/base/eCos-Synthetic-Framebuffer/readme.txt
@@ -0,0 +1,11 @@
+This directory contains the interface for eCos using a synthetic framebuffer display.
+
+
+
+On this board uGFX currently supports:
+
+ - GDISP via the framebuffer driver
+
+
+
+There is an example Makefile and project in the examples directory.