aboutsummaryrefslogtreecommitdiffstats
path: root/boards
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-03-30 19:11:29 +1000
committerinmarket <andrewh@inmarket.com.au>2014-03-30 19:11:29 +1000
commitfb8d159749daa8aefa75615d2f8a6cca2fac9ec0 (patch)
tree132c56a8db4e46a6bec3e0d9057ca8eeaed03090 /boards
parent04f03ea71da1337c501b598c6038afaf0216fed8 (diff)
downloaduGFX-fb8d159749daa8aefa75615d2f8a6cca2fac9ec0.tar.gz
uGFX-fb8d159749daa8aefa75615d2f8a6cca2fac9ec0.tar.bz2
uGFX-fb8d159749daa8aefa75615d2f8a6cca2fac9ec0.zip
Turn on PWM audio output for Olimex SAM7EX256 board.
Diffstat (limited to 'boards')
-rw-r--r--boards/base/Olimex-SAM7EX256-GE8/board.mk1
-rw-r--r--boards/base/Olimex-SAM7EX256-GE8/example/halconf.h6
-rw-r--r--boards/base/Olimex-SAM7EX256-GE8/example/mcuconf.h11
-rw-r--r--boards/base/Olimex-SAM7EX256-GE8/gaudio_play_board.h75
4 files changed, 88 insertions, 5 deletions
diff --git a/boards/base/Olimex-SAM7EX256-GE8/board.mk b/boards/base/Olimex-SAM7EX256-GE8/board.mk
index 249cfc2d..98119565 100644
--- a/boards/base/Olimex-SAM7EX256-GE8/board.mk
+++ b/boards/base/Olimex-SAM7EX256-GE8/board.mk
@@ -6,3 +6,4 @@ include $(GFXLIB)/drivers/gadc/AT91SAM7/gadc_lld.mk
include $(GFXLIB)/drivers/ginput/dial/GADC/ginput_lld.mk
include $(GFXLIB)/drivers/ginput/toggle/Pal/ginput_lld.mk
include $(GFXLIB)/drivers/gaudio/gadc/driver.mk
+include $(GFXLIB)/drivers/gaudio/pwm/driver.mk
diff --git a/boards/base/Olimex-SAM7EX256-GE8/example/halconf.h b/boards/base/Olimex-SAM7EX256-GE8/example/halconf.h
index db88d41b..3b60d923 100644
--- a/boards/base/Olimex-SAM7EX256-GE8/example/halconf.h
+++ b/boards/base/Olimex-SAM7EX256-GE8/example/halconf.h
@@ -80,7 +80,7 @@
* @brief Enables the GPT subsystem.
*/
#if !defined(HAL_USE_GPT) || defined(__DOXYGEN__)
-#define HAL_USE_GPT FALSE
+#define HAL_USE_GPT TRUE
#endif
/**
@@ -116,10 +116,6 @@
*/
#if !defined(HAL_USE_PWM) || defined(__DOXYGEN__)
#define HAL_USE_PWM TRUE
-#define PWM_USE_PWM1 FALSE
-#define PWM_USE_PWM2 TRUE
-#define PWM_USE_PWM3 FALSE
-#define PWM_USE_PWM4 FALSE
#endif
/**
diff --git a/boards/base/Olimex-SAM7EX256-GE8/example/mcuconf.h b/boards/base/Olimex-SAM7EX256-GE8/example/mcuconf.h
index a9a0fea7..8acdd42d 100644
--- a/boards/base/Olimex-SAM7EX256-GE8/example/mcuconf.h
+++ b/boards/base/Olimex-SAM7EX256-GE8/example/mcuconf.h
@@ -52,6 +52,10 @@
/*
* PWM driver system settings.
*/
+#define PWM_USE_PWM1 TRUE // used by audio-out
+#define PWM_USE_PWM2 TRUE // used by back-light
+#define PWM_USE_PWM3 FALSE
+#define PWM_USE_PWM4 FALSE
/*
* SERIAL driver system settings.
@@ -69,3 +73,10 @@
#define AT91SAM7_SPI_USE_SPI1 FALSE
#define AT91SAM7_SPI0_PRIORITY (AT91C_AIC_PRIOR_HIGHEST - 1)
#define AT91SAM7_SPI1_PRIORITY (AT91C_AIC_PRIOR_HIGHEST - 1)
+
+/*
+ * GPT driver system settings.
+ */
+#define AT91_GPT_USE_TC0 FALSE // used internally by ADC driver
+#define AT91_GPT_USE_TC1 TRUE // uGFX used for audio-out
+#define AT91_GPT_USE_TC2 FALSE
diff --git a/boards/base/Olimex-SAM7EX256-GE8/gaudio_play_board.h b/boards/base/Olimex-SAM7EX256-GE8/gaudio_play_board.h
new file mode 100644
index 00000000..bbbc48c6
--- /dev/null
+++ b/boards/base/Olimex-SAM7EX256-GE8/gaudio_play_board.h
@@ -0,0 +1,75 @@
+/*
+ * This file is subject to the terms of the GFX License. If a copy of
+ * the license was not distributed with this file, you can obtain one at:
+ *
+ * http://ugfx.org/license.html
+ */
+
+#ifndef GAUDIO_PLAY_BOARD_H
+#define GAUDIO_PLAY_BOARD_H
+
+/* Our timer callback */
+static void gptcallback(GPTDriver *gptp) {
+ (void) gptp;
+ gaudio_play_pwm_timer_callbackI();
+}
+
+/* PWM configuration structure. The speaker is on PWM0/PB19 ie PWM1/PIN1 in ChibiOS speak */
+static PWMConfig pwmcfg = {
+ 1000000, /* 1 MHz PWM clock frequency. Ignored as we are using PWM_MCK_DIV_n */
+ 1024, /* PWM period is 1024 cycles (10 bits). */
+ 0,
+ {
+ {PWM_MCK_DIV_1 | PWM_OUTPUT_CENTER | PWM_OUTPUT_ACTIVE_HIGH | PWM_OUTPUT_PIN1 | PWM_DISABLEPULLUP_PIN1, 0},
+ },
+};
+
+/* Timer configuration structure. We use Timer 2 (TC1) */
+static GPTConfig gptcfg = {
+ 8192, // frequency
+ gptcallback, // callback
+ GPT_CLOCK_FREQUENCY, // clocksource
+ GPT_GATE_NONE, // clockgate
+ GPT_TRIGGER_NONE, // trigger
+};
+
+static uint16_t lastvalue;
+
+static bool gaudio_play_pwm_setup(uint32_t frequency, ArrayDataFormat format) {
+ if (format == ARRAY_DATA_10BITUNSIGNED)
+ pwmcfg.period = 1024;
+ else if (format == ARRAY_DATA_8BITUNSIGNED)
+ pwmcfg.period = 256;
+ else
+ return FALSE;
+ gptcfg.frequency = frequency;
+ return TRUE;
+}
+
+static void gaudio_play_pwm_start(void) {
+ /* Start the PWM */
+ pwmStart(&PWMD1, &pwmcfg);
+ lastvalue = pwmcfg.period>>1;
+ pwmEnableChannelI(&PWMD1, 0, lastvalue);
+
+ /* Start the timer interrupt */
+ gptStart(&GPTD2, &gptcfg);
+ gptStartContinuous(&GPTD2, 0);
+}
+
+static void gaudio_play_pwm_stop(void) {
+ /* Stop the timer interrupt */
+ gptStopTimer(&GPTD2);
+
+ /* Stop the PWM */
+ pwmStop(&PWMD1);
+}
+
+static void gaudio_play_pwm_setI(uint16_t value) {
+ if (value != lastvalue) {
+ lastvalue = value;
+ pwmEnableChannelI(&PWMD1, 0, value);
+ }
+}
+
+#endif /* GAUDIO_PLAY_BOARD_H */