aboutsummaryrefslogtreecommitdiffstats
path: root/demos/games/tetris/Example_Makefiles/linux
diff options
context:
space:
mode:
authorAndrew Hannam <Andrew Hannam>2016-07-28 16:35:36 +1000
committerAndrew Hannam <Andrew Hannam>2016-07-28 16:35:36 +1000
commit12dfd8232fe32345bd60f04d73a1a40adf38e841 (patch)
tree803aaeb35b26e6b9fd3b01136398c5157f7f6f1f /demos/games/tetris/Example_Makefiles/linux
parent868a272d6e44c267d84420932247b942c07d5713 (diff)
downloaduGFX-12dfd8232fe32345bd60f04d73a1a40adf38e841.tar.gz
uGFX-12dfd8232fe32345bd60f04d73a1a40adf38e841.tar.bz2
uGFX-12dfd8232fe32345bd60f04d73a1a40adf38e841.zip
Move demo games into demo/games directory
Diffstat (limited to 'demos/games/tetris/Example_Makefiles/linux')
-rw-r--r--demos/games/tetris/Example_Makefiles/linux/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/demos/games/tetris/Example_Makefiles/linux/Makefile b/demos/games/tetris/Example_Makefiles/linux/Makefile
new file mode 100644
index 00000000..a33eba03
--- /dev/null
+++ b/demos/games/tetris/Example_Makefiles/linux/Makefile
@@ -0,0 +1,48 @@
+# Possible Targets: all clean Debug cleanDebug Release cleanRelease
+
+##############################################################################################
+# Settings
+#
+
+# General settings
+ # See $(GFXLIB)/tools/gmake_scripts/readme.txt for the list of variables
+ OPT_OS = linux
+ OPT_LINK_OPTIMIZE = yes
+ # Change this next setting (or add the explicit compiler flags) if you are not compiling for x86 linux
+ OPT_CPU = x86
+
+# uGFX settings
+ # See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
+ GFXLIB = ../uGFX
+ GFXBOARD = Linux
+ GFXDEMO = applications/tetris
+
+# Linux settings
+ # See $(GFXLIB)/tools/gmake_scripts/os_linux.mk for the list of variables
+
+##############################################################################################
+# Set these for your project
+#
+
+ARCH =
+SRCFLAGS = -ggdb -O0
+CFLAGS =
+CXXFLAGS =
+ASFLAGS =
+LDFLAGS =
+
+SRC =
+OBJS =
+DEFS =
+LIBS = -lm
+INCPATH =
+LIBPATH =
+
+##############################################################################################
+# These should be at the end
+#
+
+include $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk
+include $(GFXLIB)/tools/gmake_scripts/os_$(OPT_OS).mk
+include $(GFXLIB)/tools/gmake_scripts/compiler_gcc.mk
+# *** EOF ***