aboutsummaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2012-10-04 09:09:03 +0200
committerJoel Bodenmann <joel@unormal.org>2012-10-04 09:09:03 +0200
commit27276101ee46b1ef196c1c52ac92b7ea30d52778 (patch)
treeaf104a77a986fe479602aa607331ff3314d920ba /docs
parentb47ad0b71a063133d2b1434af604a6866c480e0e (diff)
downloaduGFX-27276101ee46b1ef196c1c52ac92b7ea30d52778.tar.gz
uGFX-27276101ee46b1ef196c1c52ac92b7ea30d52778.tar.bz2
uGFX-27276101ee46b1ef196c1c52ac92b7ea30d52778.zip
Makefile LCD replaced with GFX
Diffstat (limited to 'docs')
-rw-r--r--docs/usage.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/docs/usage.txt b/docs/usage.txt
index 961fa2c6..52cd39b1 100644
--- a/docs/usage.txt
+++ b/docs/usage.txt
@@ -1,15 +1,15 @@
To include any of these functions/drivers in your project...
- 1/ Specify the path to the LCDLIB. If none defined, default is $(CHIBIOS)/ext/lcd
+ 1/ Specify the path to the GFXLIB. If none defined, default is $(CHIBIOS)/ext/lcd
2/ In your project Makefile (amongst similiar lines but after the hal line) add the line...
- include $(LCDLIB)/lcd.mk
+ include $(GFXLIB)/lcd.mk
- 3/ Add $(LCDSRC) and $(LCDINC) to your SRCS and INCDIR of your projects Makefile
+ 3/ Add $(GFXSRC) and $(GFXINC) to your SRCS and INCDIR of your projects Makefile
4/ In your project Makefile add the makefiles for any specific drivers you want e.g
- include $(LCDLIB)/halext/drivers/touchpad/XPT2046/touchpad_lld.mk
- include $(LCDLIB)/halext/drivers/gdisp/Nokia6610/gdisp_lld.mk
+ include $(GFXLIB)/halext/drivers/touchpad/XPT2046/touchpad_lld.mk
+ include $(GFXLIB)/halext/drivers/gdisp/Nokia6610/gdisp_lld.mk
5/ In your project halconf.h turn on the support you want eg.
/**