aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gaudio/vs1053
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2015-11-21 19:27:08 +1000
committerinmarket <andrewh@inmarket.com.au>2015-11-21 19:27:08 +1000
commitc5a86757bd8309027d50f82d8947250c8e1197e6 (patch)
treef37f1a93fea959e870833022479603cd92702ea4 /drivers/gaudio/vs1053
parenta69849177d6e7d396ea36a8160428e327811729b (diff)
downloaduGFX-c5a86757bd8309027d50f82d8947250c8e1197e6.tar.gz
uGFX-c5a86757bd8309027d50f82d8947250c8e1197e6.tar.bz2
uGFX-c5a86757bd8309027d50f82d8947250c8e1197e6.zip
Make all include paths in ugfx relative.
The only include path now needed is for drivers (in particular GDISP drivers)
Diffstat (limited to 'drivers/gaudio/vs1053')
-rw-r--r--drivers/gaudio/vs1053/driver.mk7
-rw-r--r--drivers/gaudio/vs1053/gaudio_play_vs1053.c (renamed from drivers/gaudio/vs1053/gaudio_play_lld.c)4
2 files changed, 3 insertions, 8 deletions
diff --git a/drivers/gaudio/vs1053/driver.mk b/drivers/gaudio/vs1053/driver.mk
index faf92852..3dfb3b3d 100644
--- a/drivers/gaudio/vs1053/driver.mk
+++ b/drivers/gaudio/vs1053/driver.mk
@@ -1,7 +1,2 @@
-# List the required driver.
-GFXSRC += $(GFXLIB)/drivers/gaudio/vs1053/gaudio_play_lld.c
-
-# Required include directories
GFXINC += $(GFXLIB)/drivers/gaudio/vs1053
-
-#GFXDEFS += -DGFX_USE_GTIMER=GFX_USE_GAUDIO
+GFXSRC += $(GFXLIB)/drivers/gaudio/vs1053/gaudio_play_vs1053.c
diff --git a/drivers/gaudio/vs1053/gaudio_play_lld.c b/drivers/gaudio/vs1053/gaudio_play_vs1053.c
index 24c5a176..2aab288c 100644
--- a/drivers/gaudio/vs1053/gaudio_play_lld.c
+++ b/drivers/gaudio/vs1053/gaudio_play_vs1053.c
@@ -10,10 +10,10 @@
#if GFX_USE_GAUDIO && GAUDIO_NEED_PLAY
/* Include the driver defines */
-#include "src/gaudio/gaudio_driver_play.h"
+#include "../../../src/gaudio/gaudio_driver_play.h"
/* Include the vs1053 registers */
-#include "drivers/gaudio/vs1053/vs1053.h"
+#include "vs1053.h"
/* Include the board interface */
#include "gaudio_play_board.h"